LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices



Reply
 
Search this Thread
Old 05-02-2008, 09:50 AM   #1
BlueInkAlchemist
Member
 
Registered: Apr 2008
Location: City of Brotherly Love
Distribution: Ubuntu 10.04 Lucid Lynx
Posts: 49

Rep: Reputation: 15
World of Warcraft on Ubuntu Hardy not loading TOS/EULA/login


I'm running Wine 0.9.59 on my laptop with Ubuntu 'Hardy' 8.04, and I've installed and patched World of Warcraft. I got the initial graphics problems resolved, but now when the game loads, I'm not seeing the TOS or EULA on the initial login screen (which does not load past the starting graphic of the Dark Portal & playing the theme music). I've changed the Config.wtf file and removed references to the TOS and EULA in an attempt to bypass this, but no dice there.

Any suggestions how to resolve this? Thanks in advance.

EDIT: And, this is a minor thing, but the opening cinematic does not display video. I just hear Illidan being emo.

Last edited by BlueInkAlchemist; 05-02-2008 at 09:55 AM. Reason: Opening cinematic problem as well
 
Old 05-10-2008, 03:46 AM   #2
justcallmejim
Member
 
Registered: Oct 2006
Location: Manhattan, Montana, USA
Distribution: Arch Linux
Posts: 48

Rep: Reputation: 15
Try deleting RunOnce.wtf from your WTF folder and then edit your Config.wtf file so that it has:
Code:
SET readTOS "1"
SET readEULA "1"
 
Old 05-11-2008, 12:06 AM   #3
BlueInkAlchemist
Member
 
Registered: Apr 2008
Location: City of Brotherly Love
Distribution: Ubuntu 10.04 Lucid Lynx
Posts: 49

Original Poster
Rep: Reputation: 15
I made some modifications, including that one, and got past the login screen. However, the background animation (the Dark Portal) didn't load. Nor did any of my characters or in-game graphics other than the UI. So, I'm able to select my characters and enter the game, but I can't see any toons, buildings, or landscape. All I saw was the gradient for the atmosphere.

Here's my config.wtf:

Code:
SET locale "enUS"
SET coresDetected "1"
SET hwDetect "0"
SET gxWindow "1"
SET gxApi "OpenGL"
SET gxColorBits "24"
SET gxDepthBits "24"
SET gxResolution "1024x768"
SET gxRefresh "60"
SET gxMultisampleQuality "0.000000"
SET gxFixLag "0"
SET videoOptionsVersion "1"
SET pixelShaders "1"
SET movie "0"
SET readTOS "1"
SET readEULA "1"
SET ffxGlow "0"
SET ffxDeath "0"
SET DesktopGamma "1"
SET expansionMovie "0"
SET showToolsUI "1"
SET Sound_OutputDriverName "System Default"
SET realmList "us.logon.worldofwarcraft.com"
SET patchlist "us.version.worldofwarcraft.com"
SET SmallCull "0.040000"
SET DistCull "500.000000"
SET farclip "500.000000"
SET specular "1"
SET particleDensity "1.000000"
SET spellEffectLevel "6"
SET groundEffectDensity "24"
SET lastCharacterIndex "1"
SET Sound_VoiceChatInputDriverName "System Default"
SET Sound_VoiceChatOutputDriverName "System Default"
SET realmName "Farstriders"
SET cameraPitchMoveSpeed "90"
SET cameraPitchSmoothSpeed "45"
SET gameTip "1"
 
Old 05-12-2008, 04:49 AM   #4
justcallmejim
Member
 
Registered: Oct 2006
Location: Manhattan, Montana, USA
Distribution: Arch Linux
Posts: 48

Rep: Reputation: 15
I suspect something wrong with your GL installation. What graphics card do you have? Hopefully its by Nvidia; they currently provide the only graphics solution for Linux that I have any confidence in.

Does glxgears work? does glxinfo say "direct rendering: Yes"?

Turn off compiz (or variants of it) if you have it installed as it has been known to break or cripple GL.
 
Old 05-24-2008, 01:23 PM   #5
Zeusz3
LQ Newbie
 
Registered: May 2008
Distribution: Debian 4.0
Posts: 17

Rep: Reputation: 0
hello
i have ATI graphics card and my glxinfo returns bash: glxinfo:command not found!!
is there anything i can do please?
 
Old 05-25-2008, 01:24 AM   #6
BlueInkAlchemist
Member
 
Registered: Apr 2008
Location: City of Brotherly Love
Distribution: Ubuntu 10.04 Lucid Lynx
Posts: 49

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Zeusz3 View Post
hello
i have ATI graphics card and my glxinfo returns bash: glxinfo:command not found!!
is there anything i can do please?
Make sure you have the latest drivers for your gfx as well as the latest Wine on your system. I got mine working after updating Wine.
 
Old 05-26-2008, 07:29 PM   #7
justcallmejim
Member
 
Registered: Oct 2006
Location: Manhattan, Montana, USA
Distribution: Arch Linux
Posts: 48

Rep: Reputation: 15
Quote:
Originally Posted by Zeusz3 View Post
hello
i have ATI graphics card and my glxinfo returns bash: glxinfo:command not found!!
is there anything i can do please?
Sorry, fglrxinfo for ATI.
 
Old 06-13-2008, 07:33 AM   #8
Zeusz3
LQ Newbie
 
Registered: May 2008
Distribution: Debian 4.0
Posts: 17

Rep: Reputation: 0
here is what i get as a return for fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 2600 XT
OpenGL version string: 2.1.7537 Release

so i suppose i got the vga driver installed


but how can i check which version of wine i have?
thank you
 
Old 06-14-2008, 03:18 PM   #9
justcallmejim
Member
 
Registered: Oct 2006
Location: Manhattan, Montana, USA
Distribution: Arch Linux
Posts: 48

Rep: Reputation: 15
wine --version will tell you what version of Wine you have.

If it says wine-1.0-rc5, you are running the very latest as of the time of this writing. If your wine says Wine-0.9.58 or less you have an old version of Wine and I'd recommend upgrading. Newer versions of Wine almost always work better than older versions, when it doesn't work better it tends to be application specific and problems fixed within a version or two (they work hard to prevent and overcome regressions). At any rate the 1.0 release candidates are quite good and worth upgrading to. Wine 1.0 is set to be out very soon (within a week if things go as planned).
 
Old 07-04-2008, 11:32 PM   #10
BlueInkAlchemist
Member
 
Registered: Apr 2008
Location: City of Brotherly Love
Distribution: Ubuntu 10.04 Lucid Lynx
Posts: 49

Original Poster
Rep: Reputation: 15
Long time no see, folks. Since updating Wine, WoW and various other things, WoW has stopped working properly. After selecting "Play" from the opening window, the entire display turns to blocks and makes the interface practically impossible to navigate, even after I manage to leave the game. I've updated my ATI drivers:

Code:
$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON 9600/9700 Series
OpenGL version string: 2.1.7659 Release
I've tried several modifications to my WTF file, including deleting it altogether and letting WoW rebuild it, but I keep running into the same problem. It's only fixed when I reboot my system.
 
  


Reply

Tags
ubuntu, warcraft, wine


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: World of Warcraft in Ubuntu -- the easysauce way LXer Syndicated Linux News 0 03-18-2008 10:20 PM
PlaneShift Freezes at "Loading World" section immediately after login Person_1873 Linux - Games 1 12-04-2007 04:23 PM
World of warcraft, can it, and how? Krukur Linux - Games 14 01-24-2007 04:22 AM
World of Warcraft Sticktendo Linux - Games 7 02-04-2005 03:55 PM
World of Warcraft virii Linux - Games 12 02-03-2005 08:36 PM


All times are GMT -5. The time now is 10:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration