LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 03-23-2004, 12:34 AM   #1
jlsain
LQ Newbie
 
Registered: Mar 2004
Posts: 6

Rep: Reputation: 0
Question UT2004 Full Version Error after install... HELP!


I just installed the game on Fedora Core. After installing while logged in as root, I got to run the game, and get this error :

Xlib: extension "XFree86-DRI" missing on display ":0.0".
WARNING: ALC_EXT_capture is subject to change!

Then the screen blinks...

I have a 128mb DDR Ram NVidia GeForce PCI Video Card in my PC.

I then tried to log out, and back in as a regular user, thinking the XFree86 part had something to do with it (ie, cant run certain screensavers as root, etc.)

Any help at all guys?

Thanks,
Josh
 
Old 03-24-2004, 08:51 AM   #2
cb_linus
Member
 
Registered: Dec 2003
Location: UK
Distribution: Gentoo
Posts: 81

Rep: Reputation: 15
Sorry to jump on your thread but I'm hoping the solution will be the same for both of us - I get a similar problem with Mandrake 10 on the demo version, splash screen loads up, then the screen goes black as if it's swapping into full-screen or whatever, then just exits/dissapears. This is what I get when I run from a shell.

[chris@localhost ut2004demo]$ sh ut2004demo
Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".
Xlib: extension "XFree86-DRI" missing on display ":0.0".
Either GL_EXT_bgra or glDrawRangeElements not supported- bailing out.

History:

Exiting due to error
[chris@localhost ut2004demo]$

Graphics card is GForce FX 5200. I had (since I uninstalled) a similar problem with ut2003 (full version) but not with Mandrake 9.2.

Could this be an issue with newer x builds or something? (I noticed in the Neverwinter Nights forum there is an issue so it seems a reasonable guess).
 
Old 03-24-2004, 01:56 PM   #3
huibert.alblas
Member
 
Registered: Jan 2004
Location: Duesseldorf /Germany
Distribution: Gentoo amd64 / Debian
Posts: 226

Rep: Reputation: 30
Drivers, boys

Hi,

dont worry about the Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0". error,
it is no problem.

The other error indicates that you dont have the (latest) NVidia drivers installed.
Go to their homepage run the installer,
change your /etc/XF86config[-4] to:

Driver "nvidia"

If this didn't help,
you could be caught offguard by the TLS install bug.

Look for a tls directory under /usr/lib and /usr/X11R6/lib and (re-)move it,
under modern glib versions these libs blocks your card.

DRI is not used with the Nvidia drivers, because Nvidia provides their own
Direct Access Methods.

Hope it helped,
I'm back to playing ut2004

(Debian sarge, Nvidia drivers Kernel 2.6.3 :-)

(reply if problems persists)
 
Old 03-24-2004, 03:06 PM   #4
cb_linus
Member
 
Registered: Dec 2003
Location: UK
Distribution: Gentoo
Posts: 81

Rep: Reputation: 15
Removing tls in /usr/X11R6/lib just resulted in a segmentation fault for both ut2004 and NWN - removing the folder in usr/lib didn't seem to have any adverse affects (I think removing it is supposed to make the framerate of NWN increase ).

The problem is, for me, is I'm using the default nvidia driver that came with Mandrake 10, and whenever I try to replace it with the most recent I get some error like 'can't compile package from source' or something (never happened in Mandrake 9.2, even with the same driver) and can't use startx without crashing(?) back to runlevel 3 (command-line). XF86Config-4 seems to be configured correctly (no need to rename nv to nvidia since nvidia seems to be the default).

Everythime I quit NWN and return to the console I see the message:

Xlib: extension "XFree86-DRI" missing on display ":0.0".

The same as I'm getting with UT2004 - although actually has extra information:

Xlib: extension "XFree86-DRI" missing on display ":0.0".
Either GL_EXT_bgra or glDrawRangeElements not supported- bailing out.

History:

Exiting due to error

May be a graphics card problem for me, even though it recognises I'm using a geforce fx card I no longer get the option to 'enable shiny water' in NWN.
 
Old 03-25-2004, 01:09 AM   #5
huibert.alblas
Member
 
Registered: Jan 2004
Location: Duesseldorf /Germany
Distribution: Gentoo amd64 / Debian
Posts: 226

Rep: Reputation: 30
NV and NIVIDIA in the driver section

>
>[QUOTE]Originally posted by cb_linus
>[B]Removing tls in /usr/X11R6/lib just resulted in a segmentation fault for
>both ut2004 and NWN - removing the folder in usr/lib didn't seem to have
>any adverse affects (I think removing it is supposed to make the framerate
>of NWN increase ).

The TLS is a strange thing,
I have not completely figured it out.
If you have the nvidia driver installed (which you have not
as far as I can tell) the tls stuff stands in the way
for some games/apps.

I you use the XFree.org nv driver you _need_ TLS ........



>The problem is, for me, is I'm using the default nvidia driver that came with
>Mandrake 10, and whenever I try to replace it with the most recent I get
>some error like 'can't compile package from source' or something (never
>happened in Mandrake 9.2, even with the same driver) and can't use startx
>without crashing(?) back to runlevel 3 (command-line). XF86Config-4
>seem to be configured correctly (no need to rename nv to nvidia since
>vidia seems to be the default).

I don't know if Mandrake has the nvidia drivers,
many distros have a small script which downloads
and installs the drivers on your system.

To compile the package from source you need to have the
Kernel-Headers-2.XX.XX or the Kernel-Source-2.XX.XX package
installed.
The XX should match the version of your running kernel exactly:
to find out your kernel version: "uname -a" is the command.

Use following command to find out if you
have NVidia "all the way" :-)

glxinfo | grep vendor

Here 3 lines show up (for me at work

server glx vendor string: SGI
client glx vendor string: SGI
OpenGL vendor string: Mesa project: www.mesa3d.org


for me at home :

server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

So, at work; no UT for me (unless using Software mode :-}
but at home it rocks.




>Everythime I quit NWN and return to the console I see the message:
>
> Xlib: extension "XFree86-DRI" missing on display ":0.0".
>
>The same as I'm getting with UT2004 - although actually has extra >information:
>
> Xlib: extension "XFree86-DRI" missing on display ":0.0".
> Either GL_EXT_bgra or glDrawRangeElements not supported- bailing out.

I'm confused that you are able to play NeverWinterNights,
maybe UT requires a feature (GL_EXT_bgra) which NWN doesnt.

PLease check your /etc/XF86config for the nvidia driver,
and look at glxinfo (rinse, repeat .-)

Have Fun
 
Old 03-25-2004, 05:17 PM   #6
cb_linus
Member
 
Registered: Dec 2003
Location: UK
Distribution: Gentoo
Posts: 81

Rep: Reputation: 15
glx info:

Xlib: extension "XFree86-DRI" missing on display ":0.0".
server glx vendor string: NVIDIA Corporation
client glx vendor string: SGI
OpenGL vendor string: NVIDIA Corporation

I couldn't find kernel headers or source anywhere (either already installed or on the cds).

Nvidia part of my xf86config-4 reads:

Section "Device"
Identifier "device1"
VendorName "NVidia"
BoardName "NVIDIA GeForce FX (generic)"
Driver "nvidia"
Option "DPMS"
Option "IgnoreEDID" "1"
EndSection

When I run a test on winex, I have support for '3d rendering speed' but not for 'OpenGl Direct rendering'.

Gonna try once more to install nvidia drivers
 
Old 03-25-2004, 05:30 PM   #7
cb_linus
Member
 
Registered: Dec 2003
Location: UK
Distribution: Gentoo
Posts: 81

Rep: Reputation: 15
Nevermind

Turns out I didn't have kernel-source-2.6.3-4.mdk installed (I did a search for source thanks to ur post pankrat and installed it )

Once I did this, the latest nvidia drivers where able to instal / compile from init 3

glxinfo | grep vendor now results with:

server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

Woohoo, thanks everyone for ur help

Since it wasn't my post to begin with, I wonder, jlsain, if u've fixed ur problem yet? [edit: u should post if not]

[edit: I haven't deleted any tls directories yet (after a fresh install, will probably try later & post if any problems, I've back-ups of each tls directory of course ]

Last edited by cb_linus; 03-25-2004 at 05:33 PM.
 
Old 03-25-2004, 11:05 PM   #8
Pwnz3r
Member
 
Registered: Jan 2004
Location: Lancaster, OH
Distribution: Gentoo
Posts: 393

Rep: Reputation: 30
It's great how I can build the drivers from any runlevel in Gentoo. Anyway, I personally had no problems getting the game going after solving a major HDD problem. It seems that a lot of people don't know that they need the NVIDIA drivers, not even people running Windoze.

I'm not sure how the game will do on a NVidia GeForce PCI Video Card with only 128mb of RAM, because that seems to me like a machine that would render the game unplayable. Works great for me though at this point, even though it crashes out sometimes. Much better than the way the Windows version does it though. It crashed on my bro a little bit ago, only it also took Windows down with it and which caused him to see the infamous blue screen and Windows rebooted with a major error. For me it just closes out and I can either load it up again, or continue on with business as usual.

Anyway, if you people need anymore help I'll be here because I know how great the game is and how much better it is when you're able to play it. I had to go without it for a few days due to an HDD error for a few days after getting it so....

For all that might have no idea, you need to get the sources for your kernel extract them to /usr/src and make a symlink to them called /usr/src/linux in order to properly compile the nvidia drivers. Mandrake seems to like not giving out the kernel sources in their distro.

If you're not sure which kernel you have, open a terminal as any user and type uname -r. Hope this little bit helps anyone who's still stuck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Full server (terminal) crash on UT2004 ucc-bin usage Diademed Linux - Software 3 09-05-2005 11:24 PM
klogd - how to use full version sceadu Linux - General 0 04-22-2005 09:16 AM
Trying to install ettercap: error with libnet:wrong version?? Baix Linux - Newbie 1 02-22-2005 04:34 PM
Full UT2004 help with sound JROCK1980 Linux - Games 6 04-07-2004 11:12 AM
UT2004 DVD version enragedchip Linux - Games 7 04-05-2004 10:25 AM


All times are GMT -5. The time now is 04:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration