LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 03-15-2004, 08:24 PM   #1
Renegade498
LQ Newbie
 
Registered: Mar 2004
Distribution: Debian
Posts: 13

Rep: Reputation: 0
UT2004 Error


Just recently I downloaded the Unreal Tournament 2004 Demo for Linux. Uncompressing it was relatively smooth, but when I tried to run the program, I got this error message:

Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".
Either GL_EXT_bgra or glDrawRangeElements not supported- bailing out.

History:

Exiting due to error




I tried to look for solutions online, but I didn't find anything that helped me fix this error.

I am currently running Debian 2.4.24
I'm using a NVIDIA GeForce 4 MX 440 128MB as my video card.
I also have 512 RAM.

At this point, the only other option that I can think of is to update my video card driver. However, all other graphic intensive programs on my computer runs fine with the current drivers. However, if I do the update and if that doesn't work, I really don't know what to do next. Any suggestions are appreciated, and thanks in advance.
 
Old 03-16-2004, 08:22 AM   #2
dbauder
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware-Current
Posts: 12

Rep: Reputation: 0
Hmm...I sorry don't have an exact fix for your problem, but I do know that the first line: Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0" is harmless, I think it's a feature not found in XFree86 and is not needed, so that line can be ignored. That narrows your problem down to the 2nd line of your error message.

Obvious things to check are are you using the latest Nvidia Linux driver from their website and not the builtin XFree86 driver nv? Is GLX enabled? Can you play other OpenGL games/apps with no problems? Sorry I don't have more specific help.
 
Old 03-16-2004, 11:44 AM   #3
Renegade498
LQ Newbie
 
Registered: Mar 2004
Distribution: Debian
Posts: 13

Original Poster
Rep: Reputation: 0
No, i do not have the current Nvidia drivers, and I should probably get that next. And i probably have the builtin XFree86 drivers right now. I asked someone else about this problem, he told me to enable GLX module in the XFree86, and to make dri GLcore disabled. As far as I know, you both agree that the GLX has to be enabled, but unfortunately I have absolutely no clue how to do this. =) I'm about to search online on how to configure this, but if you can give me some input on how to enable the GLX on XFree86, I'd appreciate it. Thanks.

PS: I have not tried any other OpenGL games on Linux with my current set up yet.
 
Old 03-16-2004, 12:35 PM   #4
funkmasterdb
LQ Newbie
 
Registered: Mar 2004
Location: Philadelphia, PA
Distribution: Slackware-Current
Posts: 8

Rep: Reputation: 0
The builtin driver with XFree86, which is what you are using does not provide and 3D acceleration, which is what the problem is.

If you go to nvidia's website and grab the latest Nvidia driver here:
http://www.nvidia.com/object/linux_d..._1.0-5336.html

Follow the instructions on that page and in the README and you should be on your way. Make sure you have your kernel's source tree, as it is needed for the Nvidia installer to build the kernel driver module.
 
Old 03-16-2004, 07:00 PM   #5
Renegade498
LQ Newbie
 
Registered: Mar 2004
Distribution: Debian
Posts: 13

Original Poster
Rep: Reputation: 0
I finally got it to work. I basically had to download the NVidia drivers and configure the XFree86 in order for it to work. I got the NVidia drivers as debian packages, which made downloading them easy. I got these three files:

nvidia-kernel-common
nvidia-glx
nvidia-kernel-source

I looked at the README and did what it told me to do. Then, I went to modconf and installed the NVidia mod. Afterwards, I went to XFree86 Config and configured things a little bit. At first it was pointing to the generic video drivers, but I told it to point to nvidia instead. Afterwards, I made sure glx was enabled, and proceeded to disable dri and GLcore. After that was done, I restarted X, and tried tunning it again. This time, it worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do i fix this Minor ut2004 error? TomCollins Slackware 2 10-07-2004 09:46 PM
UT2004 error causing random quiting HenchmenResourc Linux - Games 2 07-09-2004 04:36 PM
ut2004 error SuperCoolAl Linux - Games 3 06-14-2004 07:04 AM
UT2004 Full Version Error after install... HELP! jlsain Linux - Games 7 03-25-2004 11:05 PM
Ut2004 (retail) error. Minxit Linux - Games 6 03-16-2004 11:36 PM


All times are GMT -5. The time now is 11:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration