LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 01-20-2004, 07:04 PM   #1
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Rep: Reputation: 30
UT2003 persistant mount error!


I use mandrake 9.2 and i tried 2 install ut2003 but i get the "please mount the xx cd rom" all the time. I've searched the site but i couldn't get the game 2 work whatever i did.

PLEASE SOMEONE HELP ME WITH THIS!!!!

I AM TRYING TO INSTALL THE GAME FROM 11:30PM AND HERE IT IS 3 IN THE MORNING!

I WOULD LIKE SOMEONE HOW WAS THE SAM LINUX DISTRO AS I (MANDRAKE 9.2) TO WRITE DOWN THE EXACT STEPS ON HOW 2 INSTALL UT2003 !!!!!

Thanks guys!!

PS My fstab is :

"

/dev/hda5 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
none /mnt/cdrom supermount dev=/dev/scd0,fs=iso9660,exec,ro,--,user,suid,iocharset=iso8859-7,dev 0 0
none /mnt/cdrom2 supermount dev=/dev/hdd,fs=iso9660,exec,ro,--,user,suid,dev,iocharset=iso8859-7 0 0
/dev/fd0 /mnt/floppy auto codepage=869,noauto,nodev,user,iocharset=iso8859-7,sync,nosuid,unhide,umask=0 0 0
/dev/hda1 /mnt/win_c vfat umask=0,codepage=869,iocharset=iso8859-7 0 0
/dev/hdb5 /mnt/win_c2 vfat umask=0,codepage=869,iocharset=iso8859-7 0 0
/dev/hda6 /mnt/win_d ntfs umask=0,ro,iocharset=iso8859-7 0 0
none /proc proc defaults 0 0
/dev/hda4 swap swap defaults 0 0

"
 
Old 01-20-2004, 07:14 PM   #2
Nis
Member
 
Registered: Jul 2003
Location: Virginia
Distribution: Ubuntu Hoary (5.04)
Posts: 550

Rep: Reputation: 31
First, are you installing the Linux version of UT2003 or are you trying to install through WineX?
Second, if you're installing the Linux version, are you getting stuck where it asks you for disk 1 (maybe some other number since the installer uses different numbers than what is printed on the disks)?
Lastly, are you running the install script from the cdrom folder? If so back up to the folder above cdrom and run the installer with 'sh cdrom/linux_setup.sh' or whatever the installer is called. It's been awhile since I've installed UT2003 but I read that many people wondered how to change disks during the install when they couldn't unmount the cdrom drive.
 
Old 01-20-2004, 07:16 PM   #3
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Original Poster
Rep: Reputation: 30
I am installing ut2003 for linux

I've copied the linux_installer.sh(from the 3rd cd) to my home/user folder and i ran it from there.

Plz help me!!
 
Old 01-20-2004, 07:24 PM   #4
Nis
Member
 
Registered: Jul 2003
Location: Virginia
Distribution: Ubuntu Hoary (5.04)
Posts: 550

Rep: Reputation: 31
That's your problem. Dont copy linux_installer.sh from the cd but run it from the cd. As root:
'sh /mnt/cdrom/linux_installer.sh' where /mnt/cdrom is where your cdrom is mounted.
It should ask a few questions like where you want it installed and such.
When it asks for you to change CDs, type at a console:
'eject /mnt/cdrom' * Change CDs *
'mount /mnt/cdrom'

Like I said before, the installer will ask for a certain CD but the CDs are printed differently. You should put them in in this order: CD 3 (the one with linux_installer.sh), CD 1, CD 2, and maybe CD 3 again.
 
Old 01-20-2004, 07:31 PM   #5
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Just did that but it didn't work!

Here is what i got

"

[george@localhost george]$ su root
Password:
[root@localhost george]# sh /mnt/cdrom2/linux_installer.sh
Copying to a temporary location...
Verifying archive integrity... All good.
Uncompressing Unreal Tournament 2003 for GNU/Linux 2107......................................................................

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)
mount: /dev/fd0 is not a valid block device
mount: /dev/fd0 is not a valid block device
mount: /dev/fd0 is not a valid block device
mount: /dev/fd0 is not a valid block device
mount: /dev/fd0 is not a valid block device
mount: /dev/fd0 is not a valid block device
mount: /dev/fd0 is not a valid block device

"
(of course before the "mount: /dev .... the installer popped and told me where 2 install the game accepted and click begin)

I would like to say that i would like someone who uses mandrake 9.2 and have succesfully installed the game to help me step by step cause i am doin something wrong !!

Last edited by Braveheart1980; 01-20-2004 at 07:33 PM.
 
Old 01-20-2004, 07:41 PM   #6
Nis
Member
 
Registered: Jul 2003
Location: Virginia
Distribution: Ubuntu Hoary (5.04)
Posts: 550

Rep: Reputation: 31
Okay, go here for detailed instructions for Mandrake users.
 
Old 01-21-2004, 02:26 AM   #7
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Thans Nis! I'll check that out when i get back home in a couple of hours.Hope it helps!
 
Old 01-21-2004, 05:14 AM   #8
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Original Poster
Rep: Reputation: 30
It didn't work!!!

Damn!!

How can i install this great game in Linux???????????????????????????
 
Old 01-21-2004, 06:50 AM   #9
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Here is what i did step by step :

(1) Disabled supermount through MCC

(2) Rebooted

(3) mounted the 3rd cd and copied linux_installer.sh to my /home/user/ dirctory . After that i umounted the drive and inserted cd1 ( play disk ) without mounting it .

(4) opened a terminal , su root , and wrote " export SETUP_CDROM=/mnt/cdrom2 "

(5) ./linux_installer.sh . I get this screen :
"
[root@localhost george]# ./linux_installer.sh
Copying to a temporary location...
Verifying archive integrity... All good.
Uncompressing Unreal Tournament 2003 for GNU/Linux 2107......................................................................

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)
Mounted device /dev/hdd
mount: /dev/fd0 is not a valid block device

"

(6) choosed directory and clicked begin

(7) The installer works ok for a few seconds but afterwards it says (under base install)

" extras/ip_passthrough.pl " and it does nothing more . No hd action no cd reading nothing.

I have one dvd rom (plextor) mounted @ /mnt/cdrom2 and one cd recorder (mounted @ /mnt/cdrom) . My new fstab (after disabling supermount) is :

"
/dev/hda5 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
none /mnt/cdrom supermount dev=/dev/scd0,fs=iso9660,exec,ro,--,user,noauto,iocharset=iso8859-7,dev 0 0
/dev/hdd /mnt/cdrom2 iso9660 user,noauto,iocharset=iso8859-7,dev,ro 0 0
/dev/fd0 /mnt/floppy auto codepage=869,noauto,nodev,user,iocharset=iso8859-7,sync,nosuid,unhide,umask=0 0 0
/dev/hda1 /mnt/win_c vfat umask=0,codepage=869,iocharset=iso8859-7 0 0
/dev/hdb5 /mnt/win_c2 vfat umask=0,codepage=869,iocharset=iso8859-7 0 0
/dev/hda6 /mnt/win_d ntfs umask=0,ro,iocharset=iso8859-7 0 0
none /proc proc defaults 0 0
/dev/hda4 swap swap defaults 0 0
"

Plese someone help me ! It is really embarassing for me not 2 be able to play this great game!!
 
Old 01-21-2004, 06:58 AM   #10
Nis
Member
 
Registered: Jul 2003
Location: Virginia
Distribution: Ubuntu Hoary (5.04)
Posts: 550

Rep: Reputation: 31
Do you have a floppy drive? /dev/fd0 is the usually device node for floppy drives but it might be diffrent on your system, e.g. /dev/floppy/fd0, maybe. Try removing
Code:
/dev/fd0 /mnt/floppy auto codepage=869,noauto,nodev,user,iocharset=iso8859-7,sync,nosuid,unhide,umask=0 0 0
from your fstab and doing the installer again.
 
Old 01-21-2004, 07:14 AM   #11
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Original Poster
Rep: Reputation: 30
yes i do have a floppy. I'll try removing this line from fstab.

thanx anyway Nis!

Last edited by Braveheart1980; 01-21-2004 at 07:16 AM.
 
Old 01-21-2004, 07:23 AM   #12
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Done that but it still stops @ the same point!!

I've installed the game in winxp so it works?

What could it be??
 
Old 01-21-2004, 07:25 AM   #13
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Original Poster
Rep: Reputation: 30
When i quit the installation (cancel) and then try to unmount the cdrom here is what i get :
"
[root@localhost george]# umount /mnt/cdrom2
umount: /mnt/cdrom2: device is busy
[root@localhost george]#
"

When i try to eject the cd :
"
[root@localhost george]# eject /mnt/cdrom2
umount: /mnt/cdrom2: device is busy
eject: unmount of `/dev/ide/host0/bus1/target1/lun0/cd' failed
[root@localhost george]#
"

Any clues?

Last edited by Braveheart1980; 01-21-2004 at 07:26 AM.
 
Old 01-21-2004, 07:40 AM   #14
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Found something also interesting:

(1) Before running the installer i can mount / unmount the cdrom.After running the installer i cannot

(2) I inserted the 2nd cd in my drive , unmounted it , ran the installer and it still stops @ the same point. So i understand that it does not even read the cd !!!!
 
Old 01-21-2004, 08:44 AM   #15
LavaDevil94
Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 46
Gtk warnings? maybe its because you dont have gtk installed, or its too old. maybe you could check your rpm database and see if its installed? if not, install it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ut2003 error iLLuSionZ Linux - Games 11 06-25-2004 08:48 PM
How to make mount --bind persistant linuxnube Linux - Software 1 06-10-2004 08:06 PM
persistant non fatal hardware error, help? SLaCk_KiD Linux - Hardware 5 02-08-2004 11:53 AM
UT2003 Install Error thundersdm Linux - Games 2 01-05-2004 05:53 PM
Error in starting UT2003 demo casey24601 Linux - Games 8 11-03-2003 02:21 AM


All times are GMT -5. The time now is 05:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration