LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 08-02-2004, 04:21 PM   #1
tutwabee
Member
 
Registered: Jan 2004
Location: California
Distribution: Ubuntu 10.04
Posts: 145

Rep: Reputation: 15
ut2003 glx visual problem


I have found some threads in LQ mentioning this problem but I can't seem to fix it. I tried updating my nvidia drivers and it doesn't help.

The problem is when I run Unreal Tournament 2003 or 2004 demo I get this error message:
Quote:
fcntl: Invalid argument
fcntl: Invalid argument
Couldn't set video mode: Couldn't find matching GLX visual


History:

Exiting due to error
Can someone please tell me what I am doing wrong?
 
Old 08-02-2004, 04:21 PM   #2
tutwabee
Member
 
Registered: Jan 2004
Location: California
Distribution: Ubuntu 10.04
Posts: 145

Original Poster
Rep: Reputation: 15
almost forgot

Here is my xorg.conf file if its helps any:
Quote:
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
FontPath "/etc/X11/artwiz-aleczapka-en-1.3/"
EndSection

Section "Module"
Load "glx"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "SyncMaster"
DisplaySize 380 310
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 85.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce FX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 08-25-2004, 03:16 PM   #3
Bikerpete
Member
 
Registered: Jun 2003
Location: Germany
Distribution: OpenSuSE, SLES, Debian, Ubuntu, Eisfair
Posts: 79

Rep: Reputation: 15
Re: almost forgot

Hello tutwabee and all the other tux-friends,

have you solved that problem?

I try to get UT2003 runnin´ , but after successful installation, all I get is the splash-screen and then - after a short while - the following message:

user@linux:~/bin> ut2003
fcntl: Invalid argument
fcntl: Invalid argument
Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".
OpenGL renderer relies on DXTC/S3TC support.

History:

Exiting due to error

Any idea how to solve that?
I got a ATI graphics card an I installed the newest driver from
ftp://ftp.suse.com/pub/suse/i386/sup...1/fglrx/3.11.1

Yes - I´m running Suse 9.1 ;-)

Can anybody help me ???
 
Old 08-25-2004, 07:15 PM   #4
tutwabee
Member
 
Registered: Jan 2004
Location: California
Distribution: Ubuntu 10.04
Posts: 145

Original Poster
Rep: Reputation: 15
I did solve my problem. The problem was that I hadn't added the correct items in my xorg.conf file. You need to read the instructions file for your graphics card (mine was nvidia) to see what to add.
 
Old 08-25-2004, 07:16 PM   #5
dezert_fox
LQ Newbie
 
Registered: Mar 2004
Distribution: Debian (sarge)
Posts: 23

Rep: Reputation: 15
Is the fglrx module loaded correctly? Check with lsmod.
 
Old 08-25-2004, 07:52 PM   #6
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Moved: More suitable in Games.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with GLX, ATI9000 and UT2003/4 Sim_one80 Linux - Software 1 06-13-2004 10:39 AM
GLX visual errors while starting a game w0lv3rin3 Linux - Software 0 03-07-2004 01:52 PM
video mode GLX visual? Longinus Linux - Software 6 02-22-2004 08:46 PM
damn fireGLCouldn't set video mode: Couldn't find matching GLX visual Kilka Linux - Games 0 11-27-2003 09:01 PM
ut2003--- couldn't set video mode:couldn't find matching GLX visual <h1>tux</h1> Linux - Newbie 1 08-22-2003 08:17 PM


All times are GMT -5. The time now is 10:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration