LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices



Reply
 
Search this Thread
Old 01-20-2011, 07:56 PM   #1
floopy1962
LQ Newbie
 
Registered: Jul 2010
Location: Bulgaria
Distribution: Ubuntu, Kubuntu
Posts: 25

Rep: Reputation: 0
Unhappy Trying to make shortcut to game...


So my game is Rune: Halls of Valhalla based on unreal engine and its stored in /home/user/.loki/rune/ and i have to start it from /home/user/.loki/rune/System/rune-bin
but nothing happens with double click only if i open terminal navigate to the folder and then type ./rune-bin
suo game runs but do i have to make this every time.
here's my problem i make shortcut in the menu with target /home/user/.loki/rune/System/./rune-bin but it doesn't seems to work, then i tryed to launch from terminal and here what i get:
"user@user-desktop:~$/home/user/.loki/rune/System/./rune-bin
/home/user/.loki/rune/System/./rune-bin: error while loading shared libraries: Engine.so: cannot open shared object file: No such file or directory"
the strange is that if i navigate terminal to the System folder and then type ./rune-bin the game starts
so what i missing?
i tryed also to make .desktop file and that doesn't work...
I just can't figure where is the problem
Many thanks and sorry for my english its my second language :P
 
Old 01-20-2011, 11:50 PM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 13,508

Rep: Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804
Quote:
i tryed also to make .desktop file and that doesn't work...
a desktop file should work
I do that all the time for programs with shortcuts that sit on the desktop or in Gnome menu
/Applications/Games/????

can you post the *.desktop file ?


DID you use the full path to it in the file ?
/home/user/.loki/rune/System/rune-bin or just rune-bin

is the file rune-bin executable ?
did you run " chmod +x rune-bin" on it ?
or in the GUI put a check in that check box ?

is the file path "/home/user/.loki/rune/" set ?
did you set the $PATH for this odd path ?
 
Old 01-21-2011, 05:18 AM   #3
rizzy
Member
 
Registered: Mar 2004
Distribution: Debian
Posts: 283

Rep: Reputation: 65
try ticking 'run in terminal' box when creating the shortcut
 
Old 01-21-2011, 08:53 AM   #4
floopy1962
LQ Newbie
 
Registered: Jul 2010
Location: Bulgaria
Distribution: Ubuntu, Kubuntu
Posts: 25

Original Poster
Rep: Reputation: 0
Wink

Of course i use the full path here the desktop file:
Code:
[Desktop Entry]
Comment[en_US]=Great 3th Porson Game With Vikings
Comment=Great 3th Porson Game With Vikings
Exec=/home/user/.loki/rune/System/./rune-bin
GenericName[en_US]=Online-Multiplayer 3th Porson Game
GenericName=Online-Multiplayer 3th Porson Game
Icon=
MimeType=
Name[en_US]=Rune: Halls of Valhalla
Name=Rune: Halls of Valhalla
Path=/home/user/.loki/rune/System/
StartupNotify=true
Terminal=false
TerminalOptions=
Type=Application
X-DBUS-ServiceName=
X-DBUS-StartupType=
X-KDE-SubstituteUID=false
X-KDE-Username=
X-Ubuntu-Gettext-Domain=desktop_kdebase
i can't figure what is the problem with "/home/se3n/.loki/rune/System/./rune-bin" if i navigate to folder System with dolphin and then open terminal its ok but if i navigate the whole path with terminal i get
Code:
"error while loading shared libraries: Engine.so: cannot open shared object file: No such file or directory"
so check run in terminal option doesn't help... i think this is a game bug the easiest way to make shortcut is
Code:
dolphin /home/user/.loki/rune/System/
btw thank you for the quick respond :P
 
Old 01-21-2011, 09:23 AM   #5
John VV
Guru
 
Registered: Aug 2005
Posts: 13,508

Rep: Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804Reputation: 1804
try this
in the terminal
Code:
cd /home/user/.loki/rune/System
chmod +x rune-bin
then edit the line in the desktop file
Code:
Exec=/home/user/.loki/rune/System/./rune-bin
--- to this ---
Exec=/home/user/.loki/rune/System/rune-bin
a question ?
/home/user ?????
your user name IS " user" ???
or are you just editing that from "se3n"
 
Old 01-26-2011, 12:38 AM   #6
floopy1962
LQ Newbie
 
Registered: Jul 2010
Location: Bulgaria
Distribution: Ubuntu, Kubuntu
Posts: 25

Original Poster
Rep: Reputation: 0
Question ...

that doesn't work also... i tryed everithing with "world of goo", "chicken invaders 3 & 4" and one other game... and everything works i believe that is a game bug is not a big deal glory of god that is run hov for linux now i'm trying to fix sound because there is no sound with alsa... and all new distros use alsa instead oss i tryed to install oss and the game works fine with great sound but there is no other sound no amarok no smplayer nothing but the game so i remove it and googled a little and read about alsa-oss but when i run the game with aoss (aoss ./rune-bin) there is sound but there is also delay between the sound and gameplay... sound came 5-6 after seconds i click somewere... i also tryed padsp but there is delay too... about 3-4 seconds...
Is there a way to install oss but and make it work with whole system not just the game?
Note: Do i have to move somehow the thread after i changed the subject... ?
 
Old 01-26-2011, 05:12 PM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,279

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
Like with other games, the solution is to use an
executable start script, in /usr/local/bin/ , e.g. 'start-rune.sh' :
Code:
#!/bin/sh

cd /home/user/.loki/rune/System

exec ./rune-bin
Then you can easily start the game with a launcher : Exec=start-rune.sh

..
 
Old 01-26-2011, 06:12 PM   #8
floopy1962
LQ Newbie
 
Registered: Jul 2010
Location: Bulgaria
Distribution: Ubuntu, Kubuntu
Posts: 25

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by knudfl View Post
Like with other games, the solution is to use an
executable start script, in /usr/local/bin/ , e.g. 'start-rune.sh' :
Code:
#!/bin/sh

cd /home/user/.loki/rune/System

exec ./rune-bin
Then you can easily start the game with a launcher : Exec=start-rune.sh

..
grrr...
i created the script and then one .desktop file (with the right click on kde desktop) and when i click on it...
Code:
KDEInit could not launch 'start-rune.sh'.:
Could not find 'start-rune.sh' executable.
i tryed "chmod -x" but no change... may be some other "chmod" ?... i don't know
 
Old 01-26-2011, 06:53 PM   #9
Person_1873
Member
 
Registered: Sep 2007
Location: Australia
Distribution: Arch Linux
Posts: 489

Rep: Reputation: 39
chmod -x removes the ability to execute the script, you need chmod +x
 
1 members found this post helpful.
Old 01-26-2011, 07:29 PM   #10
floopy1962
LQ Newbie
 
Registered: Jul 2010
Location: Bulgaria
Distribution: Ubuntu, Kubuntu
Posts: 25

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Person_1873 View Post
chmod -x removes the ability to execute the script, you need chmod +x
Thank you now works like a charm :P useful information for me... never hurt to learn something new solved
 
  


Reply

Tags
game, games, shortcut, shortcuts


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shortcut keys over full screen game. slimg00dy Linux - Newbie 1 10-01-2009 05:55 PM
Help me make a shortcut alaios Linux - Newbie 4 01-10-2009 09:15 AM
How do I make a shortcut to an executable? lakedude Linux - Software 3 03-10-2008 10:56 PM
How to - to how to make a shortcut on desktop rberry88 Linux - Newbie 3 09-10-2003 10:20 PM
How to make shortcut? Nicksan Linux - Software 2 06-20-2003 04:38 PM


All times are GMT -5. The time now is 01:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration