LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 05-24-2004, 06:44 AM   #1
ktvoelker
LQ Newbie
 
Registered: May 2004
Location: Wisconsin, USA
Distribution: Debian (Sarge) and Fedora Core 3
Posts: 18

Rep: Reputation: 0
Stepmania fails attempting to find sound driver


Right now, as I'm listening to music with XMMS and hearing dings from Gaim, a strange thing is happening: Stepmania is complaining about sound drivers.

I'm running Fedora Core 1, updated to kernel 2.6.6-1.377, and the ALSA sound drivers are working just fine, with OSS emulation, in my other programs. Here's the output Stepmania generated:

StepMania 3.9 alpha 18
Log starting 2004-05-24 07:44:21
Loading window: gtk
OS: Linux ver 020606
Crash backtrace component: x86 custom backtrace
Crash lookup component: dladdr
Crash demangle component: cxa_demangle
Runtime library: glibc 2.3.2
Threads library: NPTL 0.60
Couldn't open card "hw:0" to get ID: No such file or directory
ALSA: Advanced Linux Sound Architecture Driver Version 1.0.4rc2 (Tue Mar 30 08:19:30 2004 UTC).
Couldn't load driver ALSA: dsnd_pcm_open: No such file or directory
Couldn't load driver ALSA-sw: dsnd_pcm_open: No such file or directory
Couldn't load driver OSS: RageSound_OSS: Couldn't open /dev/dsp: Device or resource busy
Language:
Theme: dance
Error: Couldn't find a sound driver that works

Any ideas would be appreciated.
 
Old 07-31-2004, 04:41 AM   #2
tarantella
LQ Newbie
 
Registered: Jul 2004
Posts: 2

Rep: Reputation: 0
"Couldn't load driver OSS: RageSound_OSS: Couldn't open /dev/dsp: Device or resource busy"
Stepmania won't start if someone else program is using sound card. So you have to quit xmms before you can start Stepmania.
 
Old 07-31-2004, 12:34 PM   #3
hbbtstar
Member
 
Registered: Aug 2003
Posts: 74

Rep: Reputation: 15
I have the same problem, except I don't have anything else running which uses the sound card and it gives me this error message:

Couldn't load driver ALSA: driver unusable. Couldn't load symbol snd_pcm_forward
Couldn't load driver OSS: RageSound OSS: ALSA detected. ALSA OSS emulation is buggy; use ALSA natively.
Language:
Theme: dance
Error: Couldn't find a sound driver that works

Then it dumps me back out to the console. Neverwinter Nights also has sound, and XMMS works fine. I have SDL 1.2.7, SDL_mixer, and SDL_image, and I'm running IceWM on Mandrake 9.1.

EDIT: Problem fixed. I downloaded the latest version of ALSA and it worked fine.

Last edited by hbbtstar; 07-31-2004 at 08:38 PM.
 
Old 11-14-2004, 04:27 AM   #4
delusionner
LQ Newbie
 
Registered: May 2004
Location: Quebec
Distribution: Debian sarge
Posts: 15

Rep: Reputation: 0
hmm have the same problem but slightly different
I obtain this:

StepMania 3.9 rc1
Log starting 2004-11-14 06:26:29
Loading window: gtk
OS: Linux ver 020605
Crash backtrace component: x86 custom backtrace
Crash lookup component: dladdr
Crash demangle component: cxa_demangle
Runtime library: glibc 2.3.2
Threads library: NPTL 0.60
TLS is available
Couldn't open card "hw:0" to get ID: No such file or directory
ALSA: Advanced Linux Sound Architecture Driver Version 1.0.4rc2 (Tue Mar 30 08:19:30 2004 UTC).
Couldn't load driver ALSA: dsnd_pcm_open(hw:0): No such file or directory
Mixing 0.000000 ahead in 0 Mix() calls
Couldn't load driver ALSA-sw: dsnd_pcm_open(hw:0): No such file or directory
Mixing 0.000000 ahead in 0 Mix() calls
Couldn't load driver OSS: RageSound_OSS: ALSA detected. ALSA OSS emulation is buggy; use ALSA natively.
Language: english
Theme: default
Error: Couldn't find a sound driver that works

I use Debian with a custum 2.6.5 kernel
I should switch to ALSA but don't have time for this... :P
 
Old 11-15-2004, 07:48 AM   #5
GT_Onizuka
Member
 
Registered: Aug 2003
Location: Atlanta
Distribution: Debian, OS X
Posts: 711

Rep: Reputation: 30
A good idea would be to submit your bugs to the StepMania dev team. They use the forums on DDRManiaX to collect bugs from various users.

I recall having a problem similar to this, when I was using ALSA. The only way I got it working was to build StepMania from source, but this definitely seems like a bug to me, so I'd submit it to the dev team.
 
Old 11-18-2004, 11:02 AM   #6
delusionner
LQ Newbie
 
Registered: May 2004
Location: Quebec
Distribution: Debian sarge
Posts: 15

Rep: Reputation: 0
got it! I recently compiled kernel 2.6.9 and this time, I didn't compile alsa at all.

guess there was a conflict for having the both..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stepmania 3.9-rc3 emerge fails slithy Linux - Games 1 11-22-2005 05:32 AM
Garbled Stepmania Sound aeuzent Linux - Games 0 10-28-2005 11:52 PM
sound card for toshiba... can't find driver pgrimes Linux - Hardware 4 06-17-2004 01:23 PM
Why can't I find the correct sound driver for my laptop? DyeKid Linux - Hardware 2 05-10-2004 05:36 PM
Stepmania Sound Issues Aman9090 Linux - Games 2 02-16-2004 07:27 PM


All times are GMT -5. The time now is 01:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration