LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 06-05-2004, 01:34 PM   #1
Grisnak
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Slackware 13.37 on lappy, ubuntu on server.
Posts: 130

Rep: Reputation: 15
Soldier of fortune 2


I installed sof2 and when I wine the sof2.exe and sof2mp.exe I get the message:
OpenGL initialization Faliure. To play Soldier of Fortune II please verify that your card is OpenGL Compliant

and so on. Whyyyy?
 
Old 06-05-2004, 01:46 PM   #2
LavaDevil94
Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 46
Do you have 3D hardware acceleration properly enabled? Do glxinfo to find out.
 
Old 06-05-2004, 01:47 PM   #3
Grisnak
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Slackware 13.37 on lappy, ubuntu on server.
Posts: 130

Original Poster
Rep: Reputation: 15
name of display: :0.0
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x21 16 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x22 16 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None



Somehow this seems wrong =/
 
Old 06-05-2004, 04:39 PM   #4
proudclod
Member
 
Registered: May 2004
Distribution: Fedora Core 2
Posts: 381

Rep: Reputation: 30
You need to get OpenGL drivers for your graphics card. What do you have, a Radeon or GeForce?
 
Old 06-06-2004, 03:31 AM   #5
Grisnak
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Slackware 13.37 on lappy, ubuntu on server.
Posts: 130

Original Poster
Rep: Reputation: 15
GeForce. But the strange things is I have already installed the drivers.
 
Old 06-06-2004, 05:10 AM   #6
v00d00101
Member
 
Registered: Jun 2003
Location: UK
Distribution: Fedora 8, Centos 5.1
Posts: 480

Rep: Reputation: 30
Are you running on Fedora RC2?

If so theres a problem with nvidia drivers.

Besides that, try reinstalling the drivers.

Also post up your XF86Config/xorg.conf (/etc/X11/).
 
Old 06-08-2004, 10:19 AM   #7
Grisnak
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Slackware 13.37 on lappy, ubuntu on server.
Posts: 130

Original Poster
Rep: Reputation: 15
Heres my config file:
Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "se"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell E771p"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection



Thats it.
 
Old 06-09-2004, 03:58 PM   #8
Phorem
Member
 
Registered: Nov 2003
Location: Toronto, Canada
Distribution: Gentoo AMD64
Posts: 374

Rep: Reputation: 30
Well if you installed the nvidia drivers from the Nvidia website then the first proplem is your XF86Config.

In the Device section :


Driver "nv"

This should be......

Driver "nvidia"

Not Driver "nv"
 
Old 06-09-2004, 03:58 PM   #9
Grisnak
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Slackware 13.37 on lappy, ubuntu on server.
Posts: 130

Original Poster
Rep: Reputation: 15
K Ill try.
 
Old 06-10-2004, 10:56 AM   #10
Grisnak
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Slackware 13.37 on lappy, ubuntu on server.
Posts: 130

Original Poster
Rep: Reputation: 15
Now the multiplayer part works ok. When I try to run singleplayer I get the message:

err:virtual:map_image FATAL: Need to relocate module from addr 10000000, but there are no relocation records
wine: could not load L"C:\\Program Files\\Soldier of Fortune II - Double Helix\\SoF2.exe" as Win32 binary

Installing the gold patch doesnt work either. When I open it with wine it firstly asks me to choose language. When I do that and click ok it looks like its extracting files for maybe a second, then it goes to the next screen that asks me to close all windows programs and then click ok. When I click ok or forward or whatever it is it just freezes. And then after quite a long time it just closes down. HELP!
 
Old 06-10-2004, 12:38 PM   #11
v00d00101
Member
 
Registered: Jun 2003
Location: UK
Distribution: Fedora 8, Centos 5.1
Posts: 480

Rep: Reputation: 30
Ive never got gold patch to work yet, i had to delete the pb dirs to get it to run. I think pb notices your using some sort of hack and shuts you down. I wouldnt expect a fix, since wine isnt exactly an official method to run stuff.

Single player wont work full stop, it either doesnt load or it crashes in game after a while.

Theres advice over at frankscorner.org

But for me ive never got single player to work, nor punkbuster (but i managed to invalidate my cd key while trying ).
 
Old 06-10-2004, 12:40 PM   #12
Grisnak
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Slackware 13.37 on lappy, ubuntu on server.
Posts: 130

Original Poster
Rep: Reputation: 15
Hehe ok, thanks
 
Old 06-10-2004, 12:58 PM   #13
LavaDevil94
Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 46
Maybe you could reinstall SOF2 and run it without the gold patch? If you wanted to keep the patched multiplayer, you could copy the installation you currently have to somewhere else, install SOF2, and when you wanted to run singleplayer, use the newly installed version. If you wanted to play multiplayer, you could use the patched version. Or just try WineX .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Soldier of Fortune segfaults on KOS2 yarjar Linux - Games 0 08-07-2005 08:40 PM
punkbuster error on soldier of fortune 2 wahmed Linux - Games 3 09-01-2004 02:39 PM
Soldier of Fortune - Resolution Problem Slacker0815 Slackware 0 06-17-2004 04:23 PM
Soldier of Fortune 2 Grisnak Linux - Games 17 05-24-2004 04:21 PM
soldier of fortune 2 not working any help? citrus Linux - Games 8 03-22-2004 09:44 PM


All times are GMT -5. The time now is 03:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration