LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (http://www.linuxquestions.org/questions/linux-games-33/)
-   -   slow mouse movement when running starcraft under wine (http://www.linuxquestions.org/questions/linux-games-33/slow-mouse-movement-when-running-starcraft-under-wine-362014/)

septanla 09-10-2005 04:59 AM

slow mouse movement when running starcraft under wine
 
As stated in the title, the movement of mouse is quite slow.

before I get into the game, there is an error message:

For Windows 95:
Select "Settings - Control Panel" from the "Start" menu
Run the "System" control panel applet
Select the "Performance" tab, and press "Virtual Memory"
Use the "Let Windows manage my virtual memory..." option

For Windows NT:
Select "Settings - Control Panel" from the "Start" menu
Run the "System" control panel applet
Select the "Performance" tab
Press "Change" in "Virtual Memory" settings
Ensure that the virtual memory file is at least 32 megabytes


I press continue to start to load the game.

My system is Ubuntu with kernel: 2.6.10-5-686.

wine version: 20050310-1.1

I googled and get some threads talking about DXGrab, or DGA.
http://starcraft-wine.sourceforge.net/index_en.html
They need to modify files called 'config' and 'F86Config-4' etc.

Any ideas how to speed up the mouse?

Thanks

Septanla

vireshwali 09-15-2005 08:34 AM

well as the messages say its a memory issue.

its like the process takes a lot of CPU time and hence slow cpu shits for different processes(such as the mouse dameon).
check using top command to see whats eating cpu memory and how much is left whenu start the game.

more possily try to adjust your swap space / virtual memory more.

this should help.

septanla 09-16-2005 09:40 AM

Dear vireshwali:

I found my swap space was not mounted due to unknown reason, though my fstab has the command to mount the swap partition.

I create and swapon the partition and mount it. The warning message:

For Windows 95:
Select "Settings - Control Panel" from the "Start" menu
Run the "System" control panel applet
Select the "Performance" tab, and press "Virtual Memory"
Use the "Let Windows manage my virtual memory..." option

For Windows NT:
Select "Settings - Control Panel" from the "Start" menu
Run the "System" control panel applet
Select the "Performance" tab
Press "Change" in "Virtual Memory" settings
Ensure that the virtual memory file is at least 32 megabytes

was no longer there. But the mouse is still very slow. I copied "config" file from /usr/share/wine/skel to ~/.wine, the mouse is slow. When I change it to DXGrab='Y' in "config" file, the mouse was still slow, even worse, the sound became choppy.

It does not seem the swap space is the problem.

total used free shared buffers cached
Mem: 256676 253744 2932 0 1948 84612
-/+ buffers/cache: 167184 89492
Swap: 498920 4184 494736

Any idea?


All times are GMT -5. The time now is 09:32 AM.