LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 12-28-2003, 07:27 AM   #1
i286
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora
Posts: 24

Rep: Reputation: 15
Slow framerate in 3d


When I try to run a 3d application (tux racer for example) I get about 1 or lower frames per second.
I have Fedora core 1, AMD 1800+ and GeForce 4 with latest nVidia drivers. Should I enable hardware accerelation or something ?
 
Old 12-28-2003, 11:09 AM   #2
i286
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora
Posts: 24

Original Poster
Rep: Reputation: 15
Driver readme said that when running xdpyinfo extensions should have glx, nv-glx and nvidia-glx but I only have glx and nv-glx. Maybe that's the problem. What should I do??
 
Old 12-28-2003, 11:25 AM   #3
LavaDevil94
Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 47
get to a konsole and type glxinfo. look for a line in the output that says direct rendering: X, where X is Yes or No. if its No, then youre using software acceleration. if its yes... well, you get the idea.
 
Old 12-28-2003, 11:35 AM   #4
i286
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora
Posts: 24

Original Poster
Rep: Reputation: 15
Thanks for the reply.
Direct rendering is yes but still only 6.4fps on glxgears
 
Old 12-28-2003, 11:47 AM   #5
LavaDevil94
Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 47
i think i remember seeing a problem like yours in this faq:
http://icculus.org/lgfaq
its REALLY big, so look around alot.
 
Old 12-28-2003, 12:10 PM   #6
i286
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora
Posts: 24

Original Poster
Rep: Reputation: 15
Nope, couldn't find anything. Been searching the net for 8 hours now and getting a little tired. I don't want to go back to windows but if I can't get this work I have to.

Got this nv_check from the link file but it said my driver installation was ok. Totally out of ideas.

Last edited by i286; 12-28-2003 at 12:13 PM.
 
Old 12-29-2003, 05:14 AM   #7
i286
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora
Posts: 24

Original Poster
Rep: Reputation: 15
Ok I think it's the missing NVIDIA-GLX extension that does the problem. But what are these extensions exactly ? If anyone knows (and shares that information) I'd be really happy.
 
Old 12-29-2003, 06:54 AM   #8
i286
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora
Posts: 24

Original Poster
Rep: Reputation: 15
I think I'll post this to some other forum than games since it has very little to do with games and there aren't many readers on this section.
 
Old 12-30-2003, 11:20 AM   #9
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 35
Sounds like you could be right about the NVIDIA-GLX extension. Edit /etc/X11/XF86Config-4 and change the section named "Module". Mine looks like this:
Code:
Section "Module"
    Load        "dbe"   # Double buffer extension
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection
    Load        "type1"
    Load        "speedo"
    Load        "freetype"

# This loads the GLX module
# This is the section you will need to look at and possibly change/add to
    Load       "glx"

# This loads the DRI module
# You should have this already, since glxinfo said that direct rendering was enabled
    Load       "dri"
EndSection
Have a play. You probably have nv-glx loaded but you may need to add the line:
Code:
Load    "nvidia-glx"
or something similar.
When you've done that, restart the X server and it should (hopefully) work
Hope this helps
Guy
 
Old 01-11-2004, 11:46 AM   #10
FiveFlat
Member
 
Registered: May 2003
Location: N. California
Distribution: FC3 2.6.9
Posts: 110

Rep: Reputation: 15
glxinfo for me:
direct rendering: No

How do I change this to yes?
 
Old 01-11-2004, 01:04 PM   #11
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 35
You need the dri and glx modules loaded in the XF86Config-4 (see above). You also need the appropriate drivers enabled in your kernel. You will need DRI, and the driver that corresponds to your video card enabled.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Framerate with Radeon 9200SE drakethegreat Slackware 8 09-30-2004 07:43 PM
Rediculously slow framerate in America's Army r_jensen11 Linux - Games 7 07-06-2004 10:38 AM
Framerate Issue Bigun Linux - General 2 09-21-2003 09:39 AM
xine framerate JesusCow Linux - Software 3 08-22-2003 01:09 PM
Gears framerate RecoilUK Linux - General 1 08-30-2001 01:31 AM


All times are GMT -5. The time now is 04:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration