LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 06-15-2005, 03:40 PM   #1
morganmcdermott
LQ Newbie
 
Registered: Jun 2005
Distribution: Slackware 10.0
Posts: 14

Rep: Reputation: 0
Screen goes black with Cedega 4.3 when running Q3


Alright.. So, the screen goes black when I try to run Jedi Knight: Jedi Outcast (Q3 based) and I'm forced to restart. (Note: The main, 2d menu works fine..). I have not had the chance to test it with other games at this time, but I believe it has something to do with my video drivers. I'm running an ATI Radeon 9600XT (Yeah.. ATI has horrible issues with Linux) and Xorg 6.8.2. I'm under slackware, so I converted ATI's RPM to a TGZ then installpkg'ed it, and then went thru their make.sh and make_install.sh scripts to get the driver loaded. At this point, I ran fglrxconfig to set everything up, and it appreared to have completed successfully..

I've been getting only around 200fps with glxgears =\, and as I stated, the screen goes black when I try to run 3d apps under cedega 4.3.

Any Ideas?

Specs:
-ATI Radeon 9600XT
-Athlon processor

-Slackware 10.0
-Cedega 4.3
-Xorg 6.8.2

Thanks for your time and effort,
Morgan McDermott.
 
Old 06-15-2005, 03:48 PM   #2
Thorium
Member
 
Registered: Dec 2004
Location: USA
Distribution: Debian
Posts: 124

Rep: Reputation: 15
200 fps? Definitely sounds like you don't have 3d acceleration working, try this in the console

# glxinfo | grep rendering

If it returns no, don't think the drivers are setup right. Not familiar with getting ati cards setup on linux though sorry, but I would guess that is what is causing the cedega problems.
 
Old 06-15-2005, 04:05 PM   #3
morganmcdermott
LQ Newbie
 
Registered: Jun 2005
Distribution: Slackware 10.0
Posts: 14

Original Poster
Rep: Reputation: 0
Yeah, It returns direct rendering: No .. Could anyone assist me in figuring out what is wrong with my driver install? ^_^..

Thanks again for your time,
Morgan, Mcdermott.
 
Old 06-15-2005, 06:01 PM   #4
lowpingnoob
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3, soon DSL (DSL backwards is LSD hahahaha)
Posts: 245

Rep: Reputation: 30
Quote:
Originally posted by morganmcdermott
Yeah, It returns direct rendering: No .. Could anyone assist me in figuring out what is wrong with my driver install? ^_^..

Thanks again for your time,
Morgan, Mcdermott.
Try installing again (drivers). Sorry I cannot help more, I am a nvidia ***** all the way. (much better for linux). Sounds like you skipped a step or something like that.
 
Old 06-15-2005, 06:10 PM   #5
morganmcdermott
LQ Newbie
 
Registered: Jun 2005
Distribution: Slackware 10.0
Posts: 14

Original Poster
Rep: Reputation: 0
I've installed multiple times using multiple tutorials to no avail... I've even tried reinstalling Xorg and using dif versions of the ATI drivers >.<

I'm so tempted to go buy an Nvidia card or pop back in my Geforce3 xD.

Last edited by morganmcdermott; 06-15-2005 at 06:12 PM.
 
Old 06-15-2005, 07:18 PM   #6
morganmcdermott
LQ Newbie
 
Registered: Jun 2005
Distribution: Slackware 10.0
Posts: 14

Original Poster
Rep: Reputation: 0
Alright! I got the drivers working by enabling DRG in the fglrxconfig ... to a point.

I get about 3000fps in GLXgears, but ingame the fps are still really horrible. I'm talking about 1-2 fps .. Can't even move the mouse properly. What is this the sign of?

Thanks for your time again ^_^
Morgan McDermott
 
Old 06-15-2005, 10:12 PM   #7
lowpingnoob
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3, soon DSL (DSL backwards is LSD hahahaha)
Posts: 245

Rep: Reputation: 30
Quote:
Originally posted by morganmcdermott
Alright! I got the drivers working by enabling DRG in the fglrxconfig ... to a point.

I get about 3000fps in GLXgears, but ingame the fps are still really horrible. I'm talking about 1-2 fps .. Can't even move the mouse properly. What is this the sign of?

Thanks for your time again ^_^
Morgan McDermott
If I could have 1 huge billboard of anything in the middle of Dallas it would say:


ATI WAS HERE!
 
Old 06-15-2005, 10:17 PM   #8
lowpingnoob
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3, soon DSL (DSL backwards is LSD hahahaha)
Posts: 245

Rep: Reputation: 30
Quote:
Originally posted by lowpingnoob
If I could have 1 huge billboard of anything in the middle of Dallas it would say:


ATI WAS HERE!
really ... ATI sucks when it comes to compatiblity. My friend has a old 5200, and he popped out his horrible for linux 9800 XT Platinum (Platinum??) And put in his 5200. Anyway, across the board, he got better preformance in games (CSS 14 FPS -> 35 FPS...) in linux either horrible mobo -> video card -> distro compatibility or something......
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 11:52 AM
screen saver goes off and screen goes black Doug.Gentry Suse/Novell 2 03-26-2005 05:08 PM
Startx results in a black screen with VGA and screen errors kwosource Linux - Newbie 4 03-11-2005 02:58 PM
MDK 9.2: X freezes with a black screen or blue screen with "X cursor" Apoc Linux - Newbie 10 03-30-2004 03:38 PM
WINEX Corrupt Graohics/black screen when running games mr-tiddles Linux - Games 3 12-04-2003 03:48 AM


All times are GMT -5. The time now is 02:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration