LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (http://www.linuxquestions.org/questions/linux-games-33/)
-   -   Rocks and Diamonds 3.2.2 install problems (http://www.linuxquestions.org/questions/linux-games-33/rocks-and-diamonds-3-2-2-install-problems-484034/)

x94qvi 09-16-2006 06:59 AM

Rocks and Diamonds 3.2.2 install problems
 
Hi there!

I'm trying to install the latest version of Rocks and Diamonds 3.2.2 on my Slackware 10.2 box.

According to the website (http://www.artsoft.org/rocksndiamonds/download.html), the instructions for compiling the "SDL version" of the game are: make clean ; make SDL

And this is what I get:

Code:

gcc  main.o conf_gfx.o conf_snd.o conf_mus.o conf_hlp.o init.o config.o events.o tools.o screens.o game.o editor.o files.o tape.o cartoons.o network.o netserv.o  libgame/libgame.a game_em/game_em.a -lSDL_image -lSDL_mixer -lSDL_net -lsmpeg -L/usr/local/lib -Wl,-rpath,/usr/local/lib -lSDL -lpthread  -lm -o ../rocksndiamonds
/usr/local/lib/libsmpeg.so: undefined reference to `operator new[](unsigned)'
/usr/local/lib/libsmpeg.so: undefined reference to `operator delete(void*)'
/usr/local/lib/libsmpeg.so: undefined reference to `operator delete[](void*)'
/usr/local/lib/libsmpeg.so: undefined reference to `operator new(unsigned)'
collect2: ld returned 1 exit status
make[1]: *** [../rocksndiamonds] Error 1
make[1]: Leaving directory `/usr/local/src/rocksndiamonds-3.2.2/src'
make: *** [sdl] Error 2

I initially ran into some problems when installing a "recommended" package called smpeg-0.4.4 from source, as described at here, and I was able to do the fix described (i.e. modifying the libsmpeg.la file). But from the error message described above, I'm still running into the same sort of problem...

Prior to attempting rocksndiamdonds, I was able to successfully install SDL 1.2.11, SDL_image 1.2.5, SDL_mixer 1.2.7, SDL_net 1.2.6 from source, with no errors.

I also tried a simple "make clean ; make", (which I assumed should tell it not to use the SDL & SMPEG libs) but I got the same error message as above...

Do you know what I can do to successfully install Rocks and Diamonds from the source?

Cheers,
R


All times are GMT -5. The time now is 11:50 PM.