LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 05-12-2004, 05:50 PM   #1
furfurdemon666
Member
 
Registered: Mar 2004
Posts: 171

Rep: Reputation: 30
Quake III demo for Linux - howto adjust brightness?


I have the q3demo for Linux installed and while everything works great, the brightness adjustment option in setup is greyed out and there's no way to select it. How can I adjust the brightness and why is it greyed out in setup? The option below it is selectable, screen size I think. Hmmm...
 
Old 05-12-2004, 06:36 PM   #2
Covel
Member
 
Registered: Oct 2003
Location: Portugal
Distribution: Gentoo
Posts: 116

Rep: Reputation: 16
I have a similar problem. But my brightness ajustment option isn't greyed. It just doesn't work. Even if I set it to maximum, nothing changes. I think this has something to do with my graphics card configuration. I have an ATI Radeon 9200.

As a workaround, I set fglrx_xgamma -gamma to something higher than 1. I hope this helps.
 
Old 05-13-2004, 05:47 AM   #3
wrongman
Member
 
Registered: May 2004
Location: Italy
Distribution: Debian Unstable 64bit
Posts: 99

Rep: Reputation: 15
from the console of quake you can set

r_gamma X

where
X > 1 -> brighter
X < 1 -> darker
 
Old 05-13-2004, 12:10 PM   #4
Covel
Member
 
Registered: Oct 2003
Location: Portugal
Distribution: Gentoo
Posts: 116

Rep: Reputation: 16
Quote:
Originally posted by wrongman
from the console of quake you can set

r_gamma X

where
X > 1 -> brighter
X < 1 -> darker


That doesn't work for me. If I adjust the brightness using the quake3 brightness gauge, r_gamma value changes as it is supose to. But it doesn't get any brighter. Even after vid_restart. So I'll have to stick to the workaround for now
 
Old 05-13-2004, 04:49 PM   #5
furfurdemon666
Member
 
Registered: Mar 2004
Posts: 171

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by wrongman
from the console of quake you can set

r_gamma X

where
X > 1 -> brighter
X < 1 -> darker
Thank you, that works for me. It's nice to be able to play the demo and be able to see the entire environment now and not have to target enemies based only on where shots are coming from. ;-)
 
Old 05-14-2004, 06:57 AM   #6
v00d00101
Member
 
Registered: Jun 2003
Location: UK
Distribution: Fedora 8, Centos 5.1
Posts: 480

Rep: Reputation: 30
The problem is to do with hardware gamma settings.

These values should be changed to what i have them set as.

seta r_ext_gamma_control "1"
seta r_gamma "1.7"
seta r_ignorehwgamma "1"

Thats fairly bright, but u can up the gamma a bit more if you need.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why Quake III demo doesn't detect Voodoo 2? orbb Linux - Hardware 22 02-28-2006 03:44 PM
Quake III Demo Resolution alienzero Linux - Games 5 05-25-2004 09:22 PM
Quake III Windows on Linux Lobais Linux - Games 11 05-13-2004 12:50 PM
Quake III demo battles sound server.. help? MadCactus Linux - Software 2 11-25-2003 07:32 AM
Quake III demo anyone? linuxlah Linux - General 0 07-15-2002 05:09 AM


All times are GMT -5. The time now is 01:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration