LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 12-06-2004, 12:44 PM   #1
erick6220
LQ Newbie
 
Registered: Dec 2004
Posts: 13

Rep: Reputation: 0
Question Problems Running UT2004


Ok I am running Mandrake 10.1 I just installed UT2004Demo v3334 and the initial splash screen pops up saying Unreal Tournament 2004 Demo, but instead of loading the game it just disappears. I have no clue what it is doing, I am a newbie to linux and it took me a week just to figure out how to install it. Please help me anyone!!!!!

Intel P4 2.8C@800FSB HT
Chaintech S848P Mobo
Corsair PC3200 (512x2)
Chaintech Geforce FX 5500 256MB
 
Old 12-06-2004, 02:40 PM   #2
hamstereater
LQ Newbie
 
Registered: Aug 2003
Location: Horndean, Hants.
Distribution: OSX Tiger, XP SP2, Vista SP1
Posts: 16

Rep: Reputation: 0
Sounds like its throwing a wobbler about your graphics drivers. Do you have the NVIDIA graphics driver installed?
 
Old 12-06-2004, 03:21 PM   #3
erick6220
LQ Newbie
 
Registered: Dec 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Yeah when i installed the OS i set it for the Geforce FX drivers, is there another way to update them? I'm new to all this and just tryin to figure things out on my own has been driving me crazy. Let me know. I downloaded the new drivers from the nvidia website, but for some reason it says i have to install them from root, but my access keeps getting denied, any suggestions. OK another update to this message I think i have it figured out but i need to be able to disable x server, but i dk how to pls help

Erick

Last edited by erick6220; 12-06-2004 at 04:11 PM.
 
Old 12-06-2004, 05:24 PM   #4
WingNut
Member
 
Registered: Jun 2002
Location: Texas
Distribution: Slackware 10.1
Posts: 105

Rep: Reputation: 15
If your already logged in as root. Open a console and type:

init 3

If booting. at the LILO screen press tab or esc (don't remember which) and type:

linux 3 (if the boot menu entry says 'linux' that is. Grub should be similar.)

log in as root and install your drivers. Has to be done via console mode WITHOUT X. You may have to make the file executable like:

chmod a+x filename.foo

run a search. its hard to throw a rock at this site without hitting some sort of NVIDIA help.

Just remember to do this as root and with no X running. AND don't for get to edit the X.org file or whatever its called now. It slips my mind at present. There maybe some other things you have to do because of Mandrake.

That all sounds clear as mud to me. Hope you can gleen a little out of that.

Last edited by WingNut; 12-06-2004 at 05:27 PM.
 
Old 12-06-2004, 05:43 PM   #5
bglnelissen
Member
 
Registered: Feb 2004
Location: Utrecht Holland
Distribution: Fedora, Debian, Mandrake, OSX, OpenBSD
Posts: 76

Rep: Reputation: 15
mightbe it aint your nvidia drivers (if you see a nvidia logo at boot they are installed)
mightbe your gamesettings are too high for your monitor or graphics card.

luck

happy gaming!
 
Old 12-06-2004, 07:21 PM   #6
erick6220
LQ Newbie
 
Registered: Dec 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Well i will give it a try tomorrow evening, I don't really know how to use linux, but i tried the init 3 command took me out of the GUI into command prompt, but i couldn't get it to sh the nvidia .run file. I guess i will keep working at it and thanks for the help
 
Old 12-07-2004, 05:34 PM   #7
WingNut
Member
 
Registered: Jun 2002
Location: Texas
Distribution: Slackware 10.1
Posts: 105

Rep: Reputation: 15
Erick I remember trying to get Nvidia drivers to go for a friend under MDK 9.1 and having fits. Here is the fix and a link to that thread. I can't help but think the procedure would be similar. Let us know if it helps.

One tip. When you have the chance to enable distro provided 3d acceleration or distro provided Nvidia drivers. Don't. You will most likely wind up getting rid of it all anyway. Find whatever nvidia glx files that Mandrake throws in and ditch them. I'm sorry but I can't remember the directory.

Quote:
Ok this is a lengthy post because of file output. The new Nvidia drivers seem to be running nice and stable.

Here is what I did to get them to go:
I entered init 3 (no need to edit any files for this). I had already installed the kernel sources and I verified that binutils were installed (as per the link provided by kilgore). I then edited XF86Config-4 and made it what it should be. I went ahead and backed up the Mandrake glx stuff then removed it from its original directory. I edited /etc/modules and commented out NVdriver. I switched to KDM (I really don't think switching display managers did anything but I did it any way. The new drivers work!

I tried a little game called openuniverse that came with MDK and it renders fine at between 400 and 500 FPS.
Thread link:

http://www.linuxquestions.org/questi...hreadid=106497

Last edited by WingNut; 12-07-2004 at 05:40 PM.
 
Old 12-08-2004, 07:05 AM   #8
erick6220
LQ Newbie
 
Registered: Dec 2004
Posts: 13

Original Poster
Rep: Reputation: 0
I type in init 3 and it takes me to a login screen for the root command console. I don't know what to type to install the nvidia drivers. I tried doing the xf86config -4 but there are no nvidia drivers listed. I know when I installed the OS I selected Nvidia Geforce FX drivers from the list of video card drivers, I just don't understand why UT2004 shows the demo splash screen and disappears. I haven't done anything to the settings of the game because I can't get into the game to do anything. Can someone pls just let me know what command to type in the root console after I init 3 so i can get this installed. Thanks for all the help so far.
 
Old 12-08-2004, 07:10 AM   #9
Agizor
Member
 
Registered: Dec 2004
Posts: 62

Rep: Reputation: 15
Same thing happens to me... Exept with ATi : / ...
 
Old 12-08-2004, 07:33 AM   #10
m00t00
Member
 
Registered: Sep 2004
Distribution: Slackware 10, Gentoo
Posts: 292

Rep: Reputation: 30
Quote:
Originally posted by erick6220
I type in init 3 and it takes me to a login screen for the root command console. I don't know what to type to install the nvidia drivers. I tried doing the xf86config -4 but there are no nvidia drivers listed. I know when I installed the OS I selected Nvidia Geforce FX drivers from the list of video card drivers, I just don't understand why UT2004 shows the demo splash screen and disappears. I haven't done anything to the settings of the game because I can't get into the game to do anything. Can someone pls just let me know what command to type in the root console after I init 3 so i can get this installed. Thanks for all the help so far.
try _learning_ the command line. Its generally a Good Idea, and wont take very long to at least have a basic understanding of it. If you have to be walked through it, try searching for "nvidia" here.
 
Old 12-08-2004, 07:58 AM   #11
enigma82
Member
 
Registered: Sep 2004
Location: Fagaras, Romania
Distribution: Mandrake 10.0
Posts: 48

Rep: Reputation: 15
I know it happened to me the same thing on an ATI board and at this moment I don't know how I managed to solve it.
Try to open a console in X and type there [...]$ ut2004 (if you have the link correct) and if not try
[...]$ ./usr/local/games/ut2004

You will be presented with an error message. Please read that carefully and hopefully it will guide you to the answer. I can't remember what was the error nor how did I fixed it.

Reply to post and maybe I can help you.

good luck
 
Old 12-08-2004, 11:15 AM   #12
WingNut
Member
 
Registered: Jun 2002
Location: Texas
Distribution: Slackware 10.1
Posts: 105

Rep: Reputation: 15
OK here we go.

(TIP: the path to MDK glx may be present in you xf86config. if not issue the command: locate glx

The reason the Mandrake Nvidia drivers don't work is because....................... They don't work. Never have and until certain licenseing issue are dealt with they never will. Forget about them.

Don't forget to edit the files (as root) that I mentioned in previous posts. That Nvidia entry in that modules file proved to be a show stopper for me back then.

All of the following must be done as root.

In /etc directory find the modules file. If you see anything pertaing to Nvidia comment it out by placeing a # in front of it like:
# Nvidia

It will continue to try to load the old drivers if you don't. Find the Mandrake glx files and delete them.


After you reach runlevel 3 (init 3) and are root user navigate to the directory that holds the Nvidia driver. For me its:
cd /root/tmp

Once there you may have to make the file executible:
chmod a+x NVIDIA-Linux-x86-1.0-6629-pkg1.run

Then to install the driver:
sh NVIDIA-Linux-x86-1.0-6629-pkg1.run

Now you MUST edit your xf86config-4 file or your xorg.conf file (same thing different name). I don't know which one MDK 10 has but its located in the /etc/X11 directory.

At the top of the file look for the modules section; Your looking for glx. Yours may have a path spelled out. Listing the entire path may not be necessary. I can't remember if it made a difference and I don't see why it would. If present comment out dri like (# Load "dri"). Anyway here is my modules seciton:
Section "Module"

# This loads the DBE extension module.

Load "dbe" # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

# This loads the font modules
Load "type1"
Load "freetype"
Load "speedo"


# This loads the GLX module
Load "glx"


EndSection


Look for the "Graphics device" section. In that section look for "Driver" make sure it is followed by "nvida". Here is my Graphics Device section.
# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"
Identifier "FX 5700"

Driver "nvidia"
#VideoRam 4096
# Insert Clocks lines here if appropriate
EndSection


Save your changes and you should be done... Reboot.

(TIP: after you install a game always run it from console at first. if the game crashes it should leave the console open with error output.

to run unreal open a console as normal user and type:

ut2004

keep track of any and all errors. they make the difference when asking for specific help on this or any forum.

Somebody double check me. I don't think I left anything out.

Erick, keep us posted whether it works or not.

Last edited by WingNut; 12-08-2004 at 11:25 AM.
 
Old 12-08-2004, 11:32 AM   #13
WingNut
Member
 
Registered: Jun 2002
Location: Texas
Distribution: Slackware 10.1
Posts: 105

Rep: Reputation: 15
oh yeah. after reboot hopefully you will see the nvidia splash screen for a second or two.

to test use a game other than ut2004 to test like tuxracer or something. the reason I say that is because games like unreal and quake are a little finiky and could be crashed by a sound problem. so verify that your drivers work then move on to UT.

the comand:
glxgears

will give you an indication of working or failing drivers. to exit the program simply CTRL-C
 
Old 12-08-2004, 02:54 PM   #14
erick6220
LQ Newbie
 
Registered: Dec 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Ok got the drivers loaded, but it says it conflicts with rivafb, where do i remove that driver from.
Also i get this:
# Device configured by xf86config:

Section "Device"
Identifier "Chaintech Geforce FX 5500"
Driver "nv"
#VideoRam 262144
# Insert Clocks lines here if appropriate
EndSection

It still won't load the Nvidia driver like you said. I don't get it.

Erick

Last edited by erick6220; 12-08-2004 at 04:02 PM.
 
Old 12-08-2004, 03:54 PM   #15
erick6220
LQ Newbie
 
Registered: Dec 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Ok got into root ran all info given.
Ran driver intall
errors, had to install the gcc package and the kernel-source package.
Finally installed drivers, but i have to remove the rivafb drivers, how exactly do i do that it didn't tell me where to find the driver.
I ran xf86config -4, but the only 2 Nvidia's offered so I picked Geforce, but its the same driver i originally had.

I'm getting further in this solution just need a lil more help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
UT2004 problems antihero998 Linux - Games 3 06-22-2005 09:50 AM
ut2004 running problem BigCdaAnswer3 Linux - Games 0 12-10-2004 11:01 PM
Running Update Patch for UT2004 trickle Linux - Games 3 10-22-2004 07:47 AM
(Newbie) UT2004 running very sloooow . . . Kephas Linux - Games 26 06-03-2004 04:53 PM
UT2004 running VERY! poorly Diode Linux - Software 2 02-23-2004 04:54 PM


All times are GMT -5. The time now is 11:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration