LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 10-03-2004, 01:24 AM   #1
joelescoulie
Member
 
Registered: Aug 2003
Location: Fresno, California
Distribution: Slackware 10.1
Posts: 35

Rep: Reputation: 15
OpenGL slow after 2.6.7 upgrade


Ever since I upgraded my kernel to 2.6.7 from 2.4.26, I've noticed a slowdown in openGL rendering. Games run slower and are at times choppy. I had a hell of a time gettting my NVIDIA drivers installed, (rivafb module problem) but after I did, all GL was a bit slower. I also don't have sound in games any more but that is another thread. Has anyone else noticed problems with openGL and 2.6.x kernels, and If so how did you fix them?

Slackware 10
xorg 6.7.0
NVIDIA driver 6111
cedega 4.1-1
alsa-driver 1.0.5a
 
Old 10-03-2004, 02:07 AM   #2
MNKyDeth
Member
 
Registered: Sep 2003
Location: USA
Distribution: Fedora Core 10 x86_64
Posts: 100

Rep: Reputation: 15
I havn't had any problems with the 2.6 kernels as of yet. I am thinking possibly that the system may not be using the agp. Use Option "NvAGP" "3" after the "nvidia" line to make sure the agp is enabled. the "3" will use the kernel agp if it is there and if it isn't will default to the nvidia's agp driver.
From my experience with games and such when I went to the 2.6 kernels my frame rate stayed about the same but my mouse became hella fast. I had to turn down most of the sensitivity settings to make my games playable for me again.

This is just a guess obviously but it's the only real thing I can think of atm.

GL
 
Old 10-04-2004, 10:34 PM   #3
joelescoulie
Member
 
Registered: Aug 2003
Location: Fresno, California
Distribution: Slackware 10.1
Posts: 35

Original Poster
Rep: Reputation: 15
I must have formatted the line wrong because your suggestion crashed x. I had it written like this:

Quote:
"nvidia" "NvAGP" "3"
Maybe that is not what you meant but It is no matter. My problem turned out to be with my cedega/winex config file. I never changed the file after my upgrade, and for some reason It worked fine in 2.4 but not 2.6.

The offending lines refered to my video ram:

this
Quote:
"VideoRam" = "64"
not this
Quote:
"VideoRam" = "32"
and the sound driver section

this
Quote:
"Drivers" = "winealsa.drv"
not this
Quote:
"Drivers" = "wineoss.drv"
Thanks anyway though
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
3D Acceleration ok, but OpenGL slow hansidm Slackware 6 08-24-2005 03:53 PM
ATI OpenGL is SLOW!! tionik06 Linux - Hardware 7 08-22-2005 09:13 PM
OpenGL very slow, SIS300 mmmm Linux - General 8 04-26-2005 01:40 PM
Very slow OpenGL mr_rob Linux - Newbie 3 09-24-2003 12:29 PM
slow a$$ opengl e1v!$ Linux - Software 14 07-19-2003 01:15 AM


All times are GMT -5. The time now is 03:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration