LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 08-24-2006, 01:39 AM   #1
RAFAL
Member
 
Registered: Feb 2006
Location: Warsaw, Poland
Distribution: openSUSE 11.4, openSUSE 12.3, SLES 11, Archlinux
Posts: 129

Rep: Reputation: 16
Unhappy openal for SUSE10.1 - problem with installation


Hello,

I want to install game Torcs on my SUSE 10.1 and some libraries were missing. I have almost solve it,
but with one of them I still have problem.
Torcs ./configure file shows this error message:

checking for AL/al.h... no
configure: error: Can't find AL/al.h. OpenAL can be found on http://www.openal.org/
linux-vw0p:~/TORCS 1.2.4/torcs-1.2.4 #

I have installed OpenAl from SUSE DVD, but problem was still not solved. I guess I need Openal-devel and this is not available on DVD, so I have downloaded it from www.openal.org as advised.
I have tried with openal-0.0.8-1.i586.rpm and openal-devel-0.0.8-1.i586.rpm, but it does not work. While installation there is an error "Transaction failed: Package transaction failed."
I though maybe I can install only devel and only for the version I have.
There is following error message:

Installing openal-devel-20050801-2.i586[Local packages]
There are no installable providers of openal == 20050801 for openal-devel-20050801-2.i586[Local packages]

Could anyone advise me where is the problem? Why RPM's downloaded from www.openal.org don't work. There was no information that they are for any special distribution, so I though they are universal. Where can I found openal-devel for my SUSE version?

Regards
Rafal
 
Old 08-28-2006, 09:12 PM   #2
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
I opened up yast. Not only did it list OpenAl, and OpenAl-devel, but it also had Torcs ready to install. Any reason not to just use suse's copy? And maybe you should check your install if you cant find the devel packages
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to set up pppoe in suse10... not able to acces adsl modem thru suse10 akshay_jp Suse/Novell 5 09-04-2006 10:39 PM
Apache2 installation with Yast on Suse10.0 CGI problems DLHOMME Suse/Novell 0 05-20-2006 09:20 AM
OpenAL? hylke Programming 9 07-25-2005 05:49 PM
Threads and OpenAL clb Programming 4 11-14-2004 02:04 PM
OpenAL Installation Help Little_Devil Linux - Software 0 08-08-2002 02:58 PM


All times are GMT -5. The time now is 03:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration