LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 05-19-2004, 07:11 AM   #1
biscristi
Member
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 51

Rep: Reputation: 15
not responding


first of all sorry if my english isn't perfect.
I'm having some problems running games in madrake 10. I'm playing ut2004 and while in the game and while my i can hear my hard drive is working (so i've noticed), playing stops responding for a fraction of a second. This is a problem that i've noticed in some windows versions too, on some other machines i had before, but it really shouldn't happen on my intel pentium 4 2.8 512mb ram and geforce 4 mx 440, all settings ...lowest. On windows on my curent machine all runs fine. Could you help me with this ?
 
Old 05-20-2004, 08:39 AM   #2
Oliv'
Senior Member
 
Registered: Jan 2004
Location: Montpellier (France)
Distribution: Gentoo
Posts: 1,014

Rep: Reputation: 36
Hi,

If I've correctly understood your problem: you have a sort of "lag" when you play... and it happens when your hear your hard disk working.
I think that there's no reason for your hard disk to work? But what about your memory usage? when you log in and main services are started, how many free memory have you???
Because, I think that your PC do a lot of swap when you play bec' you don't have enough memory... and so these access probably slow the game

Oliv'
 
Old 05-20-2004, 09:06 AM   #3
biscristi
Member
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 51

Original Poster
Rep: Reputation: 15
You're right about my memory. I actually noticed this problem some while ago and it's kinda strange. Right now i have 240mb used application memory, 80 buffered, 120 cached, and the rest, 90mb is free memory, which is pretty low. In windows i had 300mb free all the time. Also swap memory is totally free at the moment. What do you think is wrong? And could really memory be the problem for the "lag" ?
I really wouldn't like to upgrade my ram right now...
 
Old 05-20-2004, 10:59 AM   #4
Oliv'
Senior Member
 
Registered: Jan 2004
Location: Montpellier (France)
Distribution: Gentoo
Posts: 1,014

Rep: Reputation: 36
I don't think you need to upgrade your memory As a proof, I have 256Mb SDRAM and a video card based on the same chipset than yours and I can play Counter1.5 under Linux with no lags...
But I have a very light distro: I use LFS with an Xserver (eats a lot of memory ) and a XFCE4 as a window manager which is very light... Moreover when I play games, I have to close some applications like mozilla which also eats a lot of RAM.
I've never tested Mandrake10, but I suppose that it has a very nice graphical interface with KDE3+Qt3 and maybe some GTK widget...
So a solution to know if it comes from memory (which may be under optimised), when you want to run UT2004, run your X server with a ligth window manager (fwm should be perfect) and close all your graphical applications... Then run UT2004...
Quote:
And could really memory be the problem for the "lag" ?
Yes it can, but it can come from another thing like OS scheduling, processor, network, video card....??? But I don't think it comes from OS scheduling or processor as Mandrake10 uses kernel2.6 which seems to have greatly improved scheduling policy, and you have a very good proc... So maybe video card config??? How many FPS have you when you run glxgears?
Hope this help you

Oliv'
 
Old 05-20-2004, 01:48 PM   #5
biscristi
Member
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 51

Original Poster
Rep: Reputation: 15
here's a part of glxgears. i don't know if their good or not.
4744 frames in 5.0 seconds = 948.800 FPS
5358 frames in 5.0 seconds = 1071.600 FPS
5574 frames in 5.0 seconds = 1114.800 FPS
5339 frames in 5.0 seconds = 1067.800 FPS
5470 frames in 5.0 seconds = 1094.000 FPS
4903 frames in 5.0 seconds = 980.600 FPS


Surfing the web i found out that really my actuallty used phisycal ram is buffered+cached memory, so that leaves me with over 300mb of free memory. So memory is apparently not my problem. I noticed though that closing all programs, makes unreal tournament behave real nice, no lag. It's true that when i had the lag i had some programs opened like dc++ opera and gaim which seem to affect behavior in games.
Anyway thanks for all the help
 
Old 05-20-2004, 01:57 PM   #6
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
do you have DMA enabled??
open a term window and type.........

Code:
hdparm -tT /dev/hd??
replace ?? with you drive #
 
Old 05-21-2004, 07:16 AM   #7
biscristi
Member
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 51

Original Poster
Rep: Reputation: 15
[root@cristian cristi]# hdparm -tT /dev/hda

/dev/hda:
read() failed: Input/output error
Timing buffered disk reads: read() failed: Input/output error
[root@cristian cristi]# hdparm /dev/hda

/dev/hda:
HDIO_GET_MULTCOUNT failed: Invalid argument
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
HDIO_GETGEO failed: Invalid argument


this is the result. should i get all those errors ? it seems that dma is used though
 
Old 05-21-2004, 07:19 AM   #8
biscristi
Member
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 51

Original Poster
Rep: Reputation: 15
[root@cristian cristi]# hdparm -tT /dev/hdd

/dev/hdd:
Timing buffer-cache reads: 2960 MB in 2.00 seconds = 1478.01 MB/sec
Timing buffered disk reads: 144 MB in 3.12 seconds = 46.13 MB/sec

this is what happens when whe is use /dev/hdd ... but this is weird beacuse i thought hda is my hard drive ...
 
Old 05-21-2004, 08:40 AM   #9
Oliv'
Senior Member
 
Registered: Jan 2004
Location: Montpellier (France)
Distribution: Gentoo
Posts: 1,014

Rep: Reputation: 36
Hi,

To know your mounted drives i.e. drives in use, cat /proc/mounts (or have a look at /etc/fstab)...
Also, it seems that your video card is not "super" configured... cause with the same card I remember that I have around 2000 FPS... What I can do to help you is to post my X server config when I'll be at home...
Oliv'
 
Old 05-21-2004, 11:25 AM   #10
biscristi
Member
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 51

Original Poster
Rep: Reputation: 15
hy.
ok. so hdd is my hard drive. here is the result of hdparm:

[root@cristian cristi]# hdparm -tT /dev/hdd

/dev/hdd:
Timing buffer-cache reads: 2952 MB in 2.00 seconds = 1474.75 MB/sec
Timing buffered disk reads: 148 MB in 3.03 seconds = 48.85 MB/sec
[root@cristian cristi]# hdparm /dev/hdd

/dev/hdd:
multcount = 16 (on)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
geometry = 16383/255/63, sectors = 234441648, start = 0

also other then downloading and installing the nvidia drivers i have done nothing else to configure my video card. the thing that bothers me is that it does work in windows so it should work in linux too.
I'll be waiting for you're x configuration.
10x
 
Old 05-22-2004, 01:59 PM   #11
Oliv'
Senior Member
 
Registered: Jan 2004
Location: Montpellier (France)
Distribution: Gentoo
Posts: 1,014

Rep: Reputation: 36
Hello,

Here is my config for my video card in /etc/X11/XF86config-4:
Code:
Section "Device"
                                                                                                                                                            
    # Insert Clocks lines here if appropriate
        #ChipSet     "GeForce4 MX 440 with AGP8X"
        Identifier  "GeForce4"
        Driver      "nvidia"
        VideoRam    65536
        Option      "NoLogo" "1"
        Option      "RenderAccel" "1"
EndSection
Note that I've only put the interesting part And I made a mistake in the previous post, in facy I'm around 1500-1600 FPS with this config...
About your hard drive are you sure that hdd is your hard drive, because in general hard drive are hda or hdb and hdc or hdd are for DVD/CD-ROM... What does your /etc/fstab contains ??? Cause according to this:


Quote:
[root@cristian cristi]# hdparm /dev/hda

/dev/hda:
HDIO_GET_MULTCOUNT failed: Invalid argument
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
HDIO_GETGEO failed: Invalid argument
It seems that hda is a hard drive which does not support all ioctls (either due to hardware specs or due to a misconfig)

Oliv'
 
Old 05-23-2004, 02:12 AM   #12
biscristi
Member
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 51

Original Poster
Rep: Reputation: 15
hdd is my hard drive. the reason is the following configuration lines in lilo.cfg
boot=/dev/hdd1
.............
root=/dev/hdd9
..............

And this is the configuration for my video card, in /etc/X11/XF86config-4:

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Option "DPMS"
Option "IgnoreEDID" "1"
EndSection

as you can see, it's quite different... Is it ok ?
 
Old 05-23-2004, 06:39 AM   #13
Oliv'
Senior Member
 
Registered: Jan 2004
Location: Montpellier (France)
Distribution: Gentoo
Posts: 1,014

Rep: Reputation: 36
I think that your config can be improve with the RenderAccel option. This is what this option exactly does according to the NVIDIA-README:
Quote:
Enable or disable hardware acceleration of the RENDER
extension. THIS OPTION IS EXPERIMENTAL. ENABLE IT AT YOUR
OWN RISK. There is no correctness test suite for the RENDER
extension so NVIDIA can not verify that RENDER acceleration works
correctly. Default: hardwareacceleration of the RENDER extension is disabled.
You can also add the videoRAM option, but I don't think this will improve your video performance...
Else everything seems to be OK

Oliv'
 
Old 05-23-2004, 03:47 PM   #14
biscristi
Member
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 51

Original Poster
Rep: Reputation: 15
did that but no real improvement. Still there must be something wrong beacuse when i close all programs it runs very smooth... I don't know..
Anyway thanks for the help. I'm not a gamer anyway i'm just annoyed by the fact that it works perfect in windows..
 
Old 05-24-2004, 09:35 AM   #15
Oliv'
Senior Member
 
Registered: Jan 2004
Location: Montpellier (France)
Distribution: Gentoo
Posts: 1,014

Rep: Reputation: 36
Have you restart your Xserver before testing? And to see if there's relly a difference, retry glxgears utility
And don't worry, if you have correctly configured windws... it will obviously better work with windws cause with Linux you need to run windows game thanks to an emulator which eats a lot of system resources...
Also what you can do with your system is to patch your kernel with the low latency patch (unless you still run 2.6kernel)... you can find it here
This patch will improve your system responsivity

Oliv'
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
not responding to ping Chuck23 Linux - Security 4 10-04-2004 06:49 PM
hde not responding dwessell Linux - Newbie 12 05-22-2004 02:36 PM
HDE not responding dwessell Mandriva 0 05-19-2004 05:47 AM
mouse not responding oDyman Linux - Hardware 1 04-25-2004 11:44 AM
Linux not responding? demonfi Linux - Newbie 3 08-17-2003 09:55 PM


All times are GMT -5. The time now is 10:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration