LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices



Reply
 
Search this Thread
Old 11-30-2004, 01:34 PM   #1
Parenthesis
LQ Newbie
 
Registered: Nov 2004
Location: Australian - living in Germany
Distribution: suse 9.0
Posts: 5

Rep: Reputation: 0
no sound - quake 3 linux


Hi All,

I really hope someone can offer me some recourse for the following problem, Ive tried everything, even really dangerous and stupid solutions to fix the following simple problem ? NO SOUND WHEN PLAYING QUAKE 3 (LINUX), sound functions during all other applications besides quake.

I tried the following rough hacks

NOT RECOMMENDED

echo "quake3.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss

echo "quake3.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss

and was initially elated to hear some sound on game start, but elation soon turned to disappointment
as the game just froze the second I entered a game, and it seems Im not the only one with this exact same problem.

I believed that this problem could be solved rather easily, I have now however exhausted every avenue of recourse I can find, and would be most appreciative if anyone can help me with this.

TRIVIA ? q3 runs with a 15 to 20 % lower ping on Linux than it does on XP, another reason why Ill not stop till this is solved.

Cheers

Parenthesis

 
Old 11-30-2004, 01:53 PM   #2
Hiper
Member
 
Registered: Aug 2003
Location: Portugal
Distribution: Slackware 10.0
Posts: 100

Rep: Reputation: 15
What is your soundcard? and kernel modules used?
Do you use KDE? if so try disabling Arts in the control panel
try launching Q3 from a xterm and watching the output

If all other apps can play sound, this should be easy to solve
 
Old 11-30-2004, 03:39 PM   #3
Parenthesis
LQ Newbie
 
Registered: Nov 2004
Location: Australian - living in Germany
Distribution: suse 9.0
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Hiper
What is your soundcard? and kernel modules used?
Do you use KDE? if so try disabling Arts in the control panel
try launching Q3 from a xterm and watching the output

If all other apps can play sound, this should be easy to solve



OK, disabled Arts, to no avail, but a good tip thx.

Even tried to start quake3 at ?init 2? also to no avail, your tip sent me in that direction.

So here is the info as requested :

sound card :
VIA 8235 (Onboard Audio - realtek ALC 650)

Kernel Modules:

ada@com-mainlin:~> lsmod
Module Size Used by Not tainted
snd-seq 41424 1 (autoclean)
videodev 6272 0 (autoclean)
radeon 104032 17
agpgart 45816 3 (autoclean)
usbserial 20924 0 (autoclean) (unused)
isa-pnp 32712 0 (unused)
parport_pc 28648 1 (autoclean)
lp 6304 0 (autoclean)
parport 25608 1 (autoclean) [parport_pc lp]
hid 21444 0 (unused)
snd-via82xx 16160 4
snd-pcm 74148 0 [snd-via82xx]
snd-timer 17024 0 [snd-seq snd-pcm]
snd-ac97-codec 45400 0 [snd-via82xx]
snd-page-alloc 6676 0 [snd-via82xx snd-pcm]
snd-mpu401-uart 4128 0 [snd-via82xx]
thermal 6180 0 (unused)
processor 8312 0 [thermal]
snd-rawmidi 15968 0 [snd-mpu401-uart]
snd-seq-device 4528 0 [snd-seq snd-rawmidi]
fan 1472 0 (unused)
button 2380 0 (unused)
snd 40388 4 [snd-seq snd-via82xx snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]
battery 5600 0 (unused)
soundcore 3940 0 [snd]
ac 1696 0 (unused)
ipt_TCPMSS 2392 1 (autoclean)
ipt_TOS 1048 9 (autoclean)
ipt_state 568 48 (autoclean)
ipt_LOG 3384 53 (autoclean)
st 29680 0 (autoclean) (unused)
sr_mod 14616 0 (autoclean)
sg 35232 0 (autoclean)
keybdev 2156 0 (unused)
mousedev 4340 1
joydev 5440 0 (unused)
evdev 3840 0 (unused)
input 3488 0 [hid keybdev mousedev joydev evdev]
usb-uhci 23824 0 (unused)
ehci-hcd 18028 0 (unused)
usbcore 64332 1 [usbserial hid usb-uhci ehci-hcd]
raw1394 18288 0 (unused)
ohci1394 25808 0 (unused)
ieee1394 188260 0 [raw1394 ohci1394]
8139too 15084 1

Hope this helps, and thank you for your time

Cheers
 
Old 11-30-2004, 06:25 PM   #4
Hiper
Member
 
Registered: Aug 2003
Location: Portugal
Distribution: Slackware 10.0
Posts: 100

Rep: Reputation: 15
Seems you are not using alsa drivers.
Maybe that could do the trick.

the site is www.alsa-project.org but maybe your distro has a better way to install it
if you are using a 2.6 kernel, you just need to compile the appropriate kernel module and install alsa-lib and alsa-utils

Hope that helps
 
Old 12-01-2004, 08:38 PM   #5
Tormented
Member
 
Registered: Feb 2003
Location: ???
Distribution: Mandriva 2006
Posts: 92

Rep: Reputation: 15
I have a via 8233 soundcard and in order to get Q3 to stop locking up I had to add the following lines to /etc/modprobe.conf:

options snd-via82xx dxs_support=4
options snd-via82xx ac97_clock=48000

If that doesn't work you can try changing the 4 to a 2.
 
Old 12-02-2004, 10:41 PM   #6
The_Nerd
Member
 
Registered: Aug 2002
Distribution: Debian
Posts: 540

Rep: Reputation: 32
I am having the same problem with quake3. I have tried everything I know of with no avail, however, you may want to try this command:
artsd ; artsdsp quake3

It does make allot of things work, but it didn't help me for quake3. Maybe it'll help you.
There is a variable you can set in quake3, I think it's called "s_sndserver", or something related. By default this variable points to /dev/dsp, you can change this and do a /snd_restart

You do know how to use the console right?
 
Old 12-03-2004, 03:49 AM   #7
Soulstealer
Member
 
Registered: Dec 2004
Location: Necropolis
Distribution: FreeBSD
Posts: 47

Rep: Reputation: 15
I've fixed "the no sound problem in quake3" by compiling the exact sound support directly to my kernel (not like a module), and it works
 
Old 12-05-2004, 06:25 AM   #8
nick_th_fury
Member
 
Registered: Jun 2003
Location: Texas
Distribution: Slackware, NetBSD
Posts: 151

Rep: Reputation: 23
Quote:
Originally posted by The_Nerd
I am having the same problem with quake3. I have tried everything I know of with no avail, however, you may want to try this command:
artsd ; artsdsp quake3

It does make allot of things work, but it didn't help me for quake3. Maybe it'll help you.
There is a variable you can set in quake3, I think it's called "s_sndserver", or something related. By default this variable points to /dev/dsp, you can change this and do a /snd_restart

You do know how to use the console right?


I have found that /dev/dsp is often the culprit when only quake3 won't play sounds.
Make sure that if it's a link it points to /dev/dsp0 and that dsp0 is read & writeable by owner, group & world.
Once I set it so everyone can use it, quake3 sound worked for me.
 
Old 07-12-2005, 09:10 PM   #9
-mX-
LQ Newbie
 
Registered: Jul 2005
Location: Poland
Distribution: Mandriva Linux 2005 LE
Posts: 5

Rep: Reputation: 0
Hi, sorry for bringing this ancient topic back up but i have the exact same problem with Quake3, i have tried everything and either sound is delayed (artsdsp -m) or it works but q3 freezes as soon as i start or join a map (see post #1).
Have anyone found a full-proof solution for that problem?
I'm using Realtek AC97 on-board sound card (that comes with nForce2) which works mighty fine with any other app/game.

Quote:
Originally posted by nick_th_fury
Make sure that if it's a link it points to /dev/dsp0 and that dsp0 is read & writeable by owner, group & world.[/B]
I would like to try that one too, but you got me there, i'm noob and i don't know how to change r-w of anything just yet :P
 
Old 08-21-2005, 04:00 PM   #10
AN35N
LQ Newbie
 
Registered: Aug 2005
Posts: 1

Rep: Reputation: 0
hello all...im having the same problem as everyone else. quake has no sound and ive made the /dev/dsp write/read enabled. but quake still says that it can't open it. anyone have any ideas?
 
Old 09-14-2005, 06:26 AM   #11
t2nes
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Rep: Reputation: 0
Bro found this for me thanks ric.
Q: I get no sound in Quake III, and I'm using ALSA!

A: echo "quake3.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
A: Note that this also works for any other game that doesn't support ALSA and needs mmap'd audio, just change the binary name (quake3.x86 with, for instance, et.x86, for Enemy Territory.)
A: Or switch to the open-source Quake III port here at icculus.org: http://www.icculus.org/quake3/

fixed prob for me
 
Old 09-24-2005, 09:17 PM   #12
jameszhu
LQ Newbie
 
Registered: Sep 2005
Posts: 1

Rep: Reputation: 0
I have exactly the same problem.
with 'echo "quake3.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss'
the entering of the game and menu has sound, and the single player mod stage 0 (q3_dm0) has perfect sound too. but after passed the q3_dm0 and after loading the q3_dm1, it freeze.
I'm already use alsa 1.0.9

what's the real solution?!
 
Old 10-03-2005, 10:12 PM   #13
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Get alsa working for your soundcard. You can easily test it with xmms or mplayer.
Launch artsd in a terminal.
In another terminal, type:
artsdsp -m quake3

If it don't work as user but succeed as root, then go add yourself in the audio group in /etc/group .

Last edited by Linux.tar.gz; 10-03-2005 at 10:13 PM.
 
Old 10-07-2005, 09:44 PM   #14
Rhatlinux
Member
 
Registered: Sep 2004
Distribution: Arch 0.7.1 (Noodle)
Posts: 128

Rep: Reputation: 15
My Quake 3 does not have sound either. The Quake 3 console displays, "Could not open /dev/sound/dsp." I don't run KDE so artsd is not installed. This seems like an unsolved problem. I have been searching Google and have not found an answer to this problem.
 
Old 10-22-2005, 05:04 PM   #15
jeffpc
LQ Newbie
 
Registered: Oct 2005
Posts: 2

Rep: Reputation: 0
So....

It sounds like there are two issues....

1) People get no sound whatsoever, and an error message that is something like:

Code:
Could not mmap dma buffer PROT_WRITE|PROT_READ
trying mmap PROT_WRITE (with associated better compatibility / less performance code)
/dev/dsp: Input/output error
Could not mmap /dev/dsp
and 2) People run

Code:
echo "quake3.x86 0 0 direct" > /proc/asound/ICH5/pcm0p/oss
and get sound in the menus, but once a game starts, quake freezes.

I fall into second category. Quake3 just freezes.

I really want to get sound working... :-(

Jeff.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Quake 3 = no sound Ice9 Linux - Software 15 01-11-2007 12:05 AM
Quake 4 - Sound Glitches mdiotto Linux - Games 3 10-27-2005 03:08 AM
Sound with Quake 3 on VIA 8237 vanquisher Linux - Games 0 02-25-2005 02:00 AM
quake 3 sound e1000 Linux - Games 2 12-03-2003 02:34 AM
sound under quake schatoor Linux - Software 0 09-24-2002 09:30 AM


All times are GMT -5. The time now is 05:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration