LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (http://www.linuxquestions.org/questions/linux-games-33/)
-   -   no sound - quake 3 linux (http://www.linuxquestions.org/questions/linux-games-33/no-sound-quake-3-linux-260975/)

Parenthesis 11-30-2004 12:34 PM

no sound - quake 3 linux
 
Hi All,

I really hope someone can offer me some recourse for the following problem, Ive tried everything, even really dangerous and stupid solutions to fix the following simple problem ? NO SOUND WHEN PLAYING QUAKE 3 (LINUX), sound functions during all other applications besides quake.

I tried the following rough hacks

NOT RECOMMENDED

echo "quake3.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss

echo "quake3.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss

and was initially elated to hear some sound on game start, but elation soon turned to disappointment
as the game just froze the second I entered a game, and it seems Im not the only one with this exact same problem.

I believed that this problem could be solved rather easily, I have now however exhausted every avenue of recourse I can find, and would be most appreciative if anyone can help me with this.

TRIVIA ? q3 runs with a 15 to 20 % lower ping on Linux than it does on XP, another reason why Ill not stop till this is solved.

Cheers

Parenthesis

:scratch:

Hiper 11-30-2004 12:53 PM

What is your soundcard? and kernel modules used?
Do you use KDE? if so try disabling Arts in the control panel
try launching Q3 from a xterm and watching the output

If all other apps can play sound, this should be easy to solve :)

Parenthesis 11-30-2004 02:39 PM

Quote:

Originally posted by Hiper
What is your soundcard? and kernel modules used?
Do you use KDE? if so try disabling Arts in the control panel
try launching Q3 from a xterm and watching the output

If all other apps can play sound, this should be easy to solve :)




OK, disabled Arts, to no avail, but a good tip thx.

Even tried to start quake3 at ?init 2? also to no avail, your tip sent me in that direction.

So here is the info as requested :

sound card :
VIA 8235 (Onboard Audio - realtek ALC 650)

Kernel Modules:

ada@com-mainlin:~> lsmod
Module Size Used by Not tainted
snd-seq 41424 1 (autoclean)
videodev 6272 0 (autoclean)
radeon 104032 17
agpgart 45816 3 (autoclean)
usbserial 20924 0 (autoclean) (unused)
isa-pnp 32712 0 (unused)
parport_pc 28648 1 (autoclean)
lp 6304 0 (autoclean)
parport 25608 1 (autoclean) [parport_pc lp]
hid 21444 0 (unused)
snd-via82xx 16160 4
snd-pcm 74148 0 [snd-via82xx]
snd-timer 17024 0 [snd-seq snd-pcm]
snd-ac97-codec 45400 0 [snd-via82xx]
snd-page-alloc 6676 0 [snd-via82xx snd-pcm]
snd-mpu401-uart 4128 0 [snd-via82xx]
thermal 6180 0 (unused)
processor 8312 0 [thermal]
snd-rawmidi 15968 0 [snd-mpu401-uart]
snd-seq-device 4528 0 [snd-seq snd-rawmidi]
fan 1472 0 (unused)
button 2380 0 (unused)
snd 40388 4 [snd-seq snd-via82xx snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]
battery 5600 0 (unused)
soundcore 3940 0 [snd]
ac 1696 0 (unused)
ipt_TCPMSS 2392 1 (autoclean)
ipt_TOS 1048 9 (autoclean)
ipt_state 568 48 (autoclean)
ipt_LOG 3384 53 (autoclean)
st 29680 0 (autoclean) (unused)
sr_mod 14616 0 (autoclean)
sg 35232 0 (autoclean)
keybdev 2156 0 (unused)
mousedev 4340 1
joydev 5440 0 (unused)
evdev 3840 0 (unused)
input 3488 0 [hid keybdev mousedev joydev evdev]
usb-uhci 23824 0 (unused)
ehci-hcd 18028 0 (unused)
usbcore 64332 1 [usbserial hid usb-uhci ehci-hcd]
raw1394 18288 0 (unused)
ohci1394 25808 0 (unused)
ieee1394 188260 0 [raw1394 ohci1394]
8139too 15084 1

Hope this helps, and thank you for your time

Cheers

Hiper 11-30-2004 05:25 PM

Seems you are not using alsa drivers.
Maybe that could do the trick.

the site is www.alsa-project.org but maybe your distro has a better way to install it
if you are using a 2.6 kernel, you just need to compile the appropriate kernel module and install alsa-lib and alsa-utils

Hope that helps :)

Tormented 12-01-2004 07:38 PM

I have a via 8233 soundcard and in order to get Q3 to stop locking up I had to add the following lines to /etc/modprobe.conf:

options snd-via82xx dxs_support=4
options snd-via82xx ac97_clock=48000

If that doesn't work you can try changing the 4 to a 2.

The_Nerd 12-02-2004 09:41 PM

I am having the same problem with quake3. I have tried everything I know of with no avail, however, you may want to try this command:
artsd ; artsdsp quake3

It does make allot of things work, but it didn't help me for quake3. Maybe it'll help you.
There is a variable you can set in quake3, I think it's called "s_sndserver", or something related. By default this variable points to /dev/dsp, you can change this and do a /snd_restart

You do know how to use the console right?

Soulstealer 12-03-2004 02:49 AM

I've fixed "the no sound problem in quake3" by compiling the exact sound support directly to my kernel (not like a module), and it works

nick_th_fury 12-05-2004 05:25 AM

Quote:

Originally posted by The_Nerd
I am having the same problem with quake3. I have tried everything I know of with no avail, however, you may want to try this command:
artsd ; artsdsp quake3

It does make allot of things work, but it didn't help me for quake3. Maybe it'll help you.
There is a variable you can set in quake3, I think it's called "s_sndserver", or something related. By default this variable points to /dev/dsp, you can change this and do a /snd_restart

You do know how to use the console right?



I have found that /dev/dsp is often the culprit when only quake3 won't play sounds.
Make sure that if it's a link it points to /dev/dsp0 and that dsp0 is read & writeable by owner, group & world.
Once I set it so everyone can use it, quake3 sound worked for me.

-mX- 07-12-2005 08:10 PM

Hi, sorry for bringing this ancient topic back up but i have the exact same problem with Quake3, i have tried everything and either sound is delayed (artsdsp -m) or it works but q3 freezes as soon as i start or join a map (see post #1).
Have anyone found a full-proof solution for that problem?
I'm using Realtek AC97 on-board sound card (that comes with nForce2) which works mighty fine with any other app/game.

Quote:

Originally posted by nick_th_fury
Make sure that if it's a link it points to /dev/dsp0 and that dsp0 is read & writeable by owner, group & world.[/B]
I would like to try that one too, but you got me there, i'm noob and i don't know how to change r-w of anything just yet :P

AN35N 08-21-2005 03:00 PM

hello all...im having the same problem as everyone else. quake has no sound and ive made the /dev/dsp write/read enabled. but quake still says that it can't open it. anyone have any ideas?

t2nes 09-14-2005 05:26 AM

Bro found this for me thanks ric.
Q: I get no sound in Quake III, and I'm using ALSA!

A: echo "quake3.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
A: Note that this also works for any other game that doesn't support ALSA and needs mmap'd audio, just change the binary name (quake3.x86 with, for instance, et.x86, for Enemy Territory.)
A: Or switch to the open-source Quake III port here at icculus.org: http://www.icculus.org/quake3/

fixed prob for me

jameszhu 09-24-2005 08:17 PM

I have exactly the same problem.
with 'echo "quake3.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss'
the entering of the game and menu has sound, and the single player mod stage 0 (q3_dm0) has perfect sound too. but after passed the q3_dm0 and after loading the q3_dm1, it freeze.
I'm already use alsa 1.0.9

what's the real solution?!

Linux.tar.gz 10-03-2005 09:12 PM

Get alsa working for your soundcard. You can easily test it with xmms or mplayer.
Launch artsd in a terminal.
In another terminal, type:
artsdsp -m quake3

If it don't work as user but succeed as root, then go add yourself in the audio group in /etc/group .

Rhatlinux 10-07-2005 08:44 PM

My Quake 3 does not have sound either. The Quake 3 console displays, "Could not open /dev/sound/dsp." I don't run KDE so artsd is not installed. This seems like an unsolved problem. I have been searching Google and have not found an answer to this problem.

jeffpc 10-22-2005 04:04 PM

So....
 
It sounds like there are two issues....

1) People get no sound whatsoever, and an error message that is something like:

Code:

Could not mmap dma buffer PROT_WRITE|PROT_READ
trying mmap PROT_WRITE (with associated better compatibility / less performance code)
/dev/dsp: Input/output error
Could not mmap /dev/dsp

and 2) People run

Code:

echo "quake3.x86 0 0 direct" > /proc/asound/ICH5/pcm0p/oss
and get sound in the menus, but once a game starts, quake freezes.

I fall into second category. Quake3 just freezes.

I really want to get sound working... :-(

Jeff.


All times are GMT -5. The time now is 02:55 AM.