LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 06-30-2006, 05:39 PM   #1
magnum2066
LQ Newbie
 
Registered: Jun 2006
Posts: 12

Rep: Reputation: 0
No Sound in Games


I have recently turned faceward towards Ubuntu and gave it all a shot! Unfortunately all I am getting is problem after problem. The game now runs amazingly but puts out no sound. I tried a few killall commands, turning all volumes to max, and reading a LOT today. I have a sound blaster live! card which I am using in place of my onboard ac97 audio. I get sound through apps like GAIM and other small stuff. When I attempt to play UT2004 or Enemy-Territory it plays be again no sound. What can I do to fix this issue?
 
Old 06-30-2006, 05:45 PM   #2
xpromisex
Member
 
Registered: Apr 2004
Location: Statesboro, GA
Distribution: Arch Linux 2007.05 "Duke" (Kernel 2.6.21)
Posts: 447

Rep: Reputation: 30
is esd running? Sounds like esd is hijacking /dev/dsp for itself and not allowing anything else to access it. I would kill esd and start the game and see if that helps. I know that you mentioned having to killall a lot of things, was esd one of them? Anyway - hope this helped, but if not let me know and we can run with it from there.
 
Old 06-30-2006, 11:01 PM   #3
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,197

Rep: Reputation: 164Reputation: 164
Most commercial games don't work well with ALSA(the new and better sound system for Linux). However, ALSA also has OSS(the old sound system) support.

Just run:
modprobe snd_pcm_oss (as root)
This will load ALSA's OSS emulation.

You might have to change the setup for the games as well.

UT2004, DOOM 3 and QUAKE 4:
Make sure snd_pcm_oss is loaded (as explained above).
To make it uses the OSS emulation, add the following when starting it (if needed):
+set s_driver oss
Example: "doom3-demo +set s_driver oss" (From now it will remember to use the OSS emulation.).

Wolfenstein ET:
Make sure snd_pcm_oss is loaded.
Next do (also as root):
echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss


PS: Do post back if you need more info.

Last edited by jens; 06-30-2006 at 11:11 PM.
 
Old 07-01-2006, 02:41 AM   #4
magnum2066
LQ Newbie
 
Registered: Jun 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Here is exactly what I did in Ubuntu:

1. Ran modprobe snd_pcm_oss as root.
2. Tried the game (UT2004), no improvement and same error appears.
(WARNING: ALC_EXT_capture is subject to change!)
3. Right-clicked ut2004-demo.run and clicked properties. I then added a space at the end of the name and pasted: +set s_driver oss
4. Tried game, still no Kudos.

And as for the first replier, I did the esd kill cmd.

Last edited by magnum2066; 07-01-2006 at 02:58 AM.
 
Old 07-01-2006, 03:10 AM   #5
adnan_lucky003
LQ Newbie
 
Registered: Jun 2006
Posts: 1

Rep: Reputation: 0
how can i play video cd's in linux like movies etc.
 
Old 07-01-2006, 12:42 PM   #6
magnum2066
LQ Newbie
 
Registered: Jun 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by adnan_lucky003
how can i play video cd's in linux like movies etc.
Please no hijacking.
 
Old 07-01-2006, 06:26 PM   #7
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,197

Rep: Reputation: 164Reputation: 164
Quote:
Originally Posted by magnum2066
Here is exactly what I did in Ubuntu:

1. Ran modprobe snd_pcm_oss as root.
2. Tried the game (UT2004), no improvement and same error appears.
(WARNING: ALC_EXT_capture is subject to change!)
3. Right-clicked ut2004-demo.run and clicked properties. I then added a space at the end of the name and pasted: +set s_driver oss
4. Tried game, still no Kudos.

And as for the first replier, I did the esd kill cmd.
Well, I just did some googling myself and this seems to be big problem for many people (UT2004). Are you really sure you haven't got any app using sound before starting it. Strangely I don't have any problem with it on my Debian box (In Fedora I just had to disable the the sound system from the menu). You might also want to look at this thread(post 8):
http://www.linuxquestions.org/questi...d.php?t=237788
...The OP did'n answer if it worked though.
Also, did you try changing the sound configuration in the game itself?

Apart from UT2004, did you get ET to work(as I explained above)?

Last edited by jens; 07-01-2006 at 06:31 PM.
 
Old 07-02-2006, 12:49 AM   #8
catmanjimmy
LQ Newbie
 
Registered: Jun 2006
Location: Hastings - South England
Distribution: LazyDragon ,Slackware
Posts: 8

Rep: Reputation: 0
I released A copy of my distro with unreal 2004 demo installed on it .
Sometimes when loading games like unreal you get something like "unable to connect to soundcard" , just before the game starts . to fix it I either open up "system monitor" in gnome and look through all the processes to see if "esd" or "artsd" are running ( they may be running twice ) and then kill them . alternativly you could execute "killall esd" and "killall atsd" once or twice .
This may be a different problems , but sound still works through apps like GAIM and some other stuff . If your sound is working fine on some level , it must be a process getting in the way .
 
Old 07-02-2006, 12:15 PM   #9
magnum2066
LQ Newbie
 
Registered: Jun 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Here is a list of my processes:
http://img228.imageshack.us/img228/2...eenshot7wq.png

I tried what was suggested in that other thread but it didn't seem to work either. :/ (The part where you make a file, I made it but had no idea what to do from there or where to put it.) I've been thinking that maybe I need some other sound driver for my SBLive! card? I killed the esd process, the atsd process isn't present on this system. (I was told its for KDE.) The only error I receive when starting the game is (WARNING: ALC_EXT_capture is subject to change!. I would mess with my audio configuration in-game but I am limited to the openAL driver.

Thanks for your help thus far.

[EDIT] Reminding that I have both onboard and PCI sound. (Currently using my PCI SBLive! card.)

Last edited by magnum2066; 07-02-2006 at 12:16 PM.
 
Old 07-02-2006, 11:40 PM   #10
xpromisex
Member
 
Registered: Apr 2004
Location: Statesboro, GA
Distribution: Arch Linux 2007.05 "Duke" (Kernel 2.6.21)
Posts: 447

Rep: Reputation: 30
Have you tried using your onboard sound magnum? I had so many problems a year or so ago with two sound cards conflicting with one another, using the onboard did the trick though.
 
Old 07-03-2006, 01:40 AM   #11
magnum2066
LQ Newbie
 
Registered: Jun 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Oh my gosh... SWEET SWEET SOUND!

Just so you guys know, (WARNING: ALC_EXT_capture is subject to change!) will show whether the sound works or not. So I believe the error is unrelated. Thanks for your help!

(BTW, I had to kill one esd process before it worked.)

Last edited by magnum2066; 07-03-2006 at 01:47 AM.
 
Old 07-04-2006, 09:59 AM   #12
catmanjimmy
LQ Newbie
 
Registered: Jun 2006
Location: Hastings - South England
Distribution: LazyDragon ,Slackware
Posts: 8

Rep: Reputation: 0
I believe "ALC_EXT_capture is subject to change" is todo with a mode of graphics
driver , alternate to what comes with Xorg . Im not sure .
Glad to here you got your audio.
 
Old 07-13-2006, 06:50 PM   #13
Weasel75
LQ Newbie
 
Registered: Jul 2006
Posts: 2

Rep: Reputation: 0
Hello!

It seems like I ran into some (maybe) closely related sound-problem.
Running on Ubuntu too, I have sound on the onboard-card (use it for VoIP/headphones), but not on my primary sound-device (Audigy 2) - seems like the settings for the primary device are not used for the games?!

Semi-desperately (after all, I have *some* sound at least) - Weasel75
 
Old 07-13-2006, 11:42 PM   #14
magnum2066
LQ Newbie
 
Registered: Jun 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Weasel75
Hello!

It seems like I ran into some (maybe) closely related sound-problem.
Running on Ubuntu too, I have sound on the onboard-card (use it for VoIP/headphones), but not on my primary sound-device (Audigy 2) - seems like the settings for the primary device are not used for the games?!

Semi-desperately (after all, I have *some* sound at least) - Weasel75
I tried a lot after I succeeded with my onboard... And I only got it to work by disabling the onboard sound via BIOS. Otherwise it always gave me crap.

-M
 
Old 08-26-2006, 03:11 PM   #15
dracae
Member
 
Registered: Feb 2006
Location: Oklahoma
Distribution: Debian Sid and Etch
Posts: 423

Rep: Reputation: 30
"WARNING: ALC_EXT_capture is subject to change" is part of the voip audio capture support, and just like is says it is only a warning. It should probably say notice but EVERYONE should get it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no sound in games darwinconan Linux - Hardware 4 09-01-2006 02:45 AM
no sound in games jmanjeff Debian 2 05-15-2005 10:34 AM
games and sound Ry12 Linux - Games 2 06-15-2004 01:11 AM
Sound in games opafire Slackware 1 02-12-2004 10:01 AM
sound with games popcorn5714 Linux - Hardware 1 08-26-2002 06:24 PM


All times are GMT -5. The time now is 02:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration