LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 10-04-2004, 04:26 PM   #1
GML3G0
Member
 
Registered: Sep 2004
Location: NY
Distribution: Gentoo Linux
Posts: 50

Rep: Reputation: 15
NeverWinter Nights


I installed Neverwinter Nights and the latest update and the game runs. Only thing is, its laggy and slow as hell, even offline. The mouse cursor is struggling to move across the screen during a gam (not on the main menu). I have all the options set to their lowest values. Any help?
System Specs:
SuSE 9.1 Persional
PIII 1.2 Ghz
256 MB RAM
nVidia GeForce2Go 32 MB Video Card

It ran perfectly under Windows before I transitioned to Linux. All my other games under Linux work fine except this one. America's Army, Warcraft III: TFT, Enemy Territory, Steam Counter-Strike--they all work fine.
--------------------

"What happened, happened and couldn't have happened any other way. "

"Choice is an illusion created between those with power and those without. "

"You didn't come here to make the choice, you've already made it. You're here to try to understand *why* you made it. I thought you'd have figured that out by now. "
 
Old 10-04-2004, 04:32 PM   #2
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
running NWN through wine?

--looks like a common problem:
http://www.google.com/search?q=never...www.winehq.org

stuff going through wine isn't gauranteed to work like it did on windows; gameing in linux is one of my reasons for hanging onto MS
 
Old 10-04-2004, 06:40 PM   #3
GML3G0
Member
 
Registered: Sep 2004
Location: NY
Distribution: Gentoo Linux
Posts: 50

Original Poster
Rep: Reputation: 15
No not wine. I have the native Linux port.
 
Old 10-04-2004, 08:36 PM   #4
wasme
LQ Newbie
 
Registered: Sep 2004
Location: Manitoba, Canada
Distribution: Debian Sid (Unstable)
Posts: 11

Rep: Reputation: 0
Check your XFree/X.org config file to make sure your running at a colour depth of 24 or higher. NWN doesn't run fully hardware accelerated below 24.
 
Old 10-04-2004, 09:05 PM   #5
GML3G0
Member
 
Registered: Sep 2004
Location: NY
Distribution: Gentoo Linux
Posts: 50

Original Poster
Rep: Reputation: 15
OK, thanks a lot. It works great now with all the settings turned up to the max.

Last edited by GML3G0; 10-04-2004 at 09:13 PM.
 
Old 10-05-2004, 01:51 AM   #6
trickle
Member
 
Registered: Aug 2004
Location: South Africa
Distribution: Mandrake 9.1, 10; Red Hat 9.0, winxp and Suse 9.1 Pro, Fedora Core 3
Posts: 52

Rep: Reputation: 15
Hi GML3GO, can you please tell me where you found the linux port?

Thanks a lot
 
Old 10-05-2004, 12:29 PM   #7
Bill Cosby
Member
 
Registered: Jul 2004
Posts: 31

Rep: Reputation: 15
Quote:
Originally posted by trickle
Hi GML3GO, can you please tell me where you found the linux port?

Thanks a lot
It's available at theri homepage http://nwn.bioware.com/downloads/linuxclient.html
 
Old 10-05-2004, 12:33 PM   #8
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 10.04/12.04, Scientific Linux 6.3, Android-x86, Maemo
Posts: 1,658

Rep: Reputation: 138Reputation: 138
Also Try:

http://icculus.org/homepages/ravage/

and Ravage's installers...

They work great.
 
Old 06-27-2006, 01:08 PM   #9
tnandy
Member
 
Registered: Oct 2003
Location: Tennessee
Distribution: Fedora 14, CentOS 5
Posts: 125

Rep: Reputation: 15
Another problem that tends to make Neverwinter Nights run slowly is not having direct rendering on your video. Open a terminal and enter:
$ glxinfo
There is a massive amount of output. What you're looking for is near the top. If it says "direct rendering: No", you likely have a problem with your video card drivers. For example, the FC3 default drivers for nVIDIA video cards do not support Neverwinter Nights. You must download and properly install the nVIDIA driver and get "direct rendering: Yes" before the game runs jitter-free. Go to your video card manufacturer's web site for the appropriate driver.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
neverwinter nights issues JROCK1980 Linux - Games 8 06-28-2006 11:27 AM
Neverwinter Nights problem jaakkop Linux - Games 0 09-01-2005 01:33 PM
Can't run Neverwinter Nights drowbot Linux - Games 7 03-28-2005 10:11 AM
neverwinter nights slugishness mnchur Linux - Games 4 03-17-2004 02:47 PM
Neverwinter Nights Comarez Linux - Games 9 02-07-2004 06:11 AM


All times are GMT -5. The time now is 07:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration