LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (http://www.linuxquestions.org/questions/linux-games-33/)
-   -   Need testers for my little opengl game (http://www.linuxquestions.org/questions/linux-games-33/need-testers-for-my-little-opengl-game-938756/)

prushik 04-08-2012 10:47 AM

Need testers for my little opengl game
 
It's not finished. Most of the game has been tested pretty well, however, I'm having trouble testing the network gameplay portion. I really just started working on the network part, and I suspect that there will be some race conditions that will mess things up. I can only run it on one of my machines at the moment, since one machine is a dinosaur with video card/opengl issues, and the other is being used for an experimental Linux distro that I am working on, and at the moment it only has kdrive xserver (no OpenGL). So, anybody that can test the network portions of my game would be a big help.
Also, I have released the source, so you can look at it if you want, but be warned that I wrote most of it in highschool, so its kinda sloppy. It's licensed under the beerware license.
Here is the link:
http://www.betteros.org/games/download.html

yooy 04-08-2012 11:46 AM

It say: "package is of bad quality" when i attept to install

Quote:

Lintian check results for /home/deb/Downloads/UnititledOne.2012.04.08.deb:
Use of uninitialized value $ENV{"HOME"} in concatenation (.) or string at /usr/bin/lintian line 108.
E: UntitledOne: arch-independent-package-contains-binary-or-object usr/games/UntitledOne
E: UntitledOne: wrong-file-owner-uid-or-gid usr/ 1000/1000
E: UntitledOne: wrong-file-owner-uid-or-gid usr/games/ 1000/1000
E: UntitledOne: wrong-file-owner-uid-or-gid usr/games/UntitledOne 1000/1000
I'm using cross distro linux mint&ubuntu 12.04 beta.

when i click ignore it fails to install. However my software center seems to be broken somehow.

prushik 04-08-2012 06:29 PM

Quote:

Originally Posted by yooy (Post 4647751)
It say: "package is of bad quality" when i attept to install



I'm using cross distro linux mint&ubuntu 12.04 beta.

when i click ignore it fails to install. However my software center seems to be broken somehow.

Oh.. huh, how about that. Well, that's another reason why testing things by myself isn't good enough. I assume its a permission problem, since you don't have a user prushik with uid 1000 on your system. I'll fix the permissions and upload again soon, however, now I have to get to Korean class, so I can't fix it until I get home.
If you are determined to test it, you can try to compile it from source. It's quite easy, just:
gcc ut1l.c -lGL -lGLU -lglut -DAUDIO -lalut -lopenal -o UntitledOne
You can leave out the -DAUDIO part if you don't have openAL or if the sound is too annoying (its not done yet).

manu-tm 04-08-2012 11:18 PM

~/Desktop$ ./UntitledOne
freeglut (./UntitledOne): glXCreateContextAttribsARB not found

Maybe you should provide more detailled info about required dependencies or how to build and run the program, or a functional debian package.

prushik 04-09-2012 12:11 AM

Just got back from Korean class, now I hopefully I can fix some of these issues.

Quote:

Originally Posted by manu-tm (Post 4648040)
~/Desktop$ ./UntitledOne
freeglut (./UntitledOne): glXCreateContextAttribsARB not found

I think that is either a freeglut problem, or a glx problem. That's the error I get on my old HP laptop (the beast). I'll see if I can debug the problem, but I assumed it was a bug in the very old fglrx drivers that are running on that machine.

Quote:

Originally Posted by manu-tm (Post 4648040)
Maybe you should provide more detailled info about required dependencies or how to build and run the program, or a functional debian package.

Yep, that's a good idea. What I did was pretty slapdash, but now I have time, so I'll see about fixing the debian package.
The dependencies are:
libGL
libGLU
FreeGLUT or GLUT or OpenGLUT (OpenGLUT is untested)

Optional Audio Support:
OpenAL
libalut

prushik 04-09-2012 01:51 AM

Ok, I uploaded a new .deb package, the files are now owned by root instead of prushik, so it should work.
I also added a list of dependencies on the webpage. I also changed the source package to a little tarball with a makefile and a pseudo-configure script. Although just compiling with gcc is still just as easy, ./configure && make is more familiar to many folks.
http://www.betteros.org/games/download.html

yooy 04-09-2012 02:21 AM

now i can't downlaod deb package, ita says 404 error not found.

prushik 04-09-2012 03:49 AM

Quote:

Originally Posted by yooy (Post 4648101)
now i can't downlaod deb package, ita says 404 error not found.

Yes, sorry, that has been fixed. It was a typo. Sorry. I also added a 32 bit package as well as the 64 bit version.

prushik 04-09-2012 08:05 AM

Quote:

Originally Posted by manu-tm (Post 4648040)
~/Desktop$ ./UntitledOne
freeglut (./UntitledOne): glXCreateContextAttribsARB not found

Also, there is a solution for this, Next source code release will include a fix for this (not so much a fix, more of a workaround, but it makes the game work correctly).

prushik 04-10-2012 02:53 AM

Ok, just uploaded my updated source code. It should fix the glXCreateContextAttribsARB problem, and network play should also work.
Debian packages have been fixed again (hopefully).

Changes:
-missile sound has been changed to something less obnoxious
-explosion sounds are in place, but they suck
-network play connection fixes
-added a (hopefully) more accurate method of measuring time (which can be compiled out by passing -DSLOPPYTIME to gcc)

manu-tm 04-10-2012 07:35 AM

I get the same error again (glXCreateContextAttribsARB not found).

I have:
GLX version: 1.4
OpenGL version string: 1.4 Mesa 7.10.2

prushik 04-10-2012 06:48 PM

Quote:

Originally Posted by manu-tm (Post 4649181)
I get the same error again (glXCreateContextAttribsARB not found).

I have:
GLX version: 1.4
OpenGL version string: 1.4 Mesa 7.10.2

Did you compile from source or use a deb package? I'm pretty sure that the problem is not due to mesa or GLX but rather your video card driver. What video card do you have? Is it an ATI Radeon by any chance?
Nevermind... I checked my source again and I seem to have added the problem code back in...

If you want to get it working, remove line 307 and recompile it and it should work.
The line that says:
Code:

        glutInitContextVersion (3, 1);
is the problem, just comment it out or delete it completely and it will compile and run.

Sorry about that.

manu-tm 04-10-2012 07:13 PM

I could run the game but it's very slow and keys are not working as expected.

prushik 04-11-2012 06:33 PM

Quote:

Originally Posted by manu-tm (Post 4649706)
I could run the game but it's very slow and keys are not working as expected.

Very interesting... I haven't had any trouble with speed. If I disable the timing, then it runs too fast on my machines, even my 6 year old hp laptop (the beast).
However, I have not yet tested the new timing mechanism on more than one machine, so next time I will revert to the old timing mechanism.

Where did you see speed as an issue? During solo gameplay, network gameplay, or in the menus? Are you using 32 bit or 64 bit?

It's really not a very resource intensive game, speed shouldn't be an issue (except in network games).

manu-tm 04-12-2012 09:19 AM

Something is wrong with keyboard mapping. You probably should fix that first.


All times are GMT -5. The time now is 10:43 PM.