LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (http://www.linuxquestions.org/questions/linux-games-33/)
-   -   Installed CS (not steam) on linux, but it asks me to change color to 16 bit??? (http://www.linuxquestions.org/questions/linux-games-33/installed-cs-not-steam-on-linux-but-it-asks-me-to-change-color-to-16-bit-134113/)

RHLinuxGUY 01-12-2004 05:02 PM

Installed CS (not steam) on linux, but it asks me to change color to 16 bit???
 
When i start CS ($ wine -- cstrike.exe) it begins to start, but then asks me to change the color to at least 16 bit high color. im not sure what to do? Do i need to install 1.5? or what, i wanna play some cd on my fav. OS. thanx in advance...

PS. im using RHLinux 9 with kernel 2.6, and an ATI 9600 ALL in Wonder, with the latest drivers...

ac1980 01-12-2004 06:08 PM

I suppose your linux system actually runs X with at least 16bpp.
Check in the x11 section of your .wine/config the screendepth variable: it should be:
1. >=16
2. compatible with your X configuration: i.e. if you didn't setup any 16bit mode, you may have to try 24 or 32
3. uncommented :)

bhaskie 01-12-2004 06:15 PM

Check the wine settings. Adjust the color depth in the wine config file. Seems the color depth is set to low.

What setting do you have in the /etc/X11/XF86Config-4 ? Check the Section "Screen"
It should have a line like --> DefaultDepth 24

RHLinuxGUY 01-14-2004 03:37 PM

I've changed it both to color depth 24 but it still sayd that, did i miss something?

bhaskie 01-16-2004 09:26 PM

Have you checked the game's configuration settings? Maybe there is a problem running this version of the game! Anyways, try running strace on the game to see where it falters. I was trying to run America's Army in debian unstable and it always used to crash. Finally after debugging and a lot of googling, I found that it is a problem with the distro. It just tries to read libraries from the wrong path. Runs perfectly in Redhat 9.
The point is to see whether your game is not being able to read certain files or is looking for them in the wrong path.

RHLinuxGUY 01-28-2004 07:31 PM

Ok, it is still saying 16bit color this is getting gay. more help please

The SIN Raven 02-01-2004 04:42 PM

I had the same problem.
Just change the colours in XF86Config-4 to 16, and you should not have any more problems...
Thake care.

The SIN Raven

Kolyn_Kryw 05-05-2008 05:49 AM

hmm . .didnt know it would auto complete . . I feel so inferior in the linux forum :( lol


All times are GMT -5. The time now is 10:50 PM.