LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices



Reply
 
Search this Thread
Old 10-29-2005, 12:52 AM   #1
aeuzent
Member
 
Registered: Jan 2005
Location: Maryland, USA
Distribution: Ubuntu/Debian
Posts: 102

Rep: Reputation: 15
Garbled Stepmania Sound


Alright I have the newest versions of the Stepmaina binaries on my system. The program runs fine. But the sound is very screwed up and seems to have a staticy delay.

This is the output I get when I run the program

Code:
StepMania 3.9 rc4
Log starting 2005-10-29 01:42:50
Couldn't load driver gtk: dlopen(): /prog/StepMania-3.9-rc4/./GtkModule.so: cannot open shared ob ject file: No such file or directory
Loading window: sdl
OS: Linux ver 020612
Crash backtrace component: x86 custom backtrace
Crash lookup component: dladdr
Crash demangle component: cxa_demangle
Runtime library: glibc 2.3.5
Threads library: NPTL 2.3.5
TLS is available
ALSA: Advanced Linux Sound Architecture Driver Version 1.0.9 (Sun May 29 07:31:02 2005 UTC).
ALSA Driver: 0: ESS Allegro PCI [PCI], device 0: Allegro [Allegro], 1/2 subdevices avail
Couldn't load driver ALSA: Not enough substreams for hardware mixing, using software mixing
ALSA: Software mixing at 44100hz
Sound driver: ALSA-sw
Video renderers: 'opengl'
SDL version: 1.2.8
Got 16 bpp (5650), 16 depth, 0 stencil
OGL Vendor: NVIDIA Corporation
OGL Renderer: GeForce2 MX/AGP/SSE
OGL Version: 1.5.3 NVIDIA 76.67
OGL Extensions: GL_ARB_imaging GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_point_sprite GL _ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_compression GL_ARB_texture_cube_ma p GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_mirror ed_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_ver tex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_ multi_draw_arrays GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_pixel_buffer_object GL_EXT_ point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_E XT_shared_texture_palette GL_EXT_stencil_wrap GL_EXT_texture_compression_s3tc GL_EXT_texture_cube _map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_ filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex _array GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_squa re GL_NV_fence GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_pixel _data_range GL_NV_point_sprite GL_NV_register_combiners GL_NV_texgen_reflection GL_NV_texture_env _combine4 GL_NV_texture_rectangle GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex _program GL_NV_vertex_program1_1 GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_lod  GL_SUN_slice_accum
OGL Max texture size: 2048
GLU Version: 1.3
Display: :0.0 (screen 0)
Direct rendering: yes
X server vendor: The X.Org Foundation [6.8.2.0]
Server GLX vendor: NVIDIA Corporation [1.3]
Client GLX vendor: NVIDIA Corporation [1.3]
Fullscreen 640x480 16 color 16 texture 0Hz Vsync AA
Found 0 joysticks
Input devices changed from '' to 'Keyboard'.
Remapping joysticks.
Mixing 372.923439 ahead in 1698 Mix() calls
Players joined: P1
Language: english
Current renderer: OpenGL
Theme: default
I see three possible errors.
One is that it's not loading the GTK module
The second is that It's not reading my sound card and is skipping straight into software.
And the third being the error about substreams.

I'm not sure about how to fix any of these and would like any help possible.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mepis + SB Audigy 2 NX garbled sound jughead Linux - Hardware 3 11-23-2005 12:10 PM
Stepmania fails attempting to find sound driver ktvoelker Linux - Games 5 11-18-2004 12:02 PM
mplayer garbled sound bluedude2288 Linux - General 5 07-15-2004 01:02 PM
MPlayer sound is garbled mrsolo Linux - Software 3 05-07-2004 10:57 AM
Stepmania Sound Issues Aman9090 Linux - Games 2 02-16-2004 08:27 PM


All times are GMT -5. The time now is 11:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration