LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices



Reply
 
Search this Thread
Old 02-23-2011, 03:18 PM   #1
Emerald-Rose
Member
 
Registered: Jan 2011
Distribution: Arch linux, Ubuntu, Debian
Posts: 38
Blog Entries: 1

Rep: Reputation: 0
Games cause Ubuntu to..."reset"


I recently inherited my parents' old Compaq Presario 6000. My laptop is dual booted with arch and windows 7, but I wanted this computer to run something different, so because only Ubuntu will let easytether to work, i chose it. I installed ii-esu, exult, and holotz castle so i had something to do between homework and writing. All three cause my screen to black for a second, then reverts to the login screen. At first i thought it was just my hardware and decided to play I Wanna Be The Guy using Wine. I had run the game before under windows, so i knew it should work. When i tried to run it, i got the same result as with the aforementioned games, except this one brought up the start screen for about a split second before reverting back to the login screen. Since that ruled out a hardware problem, i decided to try Desktop Dungeons with no success. So basically i have 3 games installed through the Ubuntu software center, and 2 games that worked fine in windows, and all 5 are causing Ubuntu to reset back to the login screen when i try to play them. I have updated all my packages and software and IWBTG rules out hardware, so any input at all on this issue is very appreciated
 
Old 02-24-2011, 08:57 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,651
Blog Entries: 2

Rep: Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095
If it brings you back to the login screen, I would assume that your xserver was restarted. So please post which video hardware with which driver you are using. Your /var/log/Xorg.0.log can also help, if you have a look at it after the game crashes.
 
Old 02-24-2011, 01:40 PM   #3
rizzy
Member
 
Registered: Mar 2004
Distribution: Debian
Posts: 283

Rep: Reputation: 65
Quote:
Originally Posted by Emerald-Rose View Post
... only Ubuntu will let easytether to work....
Not true, tested myself on Debian and Crunchbang, works really well. Nowdays, i much prefer Barnacle WiFi tether app - needs phone rooting though
 
Old 02-24-2011, 03:15 PM   #4
Emerald-Rose
Member
 
Registered: Jan 2011
Distribution: Arch linux, Ubuntu, Debian
Posts: 38
Blog Entries: 1

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by TobiSGD View Post
If it brings you back to the login screen, I would assume that your xserver was restarted. So please post which video hardware with which driver you are using. Your /var/log/Xorg.0.log can also help, if you have a look at it after the game crashes.
since i was lazy and didn't dual boot i cannot run sysspec to check hardware, but another thread showed me a command that supposedly works the same, but it doesn't look quite the same, but if you can make heads or tails of it here it is
er-da209a-aba-6331rsh-na850
description: Computer
width: 32 bits
*-core
description: Motherboard
physical id: 0
*-memory
description: System memory
physical id: 0
size: 464MiB
*-cpu
product: AMD Athlon(tm) XP 2200+
vendor: Advanced Micro Devices [AMD]
physical id: 1
bus info: cpu@0
version: 6.8.0
size: 1800MHz
width: 32 bits
capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up
*-cache:0
description: L1 cache
physical id: 0
size: 128KiB
*-cache:1
description: L2 cache
physical id: 1
size: 256KiB
*-pci
description: Host bridge
product: VT8375 [KM266/KL266] Host Bridge
vendor: VIA Technologies, Inc.
physical id: 100
bus info: pci@0000:00:00.0
version: 00
width: 32 bits
clock: 66MHz
configuration: driver=agpgart-via latency=8
resources: irq:0 memory:e8000000-ebffffff
*-pci
description: PCI bridge
product: VT8633 [Apollo Pro266 AGP]
vendor: VIA Technologies, Inc.
physical id: 1
bus info: pci@0000:00:01.0
version: 00
width: 32 bits
clock: 66MHz
capabilities: pci normal_decode bus_master cap_list
resources: memory:ec000000-edffffff memory:e0000000-e7ffffff
*-display UNCLAIMED
description: VGA compatible controller
product: VT8375 [ProSavage8 KM266/KL266]
vendor: S3 Inc.
physical id: 0
bus info: pci@0000:01:00.0
version: 00
width: 32 bits
clock: 66MHz
capabilities: vga_controller bus_master cap_list
configuration: latency=32 maxlatency=255 mingnt=4
resources: memory:ed000000-ed07ffff memory:e0000000-e7ffffff memory:ec000000-ec00ffff
*-communication UNCLAIMED
description: Communication controller
product: USR 56k Internal WinModem
vendor: 3Com Corp, Modem Division
physical id: 8
bus info: pci@0000:00:08.0
version: 00
width: 32 bits
clock: 33MHz
capabilities: cap_list
configuration: latency=0
resources: memory:ef019000-ef01903f memory:ef000000-ef00ffff memory:ef010000-ef017fff ioport:d000(size=64)
*-network
description: Ethernet interface
product: RTL-8139/8139C/8139C+
vendor: Realtek Semiconductor Co., Ltd.
physical id: b
bus info: pci@0000:00:0b.0
logical name: eth0
version: 10
serial: 00:40:ca:3d:2e:e3
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list rom ethernet physical
configuration: broadcast=yes driver=8139too driverversion=0.9.28 latency=32 maxlatency=64 mingnt=32 multicast=yes
resources: irq:18 ioport:d400(size=256) memory:ef018000-ef0180ff memory:20000000-2000ffff
*-isa
description: ISA bridge
product: VT8233A ISA Bridge
vendor: VIA Technologies, Inc.
physical id: 11
bus info: pci@0000:00:11.0
version: 00
width: 32 bits
clock: 33MHz
capabilities: isa bus_master cap_list
configuration: latency=0
*-ide
description: IDE interface
product: VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE
vendor: VIA Technologies, Inc.
physical id: 11.1
bus info: pci@0000:00:11.1
version: 06
width: 32 bits
clock: 33MHz
capabilities: ide bus_master cap_list
configuration: driver=pata_via latency=32
resources: irq:23 ioport:1f0(size=8) ioport:3f6 ioport:170(size=8) ioport:376 ioport:d800(size=16)
*-usb:0
description: USB Controller
product: VT82xxxxx UHCI USB 1.1 Controller
vendor: VIA Technologies, Inc.
physical id: 11.2
bus info: pci@0000:00:11.2
version: 23
width: 32 bits
clock: 33MHz
capabilities: uhci bus_master cap_list
configuration: driver=uhci_hcd latency=32
resources: irq:21 ioport:dc00(size=32)
*-usb:1
description: USB Controller
product: VT82xxxxx UHCI USB 1.1 Controller
vendor: VIA Technologies, Inc.
physical id: 11.3
bus info: pci@0000:00:11.3
version: 23
width: 32 bits
clock: 33MHz
capabilities: uhci bus_master cap_list
configuration: driver=uhci_hcd latency=32
resources: irq:21 ioport:e000(size=32)
*-multimedia
description: Multimedia audio controller
product: VT8233/A/8235/8237 AC97 Audio Controller
vendor: VIA Technologies, Inc.
physical id: 11.5
bus info: pci@0000:00:11.5
version: 40
width: 32 bits
clock: 33MHz
capabilities: cap_list
configuration: driver=VIA 82xx Audio latency=0
resources: irq:22 ioport:e400(size=256)
*-scsi:0
physical id: 1
bus info: scsi@2
logical name: scsi2
capabilities: scsi-host
configuration: driver=usb-storage
*-scsi:1
physical id: 2
bus info: scsi@3
logical name: scsi3
capabilities: scsi-host
configuration: driver=usb-storage
*-network
description: Ethernet interface
physical id: 3
logical name: easytether0
serial: 02:00:54:74:68:72
capabilities: ethernet physical
configuration: broadcast=yes driver=tun driverversion=1.6 firmware=N/A ip=192.168.117.2 multicast=yes
as for drivers. From the looks of it i have pretty much all my Xorg drivers for an AMD processor. And the /var/log/Xorg.0.log says permission denied and when executed using sudo it says no such file or directory

Last edited by Emerald-Rose; 02-24-2011 at 07:25 PM. Reason: New info uncovered
 
Old 03-05-2011, 12:31 AM   #5
Emerald-Rose
Member
 
Registered: Jan 2011
Distribution: Arch linux, Ubuntu, Debian
Posts: 38
Blog Entries: 1

Original Poster
Rep: Reputation: 0
Still waiting on a solution to this thread, last issue i have that is unsolved. would really like to wrap it up and finally have all 3 of my distros running properly
 
Old 04-01-2011, 08:53 AM   #6
Captain Obvious
LQ Newbie
 
Registered: Sep 2009
Distribution: Ubuntu Oneiric Ocelot
Posts: 8

Rep: Reputation: 0
I noticed your graphics card configuration doesn't list a driver. What does your Xorg config file look like (if you have one).

run:

Code:
cat /etc/X11/xorg.conf > $HOME/Desktop/xorg.conf
and copy & paste that file to the thread

Also, what version of Ubuntu are you running?

EDIT: Also, list the output of

Code:
glxinfo | grep OpenGL

Last edited by Captain Obvious; 04-01-2011 at 08:57 AM.
 
  


Reply

Tags
ubuntu, wine


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"clear" and "reset" bash commands broken AviJacobson Linux - General 6 07-03-2006 07:28 AM
"clear" and "reset" bash commands broken AviJacobson Linux - Software 1 06-29-2006 03:31 PM


All times are GMT -5. The time now is 04:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration