LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 11-16-2006, 06:12 AM   #1
locodude
LQ Newbie
 
Registered: Apr 2004
Distribution: Fedora Core
Posts: 5

Rep: Reputation: 0
Angry Fullscreen games crash X in Fedora Core 6 with nVidia-card.


I'm thinking that my problem is related to the latest nVidia-drivers but I'm not sure.
What happens is that as soon as I start up a game that runs in fullscreen-mode it immediately causes X to crash and I'm thrown out and presented with either a plain text-mode login prompt or X restarts and I login that way. With some games I don't even get that though as the screen just goes black and I have to push the "reboot"-button on my machine instead.

I'm running Fedora Core 6 with the latest kernel-update (2.6.18-1.2849) and the latest nVidia-drivers (1.0.9629-1) from livna.org.

I've checked in /var/log/messages and /var/log/Xorg.0.log but I can't find anything that is even remotely

The games I've had crash on me so far are PPRacer, Abe, Freedoom, Tremulous, SuperTux, SuperTuxKart and Doom. I can still play Freedroid and Frozen Bubble since they don't run in fullscreen mode.

Weirdly enough I am able to play BZFlag with the fullscreen stretching across both of my TFT-monitors without it crashing or anything.

More info about my system: I'm running a dual head rig with Intel Core 2 Duo E6600, 2GB RAM and a Asus GF7900GS videocard.

Can anybody at least offer me some advice on how I am to go about searching for what is wrong? I'm very annoyed with this at this point.
 
Old 11-16-2006, 10:01 AM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 327Reputation: 327Reputation: 327Reputation: 327
The later 9xxx Nvidia drivers are causing problems on all my systems. I've backed out to 8776, which seems stable. For more information, you can check at the Nvidia Linux Forum.
 
Old 11-21-2006, 11:56 PM   #3
Dr. Wiley
LQ Newbie
 
Registered: Nov 2006
Posts: 3

Rep: Reputation: 0
NVidea driver and fedora 6

Hi folks,

I'm also running the latest ferdora core 6 kernel, and I loaded the 1.0.96291-1 nvidea driver from the freshrpms site. When it boots I see the nice nvidea splash screen, but whne I go to the Applications->System tools->NVIDEA X server settings panel and I click on the OpenGL/GLX info option, it logs me out of my session to a command line and then restarts X, displays the nvidea splash screen again, and asks me to relog in. Before I installed the new driver, I had HL2 running under steam with wine. Now when I try to execute "wine steam.exe" I get logged out as described.

My graphics card is a couple years old; its a Geforce4 4200 accoreding to the nvidea server settings tool.

Any advice would be appreciated, like how exactly do you back out the driver to a previous version?

-Wiley
 
Old 11-26-2006, 11:25 PM   #4
gchandler
Member
 
Registered: Aug 2003
Location: Australia
Distribution: Linux Mint 10
Posts: 69

Rep: Reputation: 15
fc6 +nVidia-drivers 1.0.9629-1

I'm also running Fedora Core 6 with the latest kernel-update (2.6.18-1.2849) and the latest nVidia-drivers (1.0.9629-1) from livna.org. Noticed that ppracer was reporting 17-19fps and glxgears reported 9fps! Since all was well previously, I assume that it is the driver. Does anyone have any solutions yet?
 
Old 11-28-2006, 02:35 AM   #5
notebookuser
LQ Newbie
 
Registered: Dec 2005
Posts: 3

Rep: Reputation: 0
http://www.linuxquestions.org/questions/showthread.php?t=503808

see the link on the subject line
 
Old 11-28-2006, 03:25 AM   #6
gchandler
Member
 
Registered: Aug 2003
Location: Australia
Distribution: Linux Mint 10
Posts: 69

Rep: Reputation: 15
Quote:
Originally Posted by notebookuser
see the link on the subject line
http://www.linuxquestions.org/questi...d.php?t=503808

This link refers to a manual change of resolution to 800x600. A bit silly really when the problem is that the latest Nvidia drivers from livna don't work properly in fc6. Playing ppracer at any screen resolution gives a reported 17frames per second. glxgears reports about 10fps. I would say I have no 3D and that there is a problem with the driver as it worked fine with the previous version. I tried a later version from livna testing, but it just crashed X altogether. I guess that's why they have "testing"

Many thanks for the suggestion, but as Im still stuck any further strategies greatly appreciated
 
Old 11-30-2006, 07:33 PM   #7
Andrew O. Shadoura
LQ Newbie
 
Registered: Nov 2006
Posts: 1

Rep: Reputation: 0
I have Debian testing ("Etch") with 2.6.17-2 kernel (from linux-image-2.6.17-2-686_2.6.17-9_i386.deb), and NVIDIA drivers version 1.0-9629 (from NVIDIA-Linux-x86-1.0-9629-pkg1.run) and I have the same problems - no program can use fullscreen mode, it crash X.org immediately. Previous version (1.0-8774) didn't work with etch, but worked fine with sarge, so after I dist-upgraded my sarge I've installed the latest release. And now I have this
 
Old 12-09-2006, 09:42 PM   #8
Dr. Wiley
LQ Newbie
 
Registered: Nov 2006
Posts: 3

Rep: Reputation: 0
Talking The fix is in

Hi Folks,

I found out that there is now an updated driver at the nvidea site, version 1.0.9631. Here is the link:

http://www.nvidia.com/object/linux_d..._1.0-9631.html

The nvidea site gives you a script that you need to execute when X is not running. To do this I rebooted at run level 3.

Once installed everything seems to work fine.

By the way, does anyone know how to leave the gnome interface and stop X without having to reboot in Fedora 6?

Thanks,
Wiley
 
Old 12-10-2006, 08:59 AM   #9
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 327Reputation: 327Reputation: 327Reputation: 327
Logoff, then hit ctrl-alt-F1. This will bring you to a command-line terminal session. Login as root, and enter the command 'telinit 3'. When you get your prompt (you may have to hit enter if messages were displayed), you are at runlevel 3. Once you have installed the Nvidia driver, you can enter the command 'telinit 5;exit'. This will return you to a runlevel 5 X login, and end your command line root session.
 
Old 12-11-2006, 02:30 AM   #10
echat
Member
 
Registered: Nov 2006
Distribution: Kubuntu 9
Posts: 34

Rep: Reputation: 16
X crashes anytime openGL loads

I recently installed my NVidia GeForce 4 MX 420 drivers in fc6.
The problem Im having didnt come until the conf file generated w/ nvidia software replaced my conf file.
On one boot I was able to see my OpenGL and all it's splender. But I made a noob mistake of not backing up my conf file.
Any one know how I can resolve this problem?

heres my conf file:
Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder3)  Thu Nov  9 17:56:12 PST 2006

Section "ServerLayout"
      Identifier     "Layout0"
      Screen      0  "Screen0" 0 0
      InputDevice    "Keyboard0" "CoreKeyboard"
      InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
      RgbPath         "/usr/X11R6/lib/X11/rgb"
      FontPath        "unix/:7100"
EndSection

Section "Module"
#     REMOVED LOAD STATMENTS > ./Module.bk
      Load           "extmod"
      Load           "glx"
EndSection

Section "ServerFlags"
      Option         "Xinerama" "0"
EndSection

Section "InputDevice"
      # generated from default
      Identifier     "Mouse0"
      Driver         "mouse"
      Option         "Protocol" "auto"
      Option         "Device" "/dev/input/mice"
      Option         "Emulate3Buttons" "no"
      Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
      # generated from data in "/etc/sysconfig/keyboard"
      Identifier     "Keyboard0"
      Driver         "kbd"
      Option         "XkbLayout" "us"
      Option         "XkbModel" "pc105"
EndSection

Section "Monitor"
      # HorizSync source: edid, VertRefresh source: edid
      Identifier     "Monitor0"
      VendorName     "Unknown"
      ModelName      "COMPAQ V75"
      HorizSync       30.0 - 69.0
      VertRefresh     50.0 - 120.0
      Option         "DPMS"
EndSection

Section "Device"
      Identifier     "Videocard0"
      Driver         "nvidia"
      VendorName     "NVIDIA Corporation"
      BoardName      "GeForce4 MX 420"
EndSection

Section "Screen"
      Identifier     "Screen0"
      Device         "Videocard0"
      Monitor        "Monitor0"
      DefaultDepth    24
      Option         "metamodes" "CRT: 1280x1024 +0+0"
        SubSection     "Display"
            Depth       24
            Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection
ps: I Don't even have to be in fullscreen mode to crash. X crashes even when I access the openGL screensavers or while trying to access OpenGL information via Nvidia software.

ps#2: I also removed a few mods from the conf file that wernt there before, no luck.

Last edited by echat; 12-11-2006 at 02:38 AM.
 
Old 12-11-2006, 03:16 AM   #11
echat
Member
 
Registered: Nov 2006
Distribution: Kubuntu 9
Posts: 34

Rep: Reputation: 16
I Fixed my problem.

I found a backup that the nivida software created.
Here is my new old conf file:

Code:
# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        ModulePath   "/usr/lib/xorg/modules/extensions/nvidia"
        ModulePath   "/usr/lib/xorg/modules"
EndSection

Section "Module"
        Load  "fbdevhw"
        Load  "record"
        Load  "freetype"
        Load  "type1"
## for nVidia driver
        Load  "glx"
        Load  "dbe"
        Load  "extmod"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        Option      "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1280x1024" "1280x960" "1280x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection
 
Old 12-12-2006, 02:31 AM   #12
gchandler
Member
 
Registered: Aug 2003
Location: Australia
Distribution: Linux Mint 10
Posts: 69

Rep: Reputation: 15
Thanks for posting your xorg.conf. I have been having problems with the 2 latest iterations of the Nvidia drivers from Livna. Framerates in glxgears of 9fps! But in comparing my xorg.conf to your working version, I realised that the section "Module" was completely missing! presumably removed by one of the updates

Quote:
Section "Module"
Load "fbdevhw"
Load "record"
Load "freetype"
Load "type1"
## for nVidia driver
Load "glx"
Load "dbe"
Load "extmod"
EndSection
No wonder no glx. Inserting that section solved all my problems too. Hope this helps others.
 
Old 12-15-2006, 11:31 PM   #13
echat
Member
 
Registered: Nov 2006
Distribution: Kubuntu 9
Posts: 34

Rep: Reputation: 16
Re:

Glad I could help.
 
Old 12-16-2006, 11:41 PM   #14
uglydot
Member
 
Registered: Mar 2003
Distribution: Gentoo
Posts: 232

Rep: Reputation: 30
Install the 9631 drivers.
 
Old 12-30-2006, 03:53 PM   #15
Dr. Wiley
LQ Newbie
 
Registered: Nov 2006
Posts: 3

Rep: Reputation: 0
Unhappy Here we go again

I just did an update with yum from freshrpms site, and it installed a new nvidea driver; nvidia-x11-drv-1.0.9746-1.i386.rpm.

Well unforntuately it doesnt run open gl. I tried adding the modele information as suggested in the above posts with no luck. I think I will have to back it out to the .9631 version.

Has this happened to anyone else?

Thanks,
Wiley
 
  


Reply

Tags
crash, fullscreen, nvidia


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fullscreen games very slow with Nvidia TNT2 NCC-1701&NCC-1701-D Linux - Hardware 1 06-14-2005 11:35 AM
games in fedora core 3 fbs2003 Linux - Software 9 06-13-2005 12:16 AM
fedora core raid crash! glue Linux - Software 0 09-15-2004 04:44 PM
TV-out working with NVIDIA card and fedora core 2 Vie Linux - Hardware 6 09-12-2004 04:49 AM
fedora core 2 + xwindows + nvidia card dualhead problem Insurr3cti0n Fedora 1 06-04-2004 01:20 AM


All times are GMT -5. The time now is 01:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration