LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 10-02-2004, 06:33 PM   #1
the_sLiDe
Member
 
Registered: Sep 2004
Distribution: Slack 10
Posts: 155

Rep: Reputation: 30
Question Enemy Territory help


When i try to start enemy territory i get this:

ET 2.56 linux-i386 Sep 10 2003
----- FS_Startup -----
Current search path:
/home/nic/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak1.pk3 (10 files)
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (4 files)
/usr/local/games/enemy-territory/etmain

----------------------
3739 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Error couldn't open the X display
...WARNING: could not set the given mode (4)
Initializing OpenGL display
...setting mode 3: 640 480
Error couldn't open the X display
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem

Anyone kno wut it means?? Thx.
 
Old 10-02-2004, 06:49 PM   #2
zackarya
Member
 
Registered: Jul 2003
Distribution: OpenSuse 10, Debian
Posts: 152

Rep: Reputation: 30
Enemy territory

Well, it says it can't open the X display. Could be your trying to run as a different user than the one who opened the X server? Can you run glgears?
I know it's not much, but a place to start. Good Luck.
 
Old 10-02-2004, 06:51 PM   #3
the_sLiDe
Member
 
Registered: Sep 2004
Distribution: Slack 10
Posts: 155

Original Poster
Rep: Reputation: 30
Yeah...i tried running as root and i got this:

ET 2.56 linux-i386 Sep 10 2003
----- FS_Startup -----
Current search path:
/root/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak1.pk3 (10 files)
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (4 files)
/usr/local/games/enemy-territory/etmain

----------------------
3739 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
Xlib: extension "XFree86-DGA" missing on display ":0.0".
Failed to detect XF86DGA Mouse
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 16 depth, 0 stencil display.
GL_RENDERER: Mesa GLX Indirect


***********************************************************
You are using software Mesa (no hardware acceleration)!
Driver DLL used: libGL.so.1
If this is intentional, add
"+set r_allowSoftwareGL 1"
to the command line when starting the game.
***********************************************************
...WARNING: could not set the given mode (4)
Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XFree86-VidModeExtension Activated at 640x480
Received signal 11, exiting...
 
Old 10-02-2004, 08:32 PM   #4
sc3252
Member
 
Registered: Feb 2004
Location: sac, ca
Distribution: mandrake/debian
Posts: 65

Rep: Reputation: 15
it doesnt look like direct rendering is enabled. run glxinfo to see if it is. Also what type of video card do you have?
 
Old 10-15-2004, 10:03 PM   #5
Zwan
LQ Newbie
 
Registered: Oct 2004
Posts: 11

Rep: Reputation: 0
i have the exact same problem, no its not enables, how do i enable it? (ati 9800 xt)
 
Old 10-17-2004, 11:10 PM   #6
pAn1k
Member
 
Registered: Jun 2004
Location: Cala city
Distribution: Suse 10.0; Debian 5.0 (Lenny) Fluxbox
Posts: 240

Rep: Reputation: 30
Try drivers from either DRI or ATI, that should fix it. It may take a while depending on your set up and stick-to-it-ev-ness...yeah. Good luck.
 
Old 10-26-2004, 03:38 PM   #7
the_sLiDe
Member
 
Registered: Sep 2004
Distribution: Slack 10
Posts: 155

Original Poster
Rep: Reputation: 30
Fixed.
 
Old 10-27-2004, 12:45 AM   #8
Zwan
LQ Newbie
 
Registered: Oct 2004
Posts: 11

Rep: Reputation: 0
"gives up"
 
Old 10-27-2004, 04:41 AM   #9
Hammett
Senior Member
 
Registered: Aug 2003
Location: Barcelona, Catalunya
Distribution: Gentoo
Posts: 1,037

Rep: Reputation: 54
Quote:
Originally posted by the_sLiDe
Fixed.
It would be really nice if you can post how did you manage to get it to work, so other users with the same problem may benefeit from your experience share.
 
Old 10-27-2004, 09:23 AM   #10
the_sLiDe
Member
 
Registered: Sep 2004
Distribution: Slack 10
Posts: 155

Original Poster
Rep: Reputation: 30
Ok, well i'm at school and i don't know exactly wut i did. I edited my xorg.conf so that it used the nvidia drivers instead of the "vesa" or "nv" driver. That's it!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enemy Territory Help lovetto Linux - Software 5 09-07-2005 10:49 PM
Enemy Territory Leviathan Linux - Newbie 8 02-02-2005 08:03 PM
Enemy Territory the_sLiDe Linux - Games 3 10-02-2004 06:50 PM
Enemy-Territory Jimbo99 Linux - Software 6 06-01-2004 12:19 AM
Enemy Territory Help coolmatty1000 Linux - Newbie 3 10-07-2003 02:17 PM


All times are GMT -5. The time now is 07:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration