LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 02-13-2005, 12:29 AM   #1
sabot
LQ Newbie
 
Registered: Jan 2004
Distribution: Ubuntu
Posts: 9

Rep: Reputation: 0
Enemy Territory does not play sound in ubuntu linux


After installing Enemy Territory in ubuntu linux 4.10 I was unable to get sound. The solution to this problem for me was to open the root terminal and enter:

echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss

Then I could open a normal terminal and enter:

et

This solved my sound problem. I have to enter the echo command each time I reboot to play the game and have sound. If you have a better way to get sound in Enemy Territory, please add to this thread.

Last edited by sabot; 02-13-2005 at 12:31 AM.
 
Old 02-13-2005, 07:03 AM   #2
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Rep: Reputation: 30
Do you have the sound daemon active?
Code:
ps -A | grep esd
if so, try without it
Code:
killall esd ; killall -9 esd; et

do you have access to the sound devices in rest?
Code:
id | grep audio
if not, (I doubt it) add your user to the audio group


what are the permisions under which the game runs?
Code:
ls -l /pathtogame/game
 
Old 04-17-2005, 08:21 AM   #3
Yert
LQ Newbie
 
Registered: Apr 2005
Posts: 1

Rep: Reputation: 0
The poster's fix for Ubuntu works, at least for me (default Ubuntu "Hoary Hedgehog" release).
 
Old 05-16-2005, 06:03 AM   #4
danielw
Member
 
Registered: Jul 2003
Location: Australia
Distribution: CRUX
Posts: 35

Rep: Reputation: 15
yeh it worked for me too.

I just put it in my rc.local and all is sweet.
 
Old 05-16-2005, 06:10 AM   #5
danielw
Member
 
Registered: Jul 2003
Location: Australia
Distribution: CRUX
Posts: 35

Rep: Reputation: 15
Check this out too: http://ubuntuforums.org/archive/index.php/t-17490.html

In summary...
Open up ~/.etwolf/etmain/profiles/%profilename%/etconfig.cfg and change
Code:
seta snddevice "/dev/dsp"
to
Code:
seta snddevice "/dev/adsp"
It doesn't work for me (mine is an AC97 card) but like the site says, it may work with others.

Last edited by danielw; 05-16-2005 at 06:22 AM.
 
Old 05-22-2005, 01:19 AM   #6
mrbass
LQ Newbie
 
Registered: Jul 2004
Posts: 25

Rep: Reputation: 15
I used to do the killall -9 esd each time before starting ET. My 6 year old kept calling me downstairs to do it for him. No need to do it any longer as I just did

sudo gedit /etc/esound/esd.conf

edit so it looks like so

[esd]
auto_spawn=1
spawn_options=-terminate -nobeeps -as 2 -d default
spawn_wait_ms=100
# default options are used in spawned and non-spawned mode
default_options=

This is taken from this thread and no I didn't do any of the other things like alsa.conf or whatever.
http://www.ubuntuforums.org/showthread.php?t=26567
 
Old 06-15-2005, 05:07 PM   #7
averagejoe84
Member
 
Registered: Jun 2005
Location: Florissant, MO
Distribution: Fedora 3/4, Centos, Suse 9.1-9.3, CentOS 4.1, Knopix
Posts: 34

Rep: Reputation: 15
I have a similar problem with ET in Fedora core 3 no sound in the game, I also have UT2004 and that sound works just fine, I have no idea what is wrong
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enemy-Territory won't Play Full Screen Jimbo99 Linux - Software 1 03-03-2005 03:00 PM
No sound in Enemy Territory wnaLinux Linux - Games 13 02-13-2005 05:00 PM
No sound only in Enemy Territory kjp_72 Linux - Newbie 0 05-22-2004 11:53 AM
Sound in Enemy Territory jeempc Linux - Hardware 5 03-02-2004 11:24 AM
Enemy Territory.. no sound?? trey85stang Linux - Games 3 12-20-2003 04:10 PM


All times are GMT -5. The time now is 05:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration