LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 03-19-2005, 12:19 AM   #1
Jason711
Member
 
Registered: Mar 2004
Distribution: suse 10.0
Posts: 45

Rep: Reputation: 15
Question doom3 hangs at "initializing menus"


any idea what could be causing this?

i have direct rendering and my audio is working. ...

im using SuSE 9.2 pro... i have downloaded fglrx drivers from suse's ftp..

i copied the .paks as it says... i renamed the .run to doom3.run and ran sh doom3.run

the install went fine as far as i can tell... the only question i may have about that is the links it made to a bin directory. (does it matter what dir? i used the default one)

do the fglrx drivers have to be patched for the s3tc compression?

thank you for any suggestions... let me know if i need to give you more information.
 
Old 03-19-2005, 12:24 AM   #2
Thoreau
Senior Member
 
Registered: May 2003
Location: /var/log/cabin
Distribution: All
Posts: 1,167

Rep: Reputation: 45
You need to install ATI's drivers, not Suse's. And even then I'm not sure if it will play properly because the game was made with Nvidia in mind. If you were using an Nvidia card, you would be playing your game now. Since that's not the case, get the latest ATI drivers and it might work.
 
Old 03-19-2005, 03:42 PM   #3
Jason711
Member
 
Registered: Mar 2004
Distribution: suse 10.0
Posts: 45

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Thoreau
You need to install ATI's drivers, not Suse's. And even then I'm not sure if it will play properly because the game was made with Nvidia in mind. If you were using an Nvidia card, you would be playing your game now. Since that's not the case, get the latest ATI drivers and it might work.
fuck.. this makes me want to rip the card out of my system and crush it.

im this close "--->||<---" to ordering a 6800NU.
 
Old 03-19-2005, 04:29 PM   #4
Jason711
Member
 
Registered: Mar 2004
Distribution: suse 10.0
Posts: 45

Original Poster
Rep: Reputation: 15
hey.. whats the difference between suse's and ati's?
 
Old 03-20-2005, 03:55 PM   #5
Jason711
Member
 
Registered: Mar 2004
Distribution: suse 10.0
Posts: 45

Original Poster
Rep: Reputation: 15
anybody?
 
Old 03-27-2005, 11:11 PM   #6
YeeHaa4LINUX
LQ Newbie
 
Registered: Sep 2004
Posts: 17

Rep: Reputation: 1
If anyone finds this.........

Doom 3 hangs at "Initializing Menus".

Some things you can do.

Start Doom3 in a console and dump the output to a file.
This will let you see what went wrong (sometimes).

So far all my Doom3 lock-ups have been due to sound card issues.

If you have an ATI card, you MUST use the latest fglrx package to run Doom3.
I use an ATI Radeon 9200 and would normally use the Linux drivers.
I switched to fglrx because I could not get GTKRadiant to work otherwise.

To get Doom3 running on Fedora Core 3 I had to do this:
doom3-demo +set in_tty 0 +set videoRam 128 >> ~/d3.log

I haven't tested on SuSE 9.1 yet but the freeze up there seems to be due to alsa issues.

I'm going to try adding +set s_alsa_pcm ###### where ##### is the alsa device name.
Otherwise I will try +set s_driver oss and see if it works that way.


Good Luck to you.
 
Old 03-27-2005, 11:44 PM   #7
Thoreau
Senior Member
 
Registered: May 2003
Location: /var/log/cabin
Distribution: All
Posts: 1,167

Rep: Reputation: 45
Don't crush your system. Nvidia just has better drivers on Linux at the moment. I know that Doom3 will run on your ATI card, just not with all the cool textures and such. The drivers disallow it.

If you decide to get a 6800, it will only make your life easier. I hate sounding like a fanboy, but that's just the way it is. Get used to disappointment or get an Nvidia card.
 
Old 03-28-2005, 12:26 AM   #8
Jason711
Member
 
Registered: Mar 2004
Distribution: suse 10.0
Posts: 45

Original Poster
Rep: Reputation: 15
supposedly i have a 6800 coming from somebody off ebay.
 
Old 03-28-2005, 09:14 PM   #9
YeeHaa4LINUX
LQ Newbie
 
Registered: Sep 2004
Posts: 17

Rep: Reputation: 1
I used to use Nvidia until this happened:

http://www.linuxquestions.org/questi...5&pagenumber=3
(look for the posts by me, YeeHaa4LINUX)

Read through the entire thread for more details.
I'm very afraid to try another Nvidia because of this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE hangs on "initializing peripherals" - zipslack 10.1 grooveharder Linux - Software 3 08-10-2005 03:42 PM
SuSE 9.2 - KDE hangs at "Initializing Peripherals" baraujo Suse/Novell 5 03-24-2005 10:57 AM
SuSE 9.1 Personal - KDE hangs at "Initializing Peripherals" knifeyspoony Linux - Distributions 7 11-20-2004 04:53 PM
boot hangs at "Initializing RT netlink socket" CraigG Red Hat 0 12-24-2003 10:51 AM
Installation hangs at "Initializing PC Card Devices" KennyK Linux - Newbie 5 08-28-2003 07:39 PM


All times are GMT -5. The time now is 03:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration