LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices



Reply
 
Search this Thread
Old 12-11-2009, 12:51 PM   #1
echat
Member
 
Registered: Nov 2006
Distribution: Kubuntu 9
Posts: 34

Rep: Reputation: 16
Angry DiabloII running in wine crash


Hello all, I recently installed D2 via wine And I added the proper native libs that wineHQ mentioned. I can run the installer no problem but when I try to run the game wine crashes.

Code:
ec0mp@estati0n:~/.wine/drive_c/Program Files/Diablo II$ wine Game.exe 
fixme:heap:HeapSetInformation (nil) 1 (nil) 0                         
fixme:advapi:RegisterEventSourceW ((null),L"Bonjour Service"): stub   
fixme:winsock:WS_setsockopt Unknown IPPROTO_IP optname 0x00000013     
fixme:winsock:WSAIoctl SIO_GET_EXTENSION_FUNCTION_POINTER {f689d7c8-6f1f-436b-8a53-e54fe351c322}: stub                                                          
fixme:winsock:WS_setsockopt Unknown level: 0x00000029                           
fixme:winsock:WS_setsockopt Unknown level: 0x00000029                           
fixme:winsock:WS_setsockopt Unknown level: 0x00000029                           
fixme:winsock:WS_setsockopt Unknown level: 0x00000029                           
fixme:winsock:WSAIoctl SIO_GET_EXTENSION_FUNCTION_POINTER {f689d7c8-6f1f-436b-8a53-e54fe351c322}: stub                                                          
fixme:winsock:WSAIoctl -> SIO_ADDRESS_LIST_CHANGE request: stub                 
fixme:iphlpapi:GetAdaptersAddresses no support for IPv6 addresses               
fixme:iphlpapi:GetAdaptersAddresses no support for IPv6 addresses               
fixme:winsock:WS_setsockopt Unknown IPPROTO_IP optname 0x00000013               
fixme:winsock:WSAIoctl SIO_GET_EXTENSION_FUNCTION_POINTER {f689d7c8-6f1f-436b-8a53-e54fe351c322}: stub                                                          
fixme:winsock:WS_setsockopt Unknown IPPROTO_IP optname 0x00000013               
fixme:iphlpapi:CreateIpForwardEntry (pRoute 0x87e998): stub                     
fixme:service:EnumServicesStatusW 0x12a1c0 type=30 state=3 (nil) 0 0x87e828 0x87e834 0x87e830                                                                   
fixme:advapi:ReportEventA (0xcafe4242,0x0004,0x0000,0x20000001,(nil),0x0001,0x00000000,0x87e638,(nil)): stub                                                    
fixme:advapi:ReportEventW (0xcafe4242,0x0004,0x0000,0x20000001,(nil),0x0001,0x00000000,0x129ff0,(nil)): stub                                                    
err:ntdll:RtlpWaitForCriticalSection section 0x137c24 #0001 wait timed out in thread 0009, blocked by 0000, retrying (60 sec)
fixme:service:EnumServicesStatusW 0x12a1c0 type=30 state=3 (nil) 0 0x87e810 0x87e81c 0x87e818
wine: Critical section 00137c24 wait failed at address 0x7ef83dc9 (thread 0009), starting debugger...

Unhandled exception: wait failed on critical section 0x00137c24
err:seh:raise_exception Unhandled exception code c0000194 flags 0 addr 0x7ef83dc9
ec0mp@estati0n:~/.wine/drive_c/Program Files/Diablo II$
ec0mp@estati0n:~/.wine/drive_c/Program Files/Diablo II$ Process of pid=0008 hasterminated
No process loaded, cannot execute 'echo Modules:'
Cannot get info on module while no process is loaded
No process loaded, cannot execute 'echo Threads:'
process  tid      prio (all id:s are in hex)
0000000e
        0000001d    0
        00000014    0
        00000010    0
        0000000f    0
00000011
        0000001b    0
        0000001a    0
        00000017    0
        00000013    0
        00000012    0
00000018
        0000001e    0
        0000001c    0
        00000019    0
00000022
        00000023    0
You must be attached to a process to run this command.
No process loaded, cannot execute 'detach'

ec0mp@estati0n:~/.wine/drive_c/Program Files/Diablo II$
I looked to wineHQ for help on this matter but came up empty, Anyone have any ideas?
 
Old 12-16-2009, 10:26 PM   #2
exvor
Senior Member
 
Registered: Jul 2004
Location: Phoenix, Arizona
Distribution: LFS-Version SVN-20091202, Arch 2009.08
Posts: 1,496

Rep: Reputation: 68
Install the updates to diablo before attempting to run them again. I cannot say however that this would resolve the problem but its a good place to start.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble running wine from src wine:error while loading shared libraries: libwine.so.1 brynjarh Linux - Newbie 2 05-28-2013 11:59 AM
Wine: How do I input into a running Wine Program with Cyrillic Characters? Riddick Linux - Software 3 08-16-2009 12:58 PM
Wine programs crash, memory or driver? tparker Linux - Software 1 02-24-2009 05:47 PM
Wine causing KDE to crash/logout Jayla Linux - Software 3 11-18-2007 08:12 AM
Cedega + DiabloII LOD nomb Linux - Software 2 02-26-2006 08:14 AM


All times are GMT -5. The time now is 04:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration