LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 04-25-2008, 08:51 PM   #1
Toxophilite
LQ Newbie
 
Registered: Feb 2008
Posts: 12

Rep: Reputation: 0
Exclamation Definitive Guide-Downloading and Installing Wolf:ET and TC:E on your comp [request]


I'm requesting the guide to end all guides for this subject.

Assuming I am within one inch of being utterly and completely mentally retarted, I beseech you; anyone, please write me a definitive, thorough, complete guide consulting how to download and install Wolfenstein:Enemy Territory, and its total conversion mod True Combat:Elite on my Ubuntu computer.

I've searched high and low for such guide. The one on the main website is 4 versions behind, so I assume its outdated. A guide on the TC:E site is 3 years old, other guides are helplessly confusing, other threads insist upon looking harder or linking me to a guide that is either old or confusing...

I am beyond asking for a generalized link. If you respond to this thread, please let it only be with a guide you wrote yourself, or a link to a guide that you know, possitively, definately, 110%, is accurate and up to date, and that speaks to an audience of people who know nothing of Linux and bought Linux the day they read the guide.

Saying something like /home/local/whatever is entirely worthless to me. Instead, translate it to /home(home refers to blahblahetc.)/local(the username you logged in with)/(the file you're looking for, which if you downloaded from so-and-so-link, should be called blahblahetc.).

Maybe it's a lot to ask for, but thats all I'm doing: I'm asking.
Obviously, if you don't want to, don't do it. Otherwise, in the name of God, please, PLEASE write/link me to the above-described guide, and in advance: I thank you with the utmost and fullest grattitude that I can possibly muster from the depths of my heart.
 
Old 04-26-2008, 04:45 AM   #2
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,138

Rep: Reputation: 49
Download from here:
http://returntocastlewolfenstein.fil...erritory;14408

after that it should be on your desktop (please put the distribution you are using in your profile... that makes things easier)
right-click the .run file - permissions - 'make executable'
leave the file menu and double click the .run file, and it will be installed.

Download true combat from here:
http://www.liflg.org/?catid=6&gameid=52
(seems to be the latest version) - I can't find the linux file on the original site.

same procedure as with the ET.run file.

If it doesn't work, please say what exactly didn't work. This shouldn't require a detailed howto
 
Old 04-27-2008, 12:51 AM   #3
Toxophilite
LQ Newbie
 
Registered: Feb 2008
Posts: 12

Original Poster
Rep: Reputation: 0
Talking

Quote:
Originally Posted by oskar View Post
(please put the distribution you are using in your profile... that makes things easier)

(seems to be the latest version) - I can't find the linux file on the original site.
Thank you SO much. I'm beginning the download right now. Can you make sure that's the latest version though, and if there are any patches?

Also, what did you mean by putting the distro in my profile..isn't ubuntu a distro?

Edit: I just finished downloading. Under the permissions menu, it doesn't give me any options/check-boxes to make it an executable.




Completely unrelated; if you could give me instructions for downloading/patching/updating the latest version of OpenArena and Tremulous, it'd be great, especially not having to make another thread

Last edited by Toxophilite; 04-27-2008 at 03:08 AM.
 
Old 04-27-2008, 05:07 PM   #4
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,138

Rep: Reputation: 49
Quote:
Thank you SO much. I'm beginning the download right now. Can you make sure that's the latest version though, and if there are any patches?
No, I can't

Quote:
Also, what did you mean by putting the distro in my profile..isn't ubuntu a distro?
Yes, if you are using ubuntu, you should either put that into your LQ profile, or say that you use Ubuntu+ which version each time you ask a question.
/edit
I see you did in your post... I missed that. You might want to add it to your profile anyway.

Quote:
Edit: I just finished downloading. Under the permissions menu, it doesn't give me any options/check-boxes to make it an executable.
It should...
Anyway. - open the command line (applications - accessories - terminal)
type:

cd Desktop
chmod +x et-linux-2.55.x86.run

Quote:
Completely unrelated; if you could give me instructions for downloading/patching/updating the latest version of OpenArena and Tremulous, it'd be great, especially not having to make another thread
They should have instructions on their homepages. If you have trouble following them, you should stick to the versions that are provided by ubuntu, which should be fairly recent.

Last edited by oskar; 04-27-2008 at 05:20 PM.
 
Old 04-27-2008, 09:18 PM   #5
Toxophilite
LQ Newbie
 
Registered: Feb 2008
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by oskar View Post
It should...
Anyway. - open the command line (applications - accessories - terminal)
type:

cd Desktop
chmod +x et-linux-2.55.x86.run


They should have instructions on their homepages. If you have trouble following them, you should stick to the versions that are provided by ubuntu, which should be fairly recent.

The download manager sucks. Most of its versions are outdated, and if you don't have the latest version of OpenArena you can't play online at all, period.

I've done the thing where you make something executable, but I sware, it doesn't give me that option this time. It just says:

Owner: kieran(kieran)
Access: Read & Write


Group: kieran
Access: Read only


Others: Read only

...

There isn't any check box or whatever..and I'm the only user on this computer (kieran). Anyways, I'm going to try the chmod thing.


Edit: I did it...It didn't show any changes, just this:

kieran@kieran-desktop:~$ cd Desktop
kieran@kieran-desktop:~/Desktop$ chmod +x et-linux-2.55.x86.run
kieran@kieran-desktop:~/Desktop$

Edit #2: I used the installer, and when it finished I didn't click start. I went into the terminal and typed et, but it said bash: command doesn't exist blah blah etc. What happened...?

Last edited by Toxophilite; 04-27-2008 at 09:24 PM.
 
Old 04-28-2008, 03:27 AM   #6
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,138

Rep: Reputation: 49
cd into the et directory (probably enemy-territory, if you haven't changed it)
and execute the binary from there:

cd enemy-territory
./et

And post the output here, if it doesn't start.
 
Old 04-28-2008, 09:40 PM   #7
Toxophilite
LQ Newbie
 
Registered: Feb 2008
Posts: 12

Original Poster
Rep: Reputation: 0
I did chmod +x true.combat.elite_0.49b-english-4.run
I ran the installer.

Error Message: You need Return to Castle Wolfenstein: Enemy Territory version 2.60(b)!

I think the problem is..I need Wolf:ET 2.60(b), which is kind of a patch to 2.60, and, the TC:E download you gave me is only 0.49(b), which is a patch to 0.49; not the full version. I need wolf 2.60b and tc:e 2.60. I don't know if I have to reinstall tc:e 0.49b after I do the regular 0.49...I hope not. Can you find those for me? Or tell me what I did wrong..
 
Old 04-28-2008, 09:45 PM   #8
Smedley
Registered User
 
Registered: Apr 2008
Distribution: Slackware
Posts: 74

Rep: Reputation: 15
Quote:
Originally Posted by Toxophilite View Post
I did chmod +x true.combat.elite_0.49b-english-4.run
I ran the installer.

Error Message: You need Return to Castle Wolfenstein: Enemy Territory version 2.60(b)!

I think the problem is..I need Wolf:ET 2.60(b), which is kind of a patch to 2.60, and, the TC:E download you gave me is only 0.49(b), which is a patch to 0.49; not the full version. I need wolf 2.60b and tc:e 2.60. I don't know if I have to reinstall tc:e 0.49b after I do the regular 0.49...I hope not. Can you find those for me? Or tell me what I did wrong..
Why not go here and check out these forums?

http://community.enemyterritory.com/
 
Old 04-29-2008, 04:42 PM   #9
Toxophilite
LQ Newbie
 
Registered: Feb 2008
Posts: 12

Original Poster
Rep: Reputation: 0
Because I'm being helped here...
Are you there oskar?

Edit: Where can I download Enemy Territory Linux Punkbuster?
I downloaded the Wolf:ET 2.60(b) like I mentioned in my above post, and I'm in the process of downloading TC:E 0.49 regular. I hope it still works even though I downloaded a patch before the real version...

Edit #2: I downloaded Wolf:ET 2.60 and 2.60(b)
I downloaded TC:E 0.49 and 0.49(b)
I have pbsetup.run on my desktop but I can't get it to run..even after I "chmod +x"'ed it.
When I try to enter a server it tells me to make sure my game is at its latest version, then disconnects me.
Tell my if you need anymore information about my problem.
Help =\

Edit #3: I tried to run a server to try the game out by myself. It said something about paks then disconnected me.
I tried again, this time checking the "auto-configure to default server settings" box. When I tried to run the server, the game closed.

Last edited by Toxophilite; 04-29-2008 at 06:35 PM.
 
Old 04-29-2008, 07:55 PM   #10
Toxophilite
LQ Newbie
 
Registered: Feb 2008
Posts: 12

Original Poster
Rep: Reputation: 0
Exclamation

Bump _________________________
 
Old 04-30-2008, 12:09 AM   #11
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,138

Rep: Reputation: 49
It would be easier to understand what your problem is, if you tried whatever you did PRIOR to posting instead of informing me about every single step.

I installed ET. It asked me if I wanted to enable punkbuster when I created my profile... you probably left that out.

You're probably really better off at the TC forums:
http://www.truecombatelite.net/forum/index.php

I don't play this game, so I can't help you with any game related issues.
 
Old 05-01-2008, 08:25 AM   #12
Toxophilite
LQ Newbie
 
Registered: Feb 2008
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by oskar View Post
... you probably left that out.

You're probably really better off at the TC forums:
http://www.truecombatelite.net/forum/index.php
Nope

They wont send my e-mail confirmation, no matter how many accounts I make or what computer I try....

Thanks for your help so far, I wouldn't have gotten this far without you.

Last edited by Toxophilite; 05-01-2008 at 04:20 PM.
 
  


Reply

Tags
elite, enemy, guide, territory, true


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: CSS: The Definitive Guide, Third Edition LXer Syndicated Linux News 0 11-29-2006 09:54 PM
The definitive guide to lilo boot-splashing Randux Linux - General 2 02-26-2006 08:54 AM
Definitive Guide to Life suggestions rusty_slacker General 106 02-07-2006 04:53 PM
Linux Lappy & Wireless PCMCIA - Definitive Guide Request geokker Linux - Laptop and Netbook 3 11-11-2004 03:11 PM
Mandrake Definitive Guide vs. Powerpack books andrew_k Mandriva 1 05-24-2004 06:06 PM


All times are GMT -5. The time now is 06:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration