LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (http://www.linuxquestions.org/questions/linux-games-33/)
-   -   Can't start Counter Strike (wine) (http://www.linuxquestions.org/questions/linux-games-33/cant-start-counter-strike-wine-687055/)

jenhu 11-29-2008 08:09 AM

Can't start Counter Strike (wine)
 
I've installed Steam and Counter Strike (1.6) under wine. Steam works fine (except the mouse pointer is slightly off) but when I try to start CS, I'm suddenly in tty1:

xprop: unable to open display ':0'
usage: xprop [-options ...
...
startkde: Done.
kdeinit: sending SIGTERM to children.
kdeinit: Exit
kdeinit: sending SIGTERM to children,
kdeinit: Exit

Then I don't know what to do, so I startx and start over.

What can I do about this?

I got a message before saying that the previous attempt to start in openGL video mode failed and that the game would run in software mode.

I run Slackware 12.0, on a machine with an internal graphicscard...

dive 11-29-2008 08:15 AM

Do any Opengl apps run? (glxgears or Opengl screensaver is a good way to test).

You don't mention your graphics card or driver.

ErV 11-29-2008 08:18 AM

Quote:

Originally Posted by jenhu (Post 3358652)
I've installed Steam and Counter Strike (1.6) under wine.

Under which version of wine?

Quote:

Originally Posted by jenhu (Post 3358652)
Steam works fine (except the mouse pointer is slightly off) but when I try to start CS, I'm suddenly in tty1:

Are you trying to start it from real terminal? This won't work.
If you are trying to start app from within X and OpenGL works - try another version of wine - newer or older.

jenhu 11-30-2008 05:24 AM

Thanks for the repiles

Opengl seams to work, I've been using an opengl screensaver for some time now. My graphics card is an nVidia mcp61s onboard graphic. I don't know anything about the drives...

I was using 1.0.1, I tried 1.1.9, now when I try to start CS I get the usual "Preparing to launch Counter-Strike..." (as before) but this time nothing happens. Under game status "syncing: 0%, 0 Bytes/s" blinks a few times, and then nothing.


All times are GMT -5. The time now is 03:33 AM.