LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (http://www.linuxquestions.org/questions/linux-games-33/)
-   -   All my games keep crashing (http://www.linuxquestions.org/questions/linux-games-33/all-my-games-keep-crashing-198708/)

GreaseMonkey87 06-28-2004 11:48 AM

All my games keep crashing
 
GFX card: ATI 9600xt
GFX driver: ATI Proprietary Linux Driver 3.9.0 (xfree86 version 3.4.0)
Distro: Mandrake
Kernel: 2.4.22.32
Games affected: Call of duty, farcry, tactical ops, UT2004 + mods.

Hey, it seems all the games listed above (everyone i have) seems to crash anywhere between 1 and 15 minutes after starting them up. They freeze for about a second, then quit to desktop with no error message coming up.
I'm really stumped about this. Any help or any direction to a log file that may help would be much appreciated.

Thanks in advanced, Grease

LavaDevil94 06-28-2004 01:33 PM

The fact that its an ATI card with the 3.9.0 drivers is the problem. If you have the cash, get an nVidia card, like a GeForce 5700 Ultra. If you dont have the cash, look for the 3.2.8 drivers, the 3.9.0 drivers have known stability problems....

GreaseMonkey87 06-28-2004 02:42 PM

K, will try downgrading my driver :(

EDIT//
Any idea where i can get the old driver for X 4.3.0? I can't seem to find it anywhere :(

GreaseMonkey87 06-29-2004 05:09 PM

For anyone wondering, or with a similar problem. I fixed this problem by moving to my original kernal (2.4.22.10) from 2.4.22.32, and getting the kernal-source for that kernel, then re-installing the GFX drivers, now it works lovely.

320mb 06-30-2004 12:50 PM

Re: All my games keep crashing
 
Quote:

Originally posted by GreaseMonkey87
GFX card: ATI 9600xt
GFX driver: ATI Proprietary Linux Driver 3.9.0 (xfree86 version 3.4.0)


Isn't this version of Xfree kinda old??
can you upgrade to some flavor of version 4x??

GreaseMonkey87 06-30-2004 05:50 PM

LOL, oops that was a typo, i meant to put 4.3.0.
Problems fixed now anyway :)


All times are GMT -5. The time now is 01:23 PM.