LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   xfcee4.8 not working (http://www.linuxquestions.org/questions/linux-from-scratch-13/xfcee4-8-not-working-888727/)

janakiramulu 06-28-2011 05:51 AM

xfcee4.8 not working
 
2 Attachment(s)
hi all
HERE I HAVE INSTALLED XFCE4.8 FOLLOWED THIS:http://www.xfce.org/download/building
while installed xfwm4/xfwm is giving small errors to me:
[as we know xfwm is window manager-so i already installed 'fluxbox' a window manager]
http://www.xfce.org/download/building

SO BELOW THINGS I DONE:
i Reinstall the X.org libraries:http://www.linuxfromscratch.org/blfs...n/x/x7lib.html
[installation method: http://wiki.linuxfromscratch.org/blf...org7Libraries]
and
Configuration of Xorg Libraries

ln -sv $XORG_PREFIX/lib/X11 /usr/lib/X11 &&
ln -sv $XORG_PREFIX/include/X11 /usr/include/X11 &&
ln -sv $XORG_PREFIX /usr/X11R6


After that, and replace .xinitrc with 'exec dbus-launch --exit-with-session startxfce4'
now my .xinitrc file is:

root[~]#cat .xinitrc

exec dbus-launch --exit-with-session startxfce4

and i reboot it
@root[~]#startxfce4

result:[SEE ATACHED FILE: Image0053.jpg]
and one dialog box with two buttons and below message:
buttons :continue anyway
:try again
message:could not look up internet address for janu-lfs
this will prevent Xfce from operating correctly.
It may be possible to correct the problem by adding janu-lfs to the file /etc/hosts on your system

i click :try again :no response

i click on :continue anyway

RESULT:[SEE ATTACHED FILE:Image0052.jpg]
again one dialog box with one button[quit] and below message
message:
title:UNABLE TO LOAD A FAILSAFE SESSION
Unable to determine failsafe session name.Possible causes:xfconfd isn't running(D-Bus setup problem); environment variable $XDG_CONFIG_DIRS is set incorrectly (must include "/usr/etc"), or xfce4-session installed incorrectly



and my /etc/host file is:i done below things while doing lfs-6.7

7.11. Configuring the localnet Script:
http://www.linuxfromscratch.org/lfs/.../hostname.html

echo "HOSTNAME=<janu-lfs>" > /etc/sysconfig/network [i choose as 'janu-lfs']

7.12. Customizing the /etc/hosts File:
http://www.linuxfromscratch.org/lfs/...r07/hosts.html [ below is my present /etc/hosts file]

cat > /etc/hosts << "EOF"
# Begin /etc/hosts (network card version)


127.0.0.1 localhost
10.100.38.216 janu-lfs.nitk.ac.in [ip address of that system:10.100.38.216]

# End /etc/hosts (network card version) [nitk.ac.in is our college home site]

EOF


here around 15 desktops are connected via LAN to internet:
but here i installed xfce4.8:http://www.xfce.org/download/building
if anything you want info i will surely assist you
thanku so much

Andy Alkaline 07-07-2011 11:14 PM

Do you need to build and install xfce from scratch? Are you using Ubuntu? Can you just install it from the repo?

janakiramulu 07-08-2011 01:04 AM

hi Andy Alkaline
thanks for reply
first of all i am not using ubuntu
i build lfs6.7 , and i build 23. X Window System Environment

and i also installed 25. Window Managers-Fluxbox-1.1.1
note: There are many Window Managers available. Some of the more well known ones include fvwm2, Window Maker, AfterStep, Enlightenment, Sawfish, and Blackbox.

The Desktop Environments available for Linux are GNOME, KDE, and XFce.

i want xfce as desktop environment to this.

HERE I HAVE INSTALLED XFCE4.8 FROM SCRATCH FOLLOWING THIS:http://www.xfce.org/download/building
[NOTE:download each package,untar ,install with following command
'./configure --prefix=${PREFIX} && make && make install' ,and here $PREFIX=/usr]

when i want start xfce as 'startxfce' at root its not working,
result:giving above message:see above attached fig

corbis_demon 07-12-2011 10:27 AM

Firstly, what have you specified as the sysconf dir for XFCE? From your error, it looks as if it's "/usr/etc", and if DBus is configured to use /etc, then XFCE is looking in the wrong place for DBus system configurations. You may have to recompile XFCE with the option
Code:

./configure --prefix=/usr --sysconfdir=/etc
If this isn't the case, then check if the DBus daemon is running. Also, do you have ConsoleKit installed? If yes, then try putting "exec ck-launch-session ${XFCE_PREFIX}/bin/startxfce". If this doesn't work either, then you most probably have a borked DBus install. As for your second error message, it's simply that your machine is either not conected to the internet or a local network configuration error.


All times are GMT -5. The time now is 10:51 PM.