LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 02-21-2013, 02:44 PM   #1
TKH
Member
 
Registered: Jul 2011
Location: Milky Way
Distribution: Ubuntu, LFS, Slackware, Fedora
Posts: 205

Rep: Reputation: 20
xfce4 session (permission?) problem


Hi, I finished installing XFCE4.
Everything goes well except the ACPI functions.
In the log out box, everything is grey except for the logout button.
I installed XFCE4 with all the packages.
I have ConsoleKit, GNUPG, UPower, and every single deps mentioned in the xfce4-session page.

But nothing can work it out, not even my recently installed gnupg
Can someone help me with this?
Every word will be appreciated!
 
Old 02-21-2013, 09:05 PM   #2
towheedm
Member
 
Registered: Sep 2011
Location: Trinidad & Tobago
Distribution: Debian Squeeze
Posts: 585

Rep: Reputation: 118Reputation: 118
This happens when starting XFCE4 from the console. If you're logging in from a graphical login manager you may need to install the xfce4-power-manager package.
 
Old 02-21-2013, 09:40 PM   #3
shivaa
Senior Member
 
Registered: Jul 2012
Location: Grenoble, Fr.
Distribution: Sun Solaris, RHEL, Ubuntu, Debian 6.0
Posts: 1,797
Blog Entries: 4

Rep: Reputation: 285Reputation: 285Reputation: 285
Check following processes/services:
Code:
~$ ps -aef | egrep "xfce4-session|xfdesktop|xfce4-panel|xfwm4"
If any of these not running, then manually invoke start them as:
Code:
~$ xfce4-session &
~$ xfdesktop &
~$ xfwm4 &
~$ xfce4-panel &
 
Old 02-21-2013, 11:54 PM   #4
TKH
Member
 
Registered: Jul 2011
Location: Milky Way
Distribution: Ubuntu, LFS, Slackware, Fedora
Posts: 205

Original Poster
Rep: Reputation: 20
Quote:
Originally Posted by towheedm View Post
This happens when starting XFCE4 from the console. If you're logging in from a graphical login manager you may need to install the xfce4-power-manager package.
I start it from a console by running:
Code:
startxfce4
by the way, I notice that all of them works when I run it as root
which is why i mention permission

@shivaa
all of them are running

Last edited by TKH; 02-21-2013 at 11:56 PM.
 
Old 02-22-2013, 12:25 AM   #5
towheedm
Member
 
Registered: Sep 2011
Location: Trinidad & Tobago
Distribution: Debian Squeeze
Posts: 585

Rep: Reputation: 118Reputation: 118
Quote:
Originally Posted by TKH View Post
by the way, I notice that all of them works when I run it as root
And that is normal. The power manager needs superuser privileges. That's why it works when you start XFCE4 as root.

When you use a graphical login manager, it escalates the power manager privileges. I think it does it through PAM, but I could be wrong.

Again, this is normal when you start XFCE4 from the console. So do I, but if I start it from a graphical login manager, the other buttons are available.

Try adding yourself to the power (or equivalent) group.

Last edited by towheedm; 02-22-2013 at 12:41 AM.
 
1 members found this post helpful.
Old 02-22-2013, 12:51 AM   #6
TKH
Member
 
Registered: Jul 2011
Location: Milky Way
Distribution: Ubuntu, LFS, Slackware, Fedora
Posts: 205

Original Poster
Rep: Reputation: 20
Quote:
Originally Posted by towheedm View Post
Try adding yourself to the power (or equivalent) group.
how do I do that?
 
Old 02-22-2013, 01:13 AM   #7
shivaa
Senior Member
 
Registered: Jul 2012
Location: Grenoble, Fr.
Distribution: Sun Solaris, RHEL, Ubuntu, Debian 6.0
Posts: 1,797
Blog Entries: 4

Rep: Reputation: 285Reputation: 285Reputation: 285
Quote:
Originally Posted by TKH View Post
how do I do that?
Did you try cmds I suggeted above? It won't need to be root to launch xfce-session.

Second, you can add your account to /etc/sudoers to take sudo access and launch any tool/utility.

OR, just for your info. (but not recommended) add your user account to main group of super-user. But take a note that, it will also require root privilages to modify your group(s):
Code:
~$ id -a root
~$ usermod -G <group> username

Last edited by shivaa; 02-22-2013 at 01:15 AM.
 
Old 02-22-2013, 02:49 AM   #8
TKH
Member
 
Registered: Jul 2011
Location: Milky Way
Distribution: Ubuntu, LFS, Slackware, Fedora
Posts: 205

Original Poster
Rep: Reputation: 20
none of it works
i kinda think that it is the problem with ConsoleKit
this problem start after i installed that package

i tried running ck-list-sessions but nothing come out
also, i check that the /var/run/console does not exist

Last edited by TKH; 02-22-2013 at 02:53 AM.
 
Old 02-22-2013, 06:48 AM   #9
shivaa
Senior Member
 
Registered: Jul 2012
Location: Grenoble, Fr.
Distribution: Sun Solaris, RHEL, Ubuntu, Debian 6.0
Posts: 1,797
Blog Entries: 4

Rep: Reputation: 285Reputation: 285Reputation: 285
Quote:
Originally Posted by TKH View Post
none of it works
i kinda think that it is the problem with ConsoleKit
this problem start after i installed that package

i tried running ck-list-sessions but nothing come out
also, i check that the /var/run/console does not exist
How can you say that none of these worked? Did you get any error message, if yes, please share it.
 
Old 02-22-2013, 11:15 AM   #10
Keith Hedger
Member
 
Registered: Jun 2010
Location: Devon,UK
Distribution: Linux From Scratch, Slackware64,
Posts: 833

Rep: Reputation: 167Reputation: 167
I think you need polkit installed, I had a similar problem but can't remember exactly what I did to fix it but I'm pretty sure it was polkit.
 
Old 02-22-2013, 01:12 PM   #11
TKH
Member
 
Registered: Jul 2011
Location: Milky Way
Distribution: Ubuntu, LFS, Slackware, Fedora
Posts: 205

Original Poster
Rep: Reputation: 20
Quote:
Originally Posted by shivaa View Post
How can you say that none of these worked?
well, the poweroff button is still grey after I tried all those methods

Quote:
Originally Posted by Keith Hedger View Post
I think you need polkit installed, I had a similar problem but can't remember exactly what I did to fix it but I'm pretty sure it was polkit.
either polkit or CK, but i don't know what kind of problem
 
Old 02-25-2013, 01:44 PM   #12
TKH
Member
 
Registered: Jul 2011
Location: Milky Way
Distribution: Ubuntu, LFS, Slackware, Fedora
Posts: 205

Original Poster
Rep: Reputation: 20
Okay, I found out that all of this mess is because of a simple goofy mistake.
I accidentally flipped some options of 'system-session' and 'system-password' line (the last ones) in /etc/pam.d/login.
It turns out good after I fix it.
Sorry for the trouble!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VNC session seems to have permission problem with firewall, updates, usb flash mount mick1965 Fedora 6 06-27-2010 02:53 PM
how can i have xfce4 in my session when i login? mjalalynia Linux - Desktop 14 07-21-2008 12:27 AM
Starting new X session in xfce4 Uruclef Debian 2 01-28-2007 03:28 AM
Starting a new X session from within Xfce4 cwwilson721 Slackware 15 07-30-2006 02:44 PM
xfce4-session fails to save session ! OneManArmy Debian 0 12-10-2004 02:14 PM


All times are GMT -5. The time now is 11:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration