LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   Which version of BLFS is compatible for LFS 7.0? (http://www.linuxquestions.org/questions/linux-from-scratch-13/which-version-of-blfs-is-compatible-for-lfs-7-0-a-934747/)

pannet1 03-16-2012 04:11 AM

Which version of BLFS is compatible for LFS 7.0?
 
Hi linux enthus,
I successfully completed my LFS...Now what my doubt is, we used 7.0 to build Phenix(our customized OS name), recently BLFS has released ongoing version shall i use this version for further building or older version(6.3)? i m eagerly waiting for ur reply...

druuna 03-16-2012 04:30 AM

Answer is given in your other post: finally we got Phenix

Andrew Benton 03-16-2012 12:31 PM

Just use current BLFS svn

stoat 03-16-2012 09:41 PM

Hello everybody,

I agree with druuna and Andrew Benton above and with the stuff in the other thread. I only wanted to add my observation that I almost always end up using two or three versions of the SVN book at the same time. To me, it has sort of become a kind of rolling release, and something gets fixed, improved, or added before I'm done with the one I started with. Anybody else do that?

For example, when that libpng-1.5 package came out not so long ago, it busted the wheels off of things all over the place. For that, I had to turn to newer versions of things that were in the newer versions of the book. Another example, was the addition of VLC to the book recently. I had been building that on my own until it suddenly appeared in one of the daily book versions, again while I was in the middle of the system build up. I can build LFS in an evening. But my typical BLFS system usually takes me two weeks, and that's enough time for new things to come along or to be needed.

Lastly, be alert to errors and typos and such in the daily versions. They're there. Create an account at the wiki and start tickets when you find them. They seem to appreciate that.

P.S.: IMO, nobody should start out with that v6.3 book. That thing was released in 2008 or so. Considering what I just said, starting with that is guaranteed to ensnare you in troubles. I did it on my first system last year and never got past X.


All times are GMT -5. The time now is 07:03 PM.