LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices



Reply
 
Search this Thread
Old 09-16-2005, 07:11 AM   #1
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Rep: Reputation: 53
What package for playing CD and midi file


Hi folks,

BLFS 6.1
twm - window manager

I have following ALSA packages installed;

alsa-firmware-1.0.9.tar.bz2
alsa-lib-1.0.9.tar.bz2
alsa-oss-1.0.9.tar.bz2
alsa-plugins-1.0.9.tar.bz2
alsa-utils-1.0.9a.tar.bz2

alsamixer can be started. Now I'm prepared to test sound on music CD as well as on midi files. Please advise what package shall I install in addition. I only need a simple tool for testing sound only.

BR
satimis
 
Old 09-16-2005, 03:49 PM   #2
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
http://www.cs.helsinki.fi/u/salerma/cd-console/
 
Old 09-17-2005, 02:50 AM   #3
shotokan
Member
 
Registered: Mar 2005
Distribution: slackware, LFS
Posts: 204

Rep: Reputation: 30
Quote:
I only need a simple tool for testing sound only.
The ALSA packages and a CD-ROM drive should be good. (For a regular Audio CD)
 
Old 09-17-2005, 04:12 AM   #4
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Original Poster
Rep: Reputation: 53
Hi shotokan,

Tks for your advice.

Quote:
The ALSA packages and a CD-ROM drive should be good. (For a regular Audio CD)
The CDRom can play music CD on FC3, the host. I have no idea how to get the music CD starts to play on BLFS 6.1. Please advise. Tks

Following ALSA packages have been installed;
alsa-firmware-1.0.9.tar.bz2
alsa-lib-1.0.9.tar.bz2
alsa-oss-1.0.9.tar.bz2
alsa-plugins-1.0.9.tar.bz2
alsa-utils-1.0.9a.tar.bz2

"man alsa-utils", "man alsa", "man alsa-oss", etc. do not work;
bash-3.00$ man alsa-oss
Code:
No manual entry for alsa-oss
alsamixer can be started as "root" only with following command;
# alsamixer

Volumn can be adjusted. But alsamixer can't be started as "user"

bash-3.00$ alsamixer
Code:
alsamixer: function snd_ctl_open failed for default: Permission denied

root@localhost:/sources/Python-2.4.1# ls -l /usr/bin/alsamixer
Code:
-rwxrwxr-x  1 root root 61555 Sep 17 00:24 /usr/bin/alsamixer
Whether change its owner and group with;

# chown satimis:satimis: /usr/bin/alsamixer

Please advise. Tks.

BR
satimis

Last edited by satimis; 09-17-2005 at 04:13 AM.
 
Old 09-17-2005, 10:16 AM   #5
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
Do you have a /etc/group file? You should try adding yourself to the audio group (and cdrom for that matter), then:
Code:
chown root:audio /dev/sound/*
if they're not already.
 
Old 09-17-2005, 12:08 PM   #6
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Original Poster
Rep: Reputation: 53
Hi ciotog,

Tks for your advice. Hereunder is /etc/group
Code:
root:x:0:
bin:x:1:
sys:x:2:
sys:x:2:
kmem:x:3:
tty:x:4:
tape:x:5:
daemon:x:6:
floppy:x:7:
disk:x:8:
lp:x:9:
dialout:x:10:
audio:x:11:
video:x:12:
utmp:x:13:
usb:x:14:
satimis:x:100:
satimis is there.

To add "cdrom" to the group;
# groupadd cdrom
# chown root:audio /dev/hdd
(cdrom is slave secondary IDE. How to check it???)
# chmod 660 /dev/hdd
# chown root:audio /dev/sound/*

If I'm wrong, please correct me. TIA

Furthermore on alsamixer window, how to activate cdrom? It is OFF. Space key does not work.

B.R.
satimis
 
Old 09-17-2005, 02:26 PM   #7
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
The audio line in /etc/group should read
Code:
audio:x:11:satimis
for you to be in the audio group.

You can add users to groups using the gpasswd command like so:
Code:
gpasswd -a satimis audio
The cdrom device should probably be root:cdrom rather than :audio since presumably you'll also use it for data

You can check on what's attached to which ide channel by looking at /proc/ide/ide?/hd?/model (where ide? is ide0 or ide1, hd? is hda, hdb, etc). I'm sure there's an easier way...

As for cdrom in alsamixer, I'm sure once all the permissions are set you'll have access to it.
 
Old 09-17-2005, 08:30 PM   #8
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Original Poster
Rep: Reputation: 53
Hi ciotog,

Tks for your advice. Steps performed as follows;

edited /etc/group
added "satimis" to "audio:x:11:satimis <====== "

root@localhost:~# cat /etc/group
Code:
root:x:0:
bin:x:1:
sys:x:2:
sys:x:2:
kmem:x:3:
tty:x:4:
tape:x:5:
daemon:x:6:
floppy:x:7:
disk:x:8:
lp:x:9:
dialout:x:10:
audio:!:11:satimis
video:x:12:
utmp:x:13:
usb:x:14:
satimis:x:100:
cdrom:x:101:
# gpasswd -a satimis audio
Code:
Adding user satimis to group audio
# ls /proc/ide/
Code:
drivers  hda  hdc  hdd  ide0  ide1  via
# ls /proc/ide/ide1
Code:
channel  hdc  hdd  mate  model
# ls /proc/ide/ide1/hdd/
Code:
capacity  driver  identify  media  model settings
# cat /proc/ide/ide1/hdd/model
SONY CD-ROM CDU5221
(That's it.)

# groupadd cdrom
# chown root:cdrom /dev/hdd
# chmod -c 660 /dev/hdd
(all of them no printout)

# ls -l /dev/hdd
Code:
brw-rw----  1 root cdrom 22, 64 Sep 18 15:36 
/dev/hdd
# chown root:audio /dev/sound/*
Code:
chown: cannot access
`/dev/sound/*': No such file or directory
root@localhost:~# ls /dev | grep sound
(No printout)

bash-3.00$ alsamixer
Code:
alsamixer: function snd_ctl_open failed for default: Permission denied
Still have to start "alsamixer" as root. To activate "cdrom" was not work. CD[Off]

Please advise. TIA

BR
satimis
 
Old 09-18-2005, 03:14 AM   #9
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
Ok, do you have /dev/snd/* character device files? If so, what user:group are they? It might be helpful to know what soundcard you have as well.

Last edited by ciotog; 09-18-2005 at 03:16 AM.
 
Old 09-18-2005, 10:11 AM   #10
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Original Poster
Rep: Reputation: 53
Hi ciotog,

Quote:
do you have /dev/snd/* character device files? If so, what user:group are they?
~# ls -l /dev/snd/
Code:
total 0
crw-rw----  1 root audio 116,  0 Sep 19 06:04 controlC0
crw-rw----  1 root audio 116, 24 Sep 19 06:04 pcmC0D0c
crw-rw----  1 root audio 116, 16 Sep 19 06:04 pcmC0D0p
crw-rw----  1 root audio 116, 25 Sep 19 06:04 pcmC0D1c
crw-rw----  1 root audio 116, 17 Sep 19 06:04 pcmC0D1p
crw-rw----  1 root audio 116,  1 Sep 19 06:04 seq
crw-rw----  1 root audio 116, 33 Sep 19 06:04 timer
Quote:
It might be helpful to know what soundcard you have as well.
On board sound card, build-in AC97 Digital Audio (by via VT8233). It works without problem on FC3, the host, on the same box.

BR
SL
 
Old 09-18-2005, 11:52 AM   #11
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Original Poster
Rep: Reputation: 53
Hi ciotog,

Further to my late posting, on checking my documentation, it came to my notice that I need to install alsa-driver-1.0.10rc1.tar.bz2. Following URL refers;

http://www.alsa-project.org/alsa-doc...=via82xx#intro

I have done it before on FC3, the host. But I could not resolve following commands on BLFS;

# modprobe snd-via82xx;modprobe snd-pcm-oss;modprobe snd-mixer-oss;modprobe snd-seq-oss

# cat /etc/modprobe.conf

BLFS 6.1 does not make it as module. Then what shall I do? What command shall I run?

Any advice? TIA

BR
satimis
 
Old 09-18-2005, 12:11 PM   #12
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
Yes, rebuilding the alsa-driver was going to be my next suggestion

If you don't have /etc/modprobe.conf then you may have problems with a few things like HW sensors, video and the like that require entries in it to work properly (well, easily). I would suggest creating the file and inserting the lines mentioned in the ALSA documentation.

When you ran "make install" did it install the snd-* modules in /lib/modules/[kernel version]/kernel/sound/pci/*? It looks like the modules aren't being found.
 
Old 09-19-2005, 12:13 AM   #13
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Original Poster
Rep: Reputation: 53
Hi ciotog,

Quote:
If you don't have /etc/modprobe.conf then you may have problems with a few things like HW sensors, video and the like that require entries in it to work properly (well, easily). I would suggest creating the file and inserting the lines mentioned in the ALSA documentation.
Please advise. Pointer would be appreciated. Tks.

Quote:
When you ran "make install" did it install the snd-* modules in /lib/modules/[kernel version]/kernel/sound/pci/*?
bash-3.00$ ls -al /lib/modules/2.6.11.12/kernel/sound/pci/
Code:
total 64
drwxr-xr-x  4 root root  4096 Aug  5 20:24 .
drwxr-xr-x  6 root root  4096 Aug  5 20:24 ..
drwxr-xr-x  2 root root  4096 Aug  5 20:24 emu10k1
-rw-r--r--  1 root root 27951 Aug  5 20:24 snd-via82xx.ko
drwxr-xr-x  2 root root  4096 Aug  5 20:24 ymfpci
Quote:
It looks like the modules aren't being found.
bash-3.00$ cat /usr/src/linux-2.6.11.12/.config | grep SND
Code:
CONFIG_SND=y
CONFIG_SND_TIMER=y
CONFIG_SND_PCM=y
CONFIG_SND_HWDEP=m
CONFIG_SND_RAWMIDI=m
CONFIG_SND_SEQUENCER=y
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=y
CONFIG_SND_PCM_OSS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_MPU401_UART=m
CONFIG_SND_OPL3_LIB=m
CONFIG_SND_AC97_CODEC=y
CONFIG_SND_EMU10K1=m
CONFIG_SND_YMFPCI=m
CONFIG_SND_INTEL8X0=y
CONFIG_SND_VIA82XX=m
some as module another just turning it on.

BR
satimis

Last edited by satimis; 09-19-2005 at 12:17 AM.
 
Old 09-19-2005, 02:10 AM   #14
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
modprobe.conf is probably best generated as part of the installation of module-init-tools, the latest stable version is 3.1 and you can get it here:
http://www.kernel.org/pub/linux/kern...rusty/modules/

Since you're building some of the drivers into the kernel instead of as modules, you don't need to insert the modules (and there won't be modules to insert). For example,
Code:
modprobe snd-pcm-oss
I'm not sure what the end result will be - I think the best way to use ALSA is to build all sound drivers as modules. That way they're easier to update.

BTW, why do you have emu10k1, ymfpci, intel8x0 selected?
 
Old 09-19-2005, 07:37 AM   #15
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Original Poster
Rep: Reputation: 53
Hi ciotog,

Tks for your advice and URL.

No, I haven't selected any item and device on kernel in respect of SND. That is by default. The LFS team made those selections as default. They must have reason.

I build this BLFS 6.1 box as an experiment only NOT for dialy operation. I'm willing to go LFS's way if possible to see what will happen in order to learn. Any suggestion or pointer will be appreciated. TIA.

B.R.
satimis
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
playing midi is harder to setup than it seems to be thinhla Linux - Software 4 07-02-2005 01:15 PM
Playing MIDI files under Mandrake KhmerDucky Linux - Software 1 06-09-2005 10:13 PM
Playing Midi in SuSE 9.2 Mic Q Suse/Novell 5 01-12-2005 06:47 PM
how to play midi file salahuddin_66 Slackware 6 05-12-2004 06:02 AM
Playing MIDI files rajan_kanwar Linux - Software 1 02-05-2004 05:46 AM


All times are GMT -5. The time now is 09:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration