-   Linux From Scratch (
-   -   Updating packages (

Kroenecker 07-05-2004 04:54 AM

Updating packages
Say I want to update to GTK+ 2.4 on my LFS 5 system. Assuming I manage to remove all of the stuff that was installed with GTK+ 2.2 from the LFS5 book, does the possibility exist that I will have problems with currently installed stuff that I compiled against GTK+2.2? still be so noobish.

Kroenecker 07-05-2004 09:15 AM

If I am asking a question that is answered somewhere in LFS, then please point me in the right direction.

Thanks :cool:

Andrew Benton 07-05-2004 11:57 AM

It's sort-of discussed here in Beyond LFS Gtk and Glib are shared libraries so it's quite possible that something may break if you update from 2.2 to 2.4. If I was in your position I'd rebuild from the start. It can be tedious though so you might want to think about using scripts.

All times are GMT -5. The time now is 02:23 AM.