LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 11-22-2006, 04:36 AM   #1
Vitalie Ciubotaru
Member
 
Registered: Dec 2005
Location: Osaka, Japan
Distribution: Ubuntu Trinity
Posts: 153

Rep: Reputation: 30
Question Strange characters in command line in X


Hi everybody,

Thanking to yourselves I am making my way in LFS. I recently solved the following issues:
1. install nVidia drivers for my old TNT2 Vanta (installer complained about not finding Linux headers).
2. see graphic files in Gnome (I blindly followed GTK+2 build instructions and compiled it "--without-libjpeg --without-libtiff").
3. see USB memory stick (I didn't enable "SCSI drive support" in the kernel)
4. have ALSA save and restore volumes after reboot (had to reconfigure kernel to have all sound-related things compiled as modules, and install "dialog")
Now there's one single thing not solved - X terminal displays some strange characters, e.g. when pressing "Backspace" or bringing up the previous typed command with "Arrow up". I posted it before, but none of the advice helped.
I would be greatful if anyone's got a clue

Vitalie CIUBOTARU
 
Old 11-22-2006, 10:08 PM   #2
KenJackson
Member
 
Registered: Jul 2006
Location: Maryland, USA
Distribution: Fedora, Arch
Posts: 572

Rep: Reputation: 64
Try these commands:
Code:
echo $LANG
echo $LANGUAGE
set | grep LC_
Do you see UTF-8 anywhere? Try changing "en_US.UTF-8" to "en_US" or just "en". I'm not sure where they are set, but you can set (and export) them in ~/.bashrc or ~/.profile, etc.
 
Old 11-22-2006, 11:38 PM   #3
Harmaa Kettu
Member
 
Registered: Apr 2005
Location: Finland
Posts: 196

Rep: Reputation: 30
Does "export TERM=xterm" help?
 
Old 11-25-2006, 03:00 AM   #4
Vitalie Ciubotaru
Member
 
Registered: Dec 2005
Location: Osaka, Japan
Distribution: Ubuntu Trinity
Posts: 153

Original Poster
Rep: Reputation: 30
Neither "echo $LANG", nor "echo $LANGUAGE" produce any output. "printenv" doesn't contain such environment variables.
"echo $TERM" yields "xterm-color", changing it to "xterm" does not seem to make a difference.
It looks like xterm interprets them correctly, but it just doesn't refresh the screen.

Vitalie CIUBOTARU

P.S.: Can it be a particular dependency of Xorg that I didn't build properly?

Last edited by Vitalie Ciubotaru; 11-25-2006 at 04:39 AM.
 
Old 11-25-2006, 11:00 AM   #5
KenJackson
Member
 
Registered: Jul 2006
Location: Maryland, USA
Distribution: Fedora, Arch
Posts: 572

Rep: Reputation: 64
Have you tried the stty command? This command will show you all of it's current settings:
Code:
stty -a
Mine contains erase = ^? and -utf8. Try this command:
Code:
stty ek
and, of course, this one: man stty.

Also man loadkeys.
 
Old 11-30-2006, 06:53 PM   #6
Vitalie Ciubotaru
Member
 
Registered: Dec 2005
Location: Osaka, Japan
Distribution: Ubuntu Trinity
Posts: 153

Original Poster
Rep: Reputation: 30
The funny thing is that when I run "xterm" in Gnome environment [instead of default "gnome-terminal"] it works ok. This means it's a font problem, right? I tried them all, one by one, in "gnome-terminal" - none works.
1. Can it be a font problem, indeed?
2. What font do I need?
3. Where can I get it?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange characters in man pages _maco_ Linux - General 2 06-01-2009 05:44 PM
Getting last characters of a line with sed command LULUSNATCH Programming 4 12-21-2005 09:33 AM
51 characters only in the 1st Line of command line eggCover Linux - General 2 07-29-2004 01:28 PM
Strange characters in Konsole under Redhat 8.0... lonestarbacon Linux - Distributions 15 07-09-2003 02:57 PM
Strange Characters : RedHat 8.0 UberPhreek Linux - Newbie 1 10-18-2002 05:58 AM


All times are GMT -5. The time now is 07:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration