LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   startx problem (http://www.linuxquestions.org/questions/linux-from-scratch-13/startx-problem-939616/)

pannet1 04-13-2012 05:07 AM

startx problem
 
Dear All,
After Xorg-server, Xorg-drivers, Xorg-fonts has been installed, we hope startx will execute correctly but our hope was frustrated by the following problem.
we hope someone will give us solution for the following problem

xauth: file /root/.serverauth.1929 does not exist


X.Org X Server 1.11.2
Release Date: 2011-11-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.1.0 i686
Current Operating System: Linux Phenix 3.1.0 #1 SMP Wed Mar 14 19:08:10 IST 2012 i686
Kernel command line: ro root=/dev/sda7
Build Date: 10 April 2012 09:18:20PM

Current version of pixman: 0.24.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Apr 11 22:26:42 2012
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/X11/share/X11/xorg.conf.d"
Parse error on line 14 of section InputClass in file /etc/X11/xorg.conf.d/10-evdev.conf
"Section" is not a valid keyword in this section.
(EE) Problem parsing the config file
(EE) Error parsing the config file

Regards,
Sugi@Phenix
Praki@Phenix

pan64 04-13-2012 05:51 AM

maybe you need to configure your system before startx.
see http://www.wikihow.com/Configure-X11-in-Linux

druuna 04-13-2012 12:29 PM

Hi,
Quote:

Originally Posted by pannet1 (Post 4651713)
After Xorg-server, Xorg-drivers, Xorg-fonts has been installed

Am I assuming correctly that you also successfully installed all the dependencies and have set the correct variables? Or did you only install the 3 mentioned?

Quote:

we hope startx will execute correctly but our hope was frustrated by the following problem.
we hope someone will give us solution for the following problem
-->snip<--
Did you successfully do the Xorg-7.6-2 Testing and Configuration chapter?

Details please....

pannet1 04-14-2012 02:25 AM

Hi all,
Actually we got x window(startx), in startx we cant able to detect keyboard and mouse we got the following error in log file.

[719.597] (WW) hotplugging is on, devices using drivers 'kbd','mouse', or 'vmmouse' will be disabled.
[719.597] (WW) disabling Mouse0
[719.597] (WW) disabling Keyboard0

Regards,
Sugi@Phenix
Praki@Phenix

ukiuki 04-14-2012 02:31 AM

Quote:

Originally Posted by pannet1 (Post 4652356)
...
[719.597] (WW) hotplugging is on, devices using drivers 'kbd','mouse', or 'vmmouse' will be disabled.
[719.597] (WW) disabling Mouse0
[719.597] (WW) disabling Keyboard0
...

Those are just warnings and normally aren't a problem, look for the lines with (EE) those are errors.
In that same file you can see what each marker means.
Code:

Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

Regards

pannet1 04-14-2012 03:20 AM

Hi everybody,
After installing X-window system in BLFS, we gave the command called startx this command executes successfully and we got 3 windows and one clock too, but we cant able to navigate to other terminals because keyboard and mouse are not detecting.. We hope someone will give solution.



Regards,
Sugi@Phenix
Praki@Phenix

druuna 04-14-2012 03:30 AM

Hi,

Still a lack of details. Can you please answer the questions asked in post #3?

Also include the Xorg.0.log file and (possible) content shown in the terminal after starting x.

pannet1 04-14-2012 04:53 AM

Hi drunna,
Ya we installed all the dependencies and Xorg-7.6-2 Testing and Configuration chapter correctly.
Our Xorg.O.log file has the following contents,


[ 719.861]
X.Org X Server 1.11.2
Release Date: 2011-11-04
[ 718.862] X Protocol Version 11, Revision 0
[ 718.862] Build Operating System: Linux 3.1.0 i686
[ 718.862] Current Operating System: Linux Phenix 3.1.0 #1 SMP Wed Mar 14 19:08:10 IST 2012 i686
[ 718.862] Kernel command line: ro root=/dev/sda7
[ 718.863] Build Date: 13 April 2012 11:09:17PM
[ 718.863]
[ 718.863] Current version of pixman: 0.24.0
[ 718.863] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 718.863] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 718.864] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Apr 14 23:24:13 2012
[ 718.869] (II) Loader magic: 0x82227c0
[ 718.869] (II) Module ABI versions:
[ 718.869] X.Org ANSI C Emulation: 0.4
[ 718.869] X.Org Video Driver: 11.0
[ 718.869] X.Org XInput driver : 13.0
[ 718.869] X.Org Server Extension : 6.0
[ 718.873] (--) PCI:*(0:0:2:0) 8086:0046:1028:0447 rev 24, Mem @ 0xfa400000/4194304, 0xc0000000/268435456, I/O @ 0x0000f080/8
[ 718.941] List of video drivers:
[ 718.942] savage
[ 718.942] i128
[ 718.942] i740
[ 718.942] ark
[ 718.942] mach64
[ 718.942] xgi
[ 718.943] nv
[ 718.943] tseng
[ 718.943] glint
[ 718.943] cirrus
[ 718.943] dummy
[ 718.943] s3virge
[ 718.944] neomagic
[ 718.944] mga
[ 718.944] trident
[ 718.944] intel
[ 718.944] radeon
[ 718.945] rendition
[ 718.945] v4l
[ 718.945] s3
[ 718.945] tga
[ 718.945] r128
[ 718.945] tdfx
[ 718.946] siliconmotion
[ 718.946] sis
[ 718.946] ati
[ 718.946] sisusb
[ 718.946] voodoo
[ 718.946] apm
[ 718.947] ast
[ 718.947] fbdev
[ 718.947] vesa
[ 718.948] (II) LoadModule: "savage"
[ 718.948] (II) Loading /usr/X11/lib/X11/modules/drivers/savage_drv.so
[ 718.954] (II) Module savage: vendor="X.Org Foundation"
[ 718.954] compiled for 1.11.2, module version = 2.3.3
[ 718.954] Module class: X.Org Video Driver
[ 718.954] ABI class: X.Org Video Driver, version 11.0
[ 718.954] (II) LoadModule: "i128"
[ 718.954] (II) Loading /usr/X11/lib/X11/modules/drivers/i128_drv.so
[ 718.967] (II) Module i128: vendor="X.Org Foundation"
[ 718.967] compiled for 1.11.2, module version = 1.3.4
[ 718.967] Module class: X.Org Video Driver
[ 718.967] ABI class: X.Org Video Driver, version 11.0
[ 718.967] (II) LoadModule: "i740"
[ 718.967] (II) Loading /usr/X11/lib/X11/modules/drivers/i740_drv.so
[ 718.990] (II) Module i740: vendor="X.Org Foundation"
[ 718.990] compiled for 1.11.2, module version = 1.3.2
[ 718.990] Module class: X.Org Video Driver
[ 718.990] ABI class: X.Org Video Driver, version 11.0
[ 718.990] (II) LoadModule: "ark"
[ 718.991] (II) Loading /usr/X11/lib/X11/modules/drivers/ark_drv.so
[ 718.994] (II) Module ark: vendor="X.Org Foundation"
[ 718.994] compiled for 1.11.2, module version = 0.7.3
[ 718.994] Module class: X.Org Video Driver
[ 718.994] ABI class: X.Org Video Driver, version 11.0
[ 718.994] (II) LoadModule: "mach64"
[ 718.994] (II) Loading /usr/X11/lib/X11/modules/drivers/mach64_drv.so
[ 719.003] (II) Module mach64: vendor="X.Org Foundation"
[ 719.003] compiled for 1.11.2, module version = 6.9.0
[ 719.003] Module class: X.Org Video Driver
[ 719.003] ABI class: X.Org Video Driver, version 11.0
[ 719.003] (II) LoadModule: "xgi"
[ 719.003] (II) Loading /usr/X11/lib/X11/modules/drivers/xgi_drv.so
[ 719.045] (EE) LoadModule: Module xgi does not have a xgiModuleData data object.
[ 719.045] (II) UnloadModule: "xgi"
[ 719.045] (II) Unloading xgi
[ 719.045] (EE) Failed to load module "xgi" (invalid module, 0)
[ 719.045] (II) LoadModule: "nv"
[ 719.045] (II) Loading /usr/X11/lib/X11/modules/drivers/nv_drv.so
[ 719.063] (II) Module nv: vendor="X.Org Foundation"
[ 719.063] compiled for 1.11.2, module version = 2.1.18
[ 719.063] Module class: X.Org Video Driver
[ 719.063] ABI class: X.Org Video Driver, version 11.0
[ 719.063] (II) LoadModule: "tseng"
[ 719.063] (II) Loading /usr/X11/lib/X11/modules/drivers/tseng_drv.so
[ 719.074] (II) Module tseng: vendor="X.Org Foundation"
[ 719.074] compiled for 1.11.2, module version = 1.1.0
[ 719.074] Module class: X.Org Video Driver
[ 719.074] ABI class: X.Org Video Driver, version 11.0
[ 719.074] (II) LoadModule: "glint"
[ 719.074] (II) Loading /usr/X11/lib/X11/modules/drivers/glint_drv.so
[ 719.090] (II) Module glint: vendor="X.Org Foundation"
[ 719.090] compiled for 1.11.2, module version = 1.2.6
[ 719.090] Module class: X.Org Video Driver
[ 719.090] ABI class: X.Org Video Driver, version 11.0
[ 719.090] (II) LoadModule: "cirrus"
[ 719.091] (II) Loading /usr/X11/lib/X11/modules/drivers/cirrus_drv.so
[ 719.101] (II) Module cirrus: vendor="X.Org Foundation"
[ 719.101] compiled for 1.11.2, module version = 1.3.2
[ 719.101] Module class: X.Org Video Driver
[ 719.101] ABI class: X.Org Video Driver, version 11.0
[ 719.101] (II) LoadModule: "dummy"
[ 719.101] (II) Loading /usr/X11/lib/X11/modules/drivers/dummy_drv.so
[ 719.113] (II) Module dummy: vendor="X.Org Foundation"
[ 719.113] compiled for 1.11.2, module version = 0.3.4
[ 719.113] Module class: X.Org Video Driver
[ 719.113] ABI class: X.Org Video Driver, version 11.0
[ 719.113] (II) LoadModule: "s3virge"
[ 719.114] (II) Loading /usr/X11/lib/X11/modules/drivers/s3virge_drv.so
[ 719.125] (II) Module s3virge: vendor="X.Org Foundation"
[ 719.125] compiled for 1.11.2, module version = 1.10.4
[ 719.125] Module class: X.Org Video Driver
[ 719.125] ABI class: X.Org Video Driver, version 11.0
[ 719.125] (II) LoadModule: "neomagic"
[ 719.125] (II) Loading /usr/X11/lib/X11/modules/drivers/neomagic_drv.so
[ 719.141] (II) Module neomagic: vendor="X.Org Foundation"
[ 719.141] compiled for 1.11.2, module version = 1.2.5
[ 719.141] Module class: X.Org Video Driver
[ 719.141] ABI class: X.Org Video Driver, version 11.0
[ 719.141] (II) LoadModule: "mga"
[ 719.141] (II) Loading /usr/X11/lib/X11/modules/drivers/mga_drv.so
[ 719.160] (II) Module mga: vendor="X.Org Foundation"
[ 719.160] compiled for 1.11.2, module version = 1.4.13
[ 719.160] Module class: X.Org Video Driver
[ 719.160] ABI class: X.Org Video Driver, version 11.0
[ 719.160] (II) LoadModule: "trident"
[ 719.160] (II) Loading /usr/X11/lib/X11/modules/drivers/trident_drv.so
[ 719.171] (II) Module trident: vendor="X.Org Foundation"
[ 719.171] compiled for 1.11.2, module version = 1.3.4
[ 719.171] Module class: X.Org Video Driver
[ 719.171] ABI class: X.Org Video Driver, version 11.0
[ 719.171] (II) LoadModule: "intel"
[ 719.172] (II) Loading /usr/X11/lib/X11/modules/drivers/intel_drv.so
[ 719.189] (EE) Failed to load /usr/X11/lib/X11/modules/drivers/intel_drv.so: libdrm.so.2: cannot open shared object file: No such file or directory
[ 719.189] (EE) LoadModule: Module intel does not have a intelModuleData data object.
[ 719.189] (II) UnloadModule: "intel"
[ 719.189] (II) Unloading intel
[ 719.189] (EE) Failed to load module "intel" (invalid module, 0)
[ 719.189] (II) LoadModule: "radeon"
[ 719.189] (II) Loading /usr/X11/lib/X11/modules/drivers/radeon_drv.so
[ 719.205] (EE) Failed to load /usr/X11/lib/X11/modules/drivers/radeon_drv.so: libdrm_radeon.so.1: cannot open shared object file: No such file or directory
[ 719.206] (EE) LoadModule: Module radeon does not have a radeonModuleData data object.
[ 719.206] (II) UnloadModule: "radeon"
[ 719.206] (II) Unloading radeon
[ 719.206] (EE) Failed to load module "radeon" (invalid module, 0)
[ 719.206] (II) LoadModule: "rendition"
[ 719.206] (II) Loading /usr/X11/lib/X11/modules/drivers/rendition_drv.so
[ 719.215] (II) Module rendition: vendor="X.Org Foundation"
[ 719.215] compiled for 1.11.2, module version = 4.2.4
[ 719.215] Module class: X.Org Video Driver
[ 719.215] ABI class: X.Org Video Driver, version 11.0
[ 719.215] (II) LoadModule: "v4l"
[ 719.216] (II) Loading /usr/X11/lib/X11/modules/drivers/v4l_drv.so
[ 719.233] (II) Module v4l: vendor="X.Org Foundation"
[ 719.233] compiled for 1.11.2, module version = 0.1.1
[ 719.233] ABI class: X.Org Video Driver, version 11.0
[ 719.233] (II) LoadModule: "s3"
[ 719.233] (II) Loading /usr/X11/lib/X11/modules/drivers/s3_drv.so
[ 719.251] (II) Module s3: vendor="X.Org Foundation"
[ 719.251] compiled for 1.11.2, module version = 0.6.3
[ 719.251] Module class: X.Org Video Driver
[ 719.251] ABI class: X.Org Video Driver, version 11.0
[ 719.251] (II) LoadModule: "tga"
[ 719.251] (II) Loading /usr/X11/lib/X11/modules/drivers/tga_drv.so
[ 719.266] (II) Module tga: vendor="X.Org Foundation"
[ 719.266] compiled for 1.11.2, module version = 1.2.1
[ 719.266] Module class: X.Org Video Driver
[ 719.266] ABI class: X.Org Video Driver, version 11.0
[ 719.266] (II) LoadModule: "r128"
[ 719.266] (II) Loading /usr/X11/lib/X11/modules/drivers/r128_drv.so
[ 719.276] (II) Module r128: vendor="X.Org Foundation"
[ 719.276] compiled for 1.11.2, module version = 6.8.1
[ 719.276] Module class: X.Org Video Driver
[ 719.276] ABI class: X.Org Video Driver, version 11.0
[ 719.276] (II) LoadModule: "tdfx"
[ 719.277] (II) Loading /usr/X11/lib/X11/modules/drivers/tdfx_drv.so
[ 719.284] (II) Module tdfx: vendor="X.Org Foundation"
[ 719.284] compiled for 1.11.2, module version = 1.4.3
[ 719.284] Module class: X.Org Video Driver
[ 719.284] ABI class: X.Org Video Driver, version 11.0
[ 719.284] (II) LoadModule: "siliconmotion"
[ 719.285] (II) Loading /usr/X11/lib/X11/modules/drivers/siliconmotion_drv.so
[ 719.294] (II) Module siliconmotion: vendor="X.Org Foundation"
[ 719.294] compiled for 1.11.2, module version = 1.7.5
[ 719.294] Module class: X.Org Video Driver
[ 719.294] ABI class: X.Org Video Driver, version 11.0
[ 719.294] (II) LoadModule: "sis"
[ 719.294] (II) Loading /usr/X11/lib/X11/modules/drivers/sis_drv.so
[ 719.314] (II) Module sis: vendor="X.Org Foundation"
[ 719.314] compiled for 1.11.2, module version = 0.10.3
[ 719.314] Module class: X.Org Video Driver
[ 719.314] ABI class: X.Org Video Driver, version 11.0
[ 719.314] (II) LoadModule: "ati"
[ 719.315] (II) Loading /usr/X11/lib/X11/modules/drivers/ati_drv.so
[ 719.324] (II) Module ati: vendor="X.Org Foundation"
[ 719.324] compiled for 1.11.2, module version = 6.14.3
[ 719.324] Module class: X.Org Video Driver
[ 719.324] ABI class: X.Org Video Driver, version 11.0
[ 719.324] (II) LoadModule: "sisusb"
[ 719.324] (II) Loading /usr/X11/lib/X11/modules/drivers/sisusb_drv.so
[ 719.326] (II) Module sisusb: vendor="X.Org Foundation"
[ 719.326] compiled for 1.11.2, module version = 0.9.4
[ 719.326] Module class: X.Org Video Driver
[ 719.326] ABI class: X.Org Video Driver, version 11.0
[ 719.326] (II) LoadModule: "voodoo"
[ 719.326] (II) Loading /usr/X11/lib/X11/modules/drivers/voodoo_drv.so
[ 719.338] (II) Module voodoo: vendor="X.Org Foundation"
[ 719.338] compiled for 1.11.2, module version = 1.1.0
[ 719.338] Module class: X.Org Video Driver
[ 719.338] ABI class: X.Org Video Driver, version 11.0
[ 719.338] (II) LoadModule: "apm"
[ 719.338] (II) Loading /usr/X11/lib/X11/modules/drivers/apm_drv.so
[ 719.346] (II) Module apm: vendor="X.Org Foundation"
[ 719.346] compiled for 1.11.2, module version = 1.2.3
[ 719.346] Module class: X.Org Video Driver
[ 719.346] ABI class: X.Org Video Driver, version 11.0
[ 719.346] (II) LoadModule: "ast"
[ 719.346] (II) Loading /usr/X11/lib/X11/modules/drivers/ast_drv.so
[ 719.354] (II) Module ast: vendor="X.Org Foundation"
[ 719.354] compiled for 1.11.2, module version = 0.93.9
[ 719.354] Module class: X.Org Video Driver
[ 719.354] ABI class: X.Org Video Driver, version 11.0
[ 719.354] (II) LoadModule: "fbdev"
[ 719.354] (II) Loading /usr/X11/lib/X11/modules/drivers/fbdev_drv.so
[ 719.359] (II) Module fbdev: vendor="X.Org Foundation"
[ 719.359] compiled for 1.11.2, module version = 0.4.2
[ 719.359] ABI class: X.Org Video Driver, version 11.0
[ 719.359] (II) LoadModule: "vesa"
[ 719.359] (II) Loading /usr/X11/lib/X11/modules/drivers/vesa_drv.so
[ 719.379] (II) Module vesa: vendor="X.Org Foundation"
[ 719.379] compiled for 1.11.2, module version = 2.3.0
[ 719.379] Module class: X.Org Video Driver
[ 719.379] ABI class: X.Org Video Driver, version 11.0
[ 719.379] (WW) Falling back to old probe method for i128
[ 719.379] (WW) Falling back to old probe method for i740
[ 719.379] (WW) Falling back to old probe method for ark
[ 719.379] (WW) Falling back to old probe method for tseng
[ 719.379] (WW) Falling back to old probe method for glint
[ 719.379] (WW) Falling back to old probe method for cirrus
[ 719.379] (II) Loading sub module "cirrus_laguna"
[ 719.379] (II) LoadModule: "cirrus_laguna"
[ 719.379] (II) Loading /usr/X11/lib/X11/modules/drivers/cirrus_laguna.so
[ 719.403] (II) Module cirrus_laguna: vendor="X.Org Foundation"
[ 719.403] compiled for 1.11.2, module version = 1.0.0
[ 719.403] ABI class: X.Org Video Driver, version 11.0
[ 719.403] (II) Loading sub module "cirrus_alpine"
[ 719.403] (II) LoadModule: "cirrus_alpine"
[ 719.403] (II) Loading /usr/X11/lib/X11/modules/drivers/cirrus_alpine.so
[ 719.409] (II) Module cirrus_alpine: vendor="X.Org Foundation"
[ 719.409] compiled for 1.11.2, module version = 1.0.0
[ 719.409] ABI class: X.Org Video Driver, version 11.0
[ 719.409] (WW) Falling back to old probe method for dummy
[ 719.409] (WW) Falling back to old probe method for s3virge
[ 719.409] (WW) Falling back to old probe method for neomagic
[ 719.409] (WW) Falling back to old probe method for trident
[ 719.409] (WW) Falling back to old probe method for v4l
[ 719.409] (II) v4l driver for Video4Linux
[ 719.409] (WW) Falling back to old probe method for s3
[ 719.409] (WW) Falling back to old probe method for tga
[ 719.409] (WW) Falling back to old probe method for siliconmotion
[ 719.409] (WW) Falling back to old probe method for sis
[ 719.409] (WW) Falling back to old probe method for sisusb
[ 719.409] (WW) Falling back to old probe method for voodoo
[ 719.409] (WW) Falling back to old probe method for apm
[ 719.409] (WW) Falling back to old probe method for ast
[ 719.409] (II) FBDEV: driver for framebuffer: fbdev
[ 719.409] (II) VESA: driver for VESA chipsets: vesa
[ 719.463] (++) Using config file: "/root/xorg.conf.new"
[ 719.463] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 719.463] (==) Using system config directory "/usr/X11/share/X11/xorg.conf.d"
[ 719.464] (==) ServerLayout "X.org Configured"
[ 719.464] (**) |-->Screen "Screen0" (0)
[ 719.464] (**) | |-->Monitor "Monitor0"
[ 719.464] (**) | |-->Device "Card0"
[ 719.464] (**) |-->Screen "Screen1" (1)
[ 719.464] (**) | |-->Monitor "Monitor1"
[ 719.464] (**) | |-->Device "Card1"
[ 719.464] (**) |-->Input Device "Mouse0"
[ 719.464] (**) |-->Input Device "Keyboard0"
[ 719.464] (==) Automatically adding devices
[ 719.464] (==) Automatically enabling devices
[ 719.597] (**) FontPath set to:
/usr/X11/share/fonts/X11/misc/,
/usr/X11/share/fonts/X11/TTF/,
/usr/X11/share/fonts/X11/OTF/,
/usr/X11/share/fonts/X11/Type1/,
/usr/X11/share/fonts/X11/100dpi/,
/usr/X11/share/fonts/X11/75dpi/,
/usr/X11/share/fonts/X11/misc/,
/usr/X11/share/fonts/X11/TTF/,
/usr/X11/share/fonts/X11/OTF/,
/usr/X11/share/fonts/X11/Type1/,
/usr/X11/share/fonts/X11/100dpi/,
/usr/X11/share/fonts/X11/75dpi/
[ 719.597] (**) ModulePath set to "/usr/X11/lib/X11/modules"
[ 719.597] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 719.597] (WW) Disabling Mouse0
[ 719.597] (WW) Disabling Keyboard0
[ 719.597] (II) Loading sub module "fbdevhw"
[ 719.597] (II) LoadModule: "fbdevhw"
[ 719.597] (II) Loading /usr/X11/lib/X11/modules/libfbdevhw.so
[ 719.612] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 719.612] compiled for 1.11.2, module version = 0.0.2
[ 719.612] ABI class: X.Org Video Driver, version 11.0
[ 719.612] (II) Loading /usr/X11/lib/X11/modules/drivers/fbdev_drv.so
[ 719.612] (II) Loading /usr/X11/lib/X11/modules/libfbdevhw.so
[ 719.612] (EE) open /dev/fb0: No such file or directory
[ 719.612] (WW) Falling back to old probe method for fbdev
[ 719.612] (II) Loading /usr/X11/lib/X11/modules/drivers/vesa_drv.so
[ 719.612]
Backtrace:
[ 719.612] 0: Xorg (xorg_backtrace+0x37) [0x81bcb07]
[ 719.612] 1: Xorg (0x8048000+0x1784aa) [0x81c04aa]
[ 719.613] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb78b040c]
[ 719.613] Segmentation fault at address (nil)
[ 719.613]
Fatal server error:
[ 719.613] Caught signal 11 (Segmentation fault). Server aborting
[ 719.613]
[ 719.613]
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 719.614] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 719.614]

But Now our problem got solved, keyboard and mouse got enabled by disabling the hotplugging in /etc/X11/xorg.conf by issuing the following command,

Section "ServerFlags"
Option "AutoAddDevices" "false"
EndSection

Is there any problem will arise because of this disabling?

Regards,
Sugi@Phenix
Praki@Phenix

druuna 04-14-2012 07:55 AM

Hi,

Quote:

Originally Posted by pannet1
But Now our problem got solved

Does that mean the posted output isn't valid any more? And you are also able to start X?

Quote:

keyboard and mouse got enabled by disabling the hotplugging in /etc/X11/xorg.conf by issuing the following command,

Section "ServerFlags"
Option "AutoAddDevices" "false"
EndSection

Is there any problem will arise because of this disabling?
Not that I know of. Possible downside could be that certain things aren't picked up automatically.


All times are GMT -5. The time now is 08:35 AM.