Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.


  Search this Thread
Old 08-22-2004, 09:39 AM   #1
Registered: Sep 2003
Location: Winnipeg, MB, CA
Distribution: LinuxMint
Posts: 101

Rep: Reputation: 15
startx does nothing, yet X still works

Hey, I've tried both XFree86 AND Xorg, and they both give me the same error. It really isn't an error at all. They both compile, I can test them both. I see a grey screen and an 'x' for a mouse cursor that I can move around. It's all good. However, when I run 'startx" nothing happens. I can run xdm even. Does anybody know what's going on? Anybody have the same problem?
Old 08-22-2004, 11:00 AM   #2
Senior Member
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 48

read the whole thread!!
Old 08-23-2004, 02:28 AM   #3
Registered: Sep 2003
Location: Winnipeg, MB, CA
Distribution: LinuxMint
Posts: 101

Original Poster
Rep: Reputation: 15
Wow! I've finally figured it out! It's the most odd problem ever! In my /etc/sysconfig/network script, I mistyped HOSTNAME=system7 as HOSTENAME=system7. Thus the command 'hostname -f' would pause forever. That is the exact command run in the startx script. Goodness!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
X won't start at boot, startx works fine though TLV Debian 15 01-03-2007 08:10 AM
startx works for root but not users aldenfuchs Red Hat 3 04-01-2005 10:28 AM
Bug / Xwindows / startx : xinit works but startx crash Linux - Software 4 10-17-2004 08:06 AM
startx only works as root rbrasil Debian 3 12-10-2003 07:45 PM
Gnome works but not with startx command lil_critter99 Linux - Software 1 12-14-2001 05:05 AM

All times are GMT -5. The time now is 01:58 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration