LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 03-04-2003, 04:04 AM   #1
ajegilefajar
LQ Newbie
 
Registered: Mar 2003
Location: My home
Distribution: Slackware Mandrake RedHat
Posts: 3

Rep: Reputation: 0
spawning too fast disabled for 5 minutes


I'm learning to make a lfs with 2 disk boot/root

I'm made it with the kernel and lilo. It can boot up, ask me to
enter the root disk. But after the init starts, it print messages

ld 1 : spawning too fast disabled for 5 minutes
ld 2 : spawning too fast disabled for 5 minutes
No more processes in this run level

Then nothing's happen. It can't start the virtual console

What's wrong ??

Can anyone help me ? pleaze

I'm using The Linux Bootdisk howto by Tom Fawcett as reference
to make this lfs

inittab:
--------
id:2:initdefault
si::sysinit:/etc/rc
1:2345:respawn:/sbin/getty 9600 tty1
2:23:respawn:/sbin/getty 9600 tty2

Thank you
 
Old 03-05-2003, 09:26 AM   #2
Mik
Senior Member
 
Registered: Dec 2001
Location: The Netherlands
Distribution: Ubuntu
Posts: 1,316

Rep: Reputation: 46
Well the process you defined for 1 and 2 are dying constantly. Kinda hard to see why from only the information you provided. Here is a list of things you might want to check:

- Any descriptive error messages in the log files?
- Can the /sbin/getty executable be run properly (permissions + x bit)
- Can the /sbin/getty executable find and load any shared libraries it uses. Might wanna run 'ldd /sbin/getty' to find out.
- I use agetty and the parameters on that are the other way around, first tty1 then 9600. Might need to check the manpage on that.
- Is the /dev/tty1 present and has the proper permissions
- Is the /bin/login executable present and able to run

Well that's about all I can think of for now. Might want to read the man pages of getty and login to find out if you have everything setup properly for them to run.

Last edited by Mik; 03-05-2003 at 09:29 AM.
 
Old 03-06-2003, 02:28 AM   #3
ajegilefajar
LQ Newbie
 
Registered: Mar 2003
Location: My home
Distribution: Slackware Mandrake RedHat
Posts: 3

Original Poster
Rep: Reputation: 0
Thank you for your respon.

There are some question in my head from your answer.

Where can I find the error log because the disk I used for
the root can't be mounted ??

I made the root disk with the command
dd if=rootfs.gz of=/dev/fdo bs=1k

in this case rootfs.gz is the commpresed root I made for this purpose.

I already check all the library needed, and the permission,
but still .....

Oh yeah I forget, this is the exact message :
INIT: Entering runlevel: 2
INIT: Id "1" respawning too fast : disabled for 5 minutes
INIT: Id "2" respawning too fast : disabled for 5 minutes
INIT: no more processes left in this run level

PS: I don't use the PAM and NSS

Thanx
 
Old 03-06-2003, 09:26 AM   #4
Mik
Senior Member
 
Registered: Dec 2001
Location: The Netherlands
Distribution: Ubuntu
Posts: 1,316

Rep: Reputation: 46
Ok well you got me on the logging one, it's just something I always tell people to do.
If logging will go anywhere it's probably gonna be to a ramdisk anyways so you will lose it after a reboot.

Well anyways the next thing I would try doing is to change the first line to:
1:2345:respawn:/bin/bash </dev/tty1 >/dev/tty1
Or whatever other shell you are using.

That should get init to start a shell on tty1 without having to login.
You can try to start the other programs from there if it gets that far.
 
Old 03-25-2003, 08:45 PM   #5
ajegilefajar
LQ Newbie
 
Registered: Mar 2003
Location: My home
Distribution: Slackware Mandrake RedHat
Posts: 3

Original Poster
Rep: Reputation: 0
Sorry, I haven't had time to try it. Your answer is the same as the answer from my friends, they suggest me to change the getty with the shell, except without the "</dev/tty1 >/dev/tty1".

It works but there was an error message :
"#sh: can't access tty; job control turned off"

but anyway thx.
 
Old 03-09-2004, 05:05 AM   #6
rushtosrini
LQ Newbie
 
Registered: Mar 2004
Location: pollachi,india now in bangalore
Distribution: redhat
Posts: 1

Rep: Reputation: 0
spawning too fast

we can solve the problem by recreating the terminals
the command is

/dev/makedev /dev/tty1

same for all other terminals just put 2,3,4,5,6,7 instead of 1

then restart the system
srini
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RH9 INIT: ID "x" respawning too fast: disabled for 5 minutes valimare Linux - Newbie 4 02-16-2007 05:53 AM
INIT:Id "x" respawning too fast,disabled for 5 minutes gepo Linux - Newbie 1 05-29-2005 11:03 PM
respawning too fast: disabled for 5 minutes robr Fedora 2 04-05-2005 12:20 AM
INIT:Id "x" respawning too fast: disabled for 5 minutes problem satimis Red Hat 4 07-22-2004 07:03 AM
INIT: id 'x' respawning too fast: disabled for 5 minutes unitcoed Linux - Newbie 1 07-06-2003 08:35 PM


All times are GMT -5. The time now is 01:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration