LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   Solution for Mesa installation error (http://www.linuxquestions.org/questions/linux-from-scratch-13/solution-for-mesa-installation-error-937881/)

pannet1 04-03-2012 07:44 AM

Solution for Mesa installation error
 
Hi friends,
While Configuring Mesa package in BLFS i got the following error,
root@Laughlin [ ~/xc ]# cd Mesa-7.11.2/
root@Laughlin [ ~/xc/Mesa-7.11.2 ]# ls
acinclude.m4 aclocal.m4 bin common.py configs configure configure.ac docs include Makefile scons SConstruct src
root@Laughlin [ ~/xc/Mesa-7.11.2 ]# sed 's@FLAGS=\"-g@FLAGS=\"@' -i configure
root@Laughlin [ ~/xc/Mesa-7.11.2 ]# patch -Np1 -i ../MesaLib-7.11.2-llvm_3.0-1.patch &&
> patch -Np1 -i ../MesaLib-7.11.2-add_xdemos-2.patch &&
> ./configure $XORG_CONFIG --enable-xcb
patching file src/gallium/auxiliary/draw/draw_llvm.c
patching file src/gallium/auxiliary/draw/draw_private.h
patching file src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
patching file src/gallium/auxiliary/gallivm/lp_bld_type.c
patching file src/gallium/drivers/llvmpipe/lp_jit.c
patching file Makefile
patching file xdemos/glxgears.c
patching file xdemos/glxinfo.c
patching file xdemos/Makefile
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for gmake... no
checking for make... make
checking for python2... no
checking for python... python
checking for makedepend... /usr/X11/bin/makedepend
checking for sed... /bin/sed
checking for flex... /usr/bin/flex
checking for bison... /usr/bin/bison
checking for a BSD-compatible install... /usr/bin/install -c
checking if compiling with clang... no
checking whether gcc version is sufficient... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking whether gcc supports -fvisibility=hidden... yes
checking whether g++ supports -fvisibility=hidden... yes
checking whether to enable assembly... yes, x86
checking for gcc option to produce PIC... -fPIC
checking for dlopen... no
checking for dlopen in -ldl... yes
checking for posix_memalign... yes
checking pkg-config files for X11 are available... yes
checking for X11... yes
checking for GLPROTO... yes
checking for LIBDRM... yes
checking for DRI2PROTO... yes
checking for XF86VIDMODE... no
checking for DRIGL... yes
checking expat.h usability... yes
checking expat.h presence... yes
checking for expat.h... yes
checking for XML_ParserCreate in -lexpat... yes
checking for INTEL... yes
checking for NOUVEAU... yes
checking for LIBDRM_RADEON... yes
checking for LIBUDEV... yes
checking for XCB_DRI2... yes
checking for xcb_dri2_connect_alignment_pad in -lxcb-dri2... no
checking for GLW... yes
checking for llvm-config... no
configure: error: LLVM is required to build Gallium R300 on x86 and x86_64

The solution that is after installing llvm package(one of dependency of Mesa package) we need to logout from our LFS and then login again(using chroot)

druuna 04-03-2012 08:39 AM

Hi pannet1,
Quote:

Originally Posted by pannet1 (Post 4643557)
Hi friends,
While Configuring Mesa package in BLFS i got the following error,
root@Laughlin [ ~/xc ]# cd Mesa-7.11.2/
root@Laughlin [ ~/xc/Mesa-7.11.2 ]# ls
acinclude.m4 aclocal.m4 bin common.py configs configure configure.ac docs include Makefile scons SConstruct src
root@Laughlin [ ~/xc/Mesa-7.11.2 ]# sed 's@FLAGS=\"-g@FLAGS=\"@' -i configure
root@Laughlin [ ~/xc/Mesa-7.11.2 ]# patch -Np1 -i ../MesaLib-7.11.2-llvm_3.0-1.patch &&
> patch -Np1 -i ../MesaLib-7.11.2-add_xdemos-2.patch &&
> ./configure $XORG_CONFIG --enable-xcb
patching file src/gallium/auxiliary/draw/draw_llvm.c
patching file src/gallium/auxiliary/draw/draw_private.h
.
.
.checking for LIBUDEV... yes
checking for XCB_DRI2... yes
checking for xcb_dri2_connect_alignment_pad in -lxcb-dri2... no
checking for GLW... yes
checking for llvm-config... no
configure: error: LLVM is required to build Gallium R300 on x86 and x86_64

The solution that is after installing llvm package(one of dependency of Mesa package) we need to logout from our LFS and then login again(using chroot)

Nice to see you found a solution for this specific case (chrooted), but.... You shouldn't use the chrooted environment used during LFS in the first place. You should use the newly build LFS system and not use the host and chroot.

One of the problems you encounter when using the chrooted environment is that the host's kernel and /dev/ entries are used and _not_ those belonging to your freshly build LFS.

Hope this helps.


All times are GMT -5. The time now is 05:05 PM.