LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   problem with installing libxcb (http://www.linuxquestions.org/questions/linux-from-scratch-13/problem-with-installing-libxcb-916701/)

devilboy09 12-02-2011 01:41 AM

problem with installing libxcb
 
well, another error.i'm installing libxcb-1.7, i installed the dependencied and when i'm going to install the package itself, i'm getting this error when i want to make it:
http://pastebin.com/AifN04MB

as you can see i installed the python 3.2.i also tried to execute c_client.py manually, i got the same error.i think there's something wrong with python, right?

druuna 12-02-2011 02:23 AM

Hi,

First google hit: Subject: Re: Python 3.2.2

Solution: Install Python-2.7.2.

devilboy09 12-02-2011 02:33 AM

how should i uninstall python 3.2 ?

druuna 12-02-2011 03:08 AM

Hi,

You don't have to uninstall python 3, you can run them side by side.

Do make sure that after you install python 2 that /usr/bin/python points to /usr/bin/python2.7 and not /usr/bin/python3

devilboy09 12-02-2011 03:29 AM

i issued this command :
Code:

ln -s /usr/bin/python2.7 /usr/bin/python
and:
Code:

ls /usr/bin/python
0 lrwxrwxrwx 1 root root 18 Dec 2 12:54 /usr/bin/python -> /usr/bin/python2.7

and i issued the make command in libxcb directory :
Code:

Making all in src
make[1]:Entering directory '/sources/libxcb-1.7/src'
/bin/python ./c_client.py -p /usr/lib/python3.2/site-packages /usr/share/xcb/xproto.xml
    File "./c_client.py" line 1013
    except getopt.GetoptError, err:   
                              ^
syntaxError: invalid syntax
make[1]: *** [xproto.c] Error 1
make[1]: Leaving directory '/sources/libxcb-1.7/src'
make: *** [all-recursive] Error 1

it seems it's still refering to python 3

devilboy09 12-02-2011 03:36 AM

there was a file named python in /bin directory.i deleted it, linked the /usr/bin/python to /bin/python and problem solved.
thank you for your help.

druuna 12-02-2011 03:37 AM

Hi,

Am I right to assume you did _not_ remove the libxcb source directory and start fresh? Redo libxcb-1.7 from step 1 (unpacking the libxcb-1.7.tar.bz2 package).

PS: Removing your post after posting might lead to strange looking answers. Please leave the original text netx time and add to the bottom of the post.


All times are GMT -5. The time now is 04:53 PM.