LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 12-24-2012, 03:56 AM   #1
Lakhan Kumar
LQ Newbie
 
Registered: Nov 2012
Posts: 22

Rep: Reputation: Disabled
Problem in LFS 7.2 ---> 6.7. Linux-3.5.2 API Headers


I am getting this while doing "make headers_check"


/bin/sh: xargs: command not found
make[2]: *** [/sources/linux-3.5.2/usr/include/asm-generic/.check] Error 127
make[1]: *** [asm-generic] Error 2
make: *** [headers_check] Error 2

I am guessing i have done some thing wrong in my /tools back in chapter 5.
Can you guide where i have done mistake?

btw, mkproper also shown something like that, i just skipped that command.
 
Old 12-24-2012, 04:46 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Quote:
Originally Posted by Lakhan Kumar View Post
I am getting this while doing "make headers_check"


/bin/sh: xargs: command not found
make[2]: *** [/sources/linux-3.5.2/usr/include/asm-generic/.check] Error 127
make[1]: *** [asm-generic] Error 2
make: *** [headers_check] Error 2

I am guessing i have done some thing wrong in my /tools back in chapter 5.
Can you guide where i have done mistake?
Please post some more of the error as described here: 1.5. Help (1.5.3 in this case).

Quote:
btw, mkproper also shown something like that, i just skipped that command.
Don't just skip commands if they don't work. Fix the problem, then continue. Not doing so will make sure you end up with a none functioning LFS.

Also:
- Which host is being used and was it made fully compliant?
- Did you enter the chrooted environment correctly?
- Did you skip any other packages/steps?
 
Old 12-24-2012, 08:28 AM   #3
Keith Hedger
Member
 
Registered: Jun 2010
Location: Devon,UK
Distribution: Linux From Scratch, Slackware64,
Posts: 833

Rep: Reputation: 167Reputation: 167
xargs is part of the findutils package make sure you have installed it properly
 
Old 12-24-2012, 02:01 PM   #4
Lakhan Kumar
LQ Newbie
 
Registered: Nov 2012
Posts: 22

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Keith Hedger View Post
xargs is part of the findutils package make sure you have installed it properly
Thank you., after searching around i Found that. I reinstalled it But it was getting all mess, since going back in ch 5 and adjusting things creates more trouble. I am again going from start, and will make sure that keep the toolchains backup.
 
Old 12-24-2012, 02:05 PM   #5
Lakhan Kumar
LQ Newbie
 
Registered: Nov 2012
Posts: 22

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by druuna View Post
Please post some more of the error as described here: 1.5. Help (1.5.3 in this case).

Don't just skip commands if they don't work. Fix the problem, then continue. Not doing so will make sure you end up with a none functioning LFS.

Also:
- Which host is being used and was it made fully compliant?
- Did you enter the chrooted environment correctly?
- Did you skip any other packages/steps?
The host in ubuntu and its fine. I have done version check too. Nops, I didnt skipped the packages, but when we are in last of ch 5 dealing with packages like tar and findutils, we may do some error, and we find about them here ... i have rebuild tar, since it wasn't working while in chroot. But have been through ua comment that one should start from beginning so just doing that now. I think i made a mistake in findutils installation at the end of ch 5.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot install Linux API Headers in LFS 7.1 chapter 6.7 ffx77905 Linux From Scratch 18 07-02-2012 05:23 AM
[SOLVED] LFS 6.6 - chap6.7 - Linux-2.6.32.8 API Headers (problems in this step) ukiuki Linux From Scratch 15 05-23-2010 07:36 AM
LFS 6.7 Linux API Headers - make headers_check fails gmontjr Linux - Newbie 4 01-26-2009 01:56 AM
LFS newbie stuck in Linux API headers step 5.5 LFS book 6.3 Vxplus Linux From Scratch 2 11-10-2008 08:13 PM
Another LFS newb is stuck: Linux API headers won't install smoochie Linux From Scratch 19 06-13-2008 11:26 AM


All times are GMT -5. The time now is 02:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration