LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   problem in booting lfs even for the very first time (http://www.linuxquestions.org/questions/linux-from-scratch-13/problem-in-booting-lfs-even-for-the-very-first-time-643553/)

sureka 05-20-2008 01:13 PM

problem in booting lfs even for the very first time
 
well........I completed the installation of lfs in the same way as mentioned in the lfs book..except for the one in which kernel is to be configured..which i did after surfing the net..now while booting the system for the very first time it gives the following message...

VFS:cannot open root device "sda1" or unknown-block(2,0)
please append a correct "root="boot option;here are the available partitions:
Kernel panic - not syncing: VFS::Unable to mount root fs on unknown-block(2,0)






though i have checked it twice for the partition number of the bootable root partition....It is sda1..
I think it is unable to mount the root partition..
pls..look out for the solution.

rocket357 05-20-2008 01:29 PM

Quote:

Originally Posted by sureka (Post 3159326)
VFS:cannot open root device "sda1" or unknown-block(2,0)
please append a correct "root="boot option;here are the available partitions:
Kernel panic - not syncing: VFS::Unable to mount root fs on unknown-block(2,0)

First I'd double check to make sure grub sees the partitions the same way you do...is (hd2) = sda?

If those match up, did you compile your kernel with support for the filesystem that partition is using?

Quote:

Originally Posted by sureka (Post 3159326)
I think it is unable to mount the root partition..

That does indeed seem to be the problem here...heh.

jailbait 05-20-2008 01:31 PM

Do you have the correct device drivers resident in the kernel? If any of the drivers needed to access /dev/sda1 are loadable modules then the kernel will not be able to access /dev/sda1 to load the modules so it fails by being unable to access the / partition.

---------------------
Steve Stites

linux-geek 05-21-2008 02:42 PM

Check your partition type and compile it into the kernel, not as a module.
 
Hi.

The solution is to include into the kernel your partition type, not as a module, but as a part of the kernel itself. e.g. If you have a resiserfs partition as your boot partition check that the reiser filesystem is checked as an asterisk not as "M" nor empty in your kernel configuration, then save your choices, recompile it, install it and reboot.

That will solve your problem.

Enjoy!


All times are GMT -5. The time now is 08:22 PM.