LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   Problem compiling glibc (http://www.linuxquestions.org/questions/linux-from-scratch-13/problem-compiling-glibc-70978/)

Azmeen 07-08-2003 12:00 PM

Problem compiling glibc
 
While trying to compile glibc I encountered an error. The config.log file is as follows:
Code:

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:929: checking host system type
configure:1079: checking sysdep dirs
configure:1302: checking for a BSD compatible install
configure:1359: checking whether ln -s works
configure:1388: checking for pwd
configure:1427: checking build system type
configure:1455: checking for gcc
configure:1489: checking version of gcc
configure:1509: checking for gnumake
configure:1509: checking for gmake
configure:1509: checking for make
configure:1543: checking version of make
configure:1572: checking for gnumsgfmt
configure:1572: checking for gmsgfmt
configure:1572: checking for msgfmt
configure:1626: checking for makeinfo
configure:1660: checking version of makeinfo
configure:1680: checking for sed
configure:1714: checking version of sed
configure:1735: checking for autoconf
configure:1788: checking whether the C compiler (gcc  ) works
configure:1807: gcc -o conftest    conftest.c  1>&5
gcc: installation problem, cannot exec `/static/lib/gcc-lib/i686-pc-linux-gnu/3.2.1/../../../../i686-pc-linux-gnu/bin/as': No such file or directory
configure: failed program was:

#line 1802 "configure"
#include "confdefs.h"

main(){return(0);}
configure:1838: checking whether the C compiler (gcc  ) is a cross-compiler
configure:1850: checking whether we are using GNU C
configure:1859: gcc -E conftest.c
configure:1872: checking build system type
configure:1927: checking how to run the C preprocessor
configure:1948: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:1943:20: assert.h: No such file or directory
configure: failed program was:
#line 1942 "configure"
#include "confdefs.h"
#include <assert.h>
Syntax Error
configure:1965: gcc -E -traditional-cpp  conftest.c >/dev/null 2>conftest.out
configure:1960: assert.h: No such file or directory
configure: failed program was:
#line 1959 "configure"
#include "confdefs.h"
#include <assert.h>
Syntax Error
configure:1982: gcc -nologo -E  conftest.c >/dev/null 2>conftest.out
gcc: unrecognized option `-nologo'
configure:1977:20: assert.h: No such file or directory
configure: failed program was:
#line 1976 "configure"
#include "confdefs.h"
#include <assert.h>
Syntax Error
configure:2096: checking whether /static/lib/gcc-lib/i686-pc-linux-gnu/3.2.1/../../../../i686-pc-linux-gnu/bin/as is GNU as
configure:2115: checking whether /static/lib/gcc-lib/i686-pc-linux-gnu/3.2.1/../../../../i686-pc-linux-gnu/bin/ld is GNU ld
configure:2135: checking for mig
configure:2227: checking whether ranlib is necessary
configure:2261: checking LD_LIBRARY_PATH variable
configure:2279: checking whether GCC supports -static-libgcc
configure:2296: checking for bash
configure:2392: checking for gawk
configure:2424: checking for perl
configure:2464: checking for install-info
configure:2499: checking for old Debian install-info
configure:2534: checking for bison
configure:2569: checking for signed size_t type
configure:2593: checking for libc-friendly stddef.h
configure:2613: gcc -c  conftest.c 1>&5
gcc: installation problem, cannot exec `/static/lib/gcc-lib/i686-pc-linux-gnu/3.2.1/../../../../i686-pc-linux-gnu/bin/as': No such file or directory
configure: failed program was:
#line 2598 "configure"
#include "confdefs.h"
#define __need_size_t
#define __need_wchar_t
#include <stddef.h>
#define __need_NULL
#include <stddef.h>
int main() {
size_t size; wchar_t wchar;
#ifdef offsetof
#error stddef.h ignored __need_*
#endif
if (&size == NULL || &wchar == NULL) abort ();
; return 0; }
configure:2632: checking whether we need to use -P to assemble .S files
configure:2655: checking whether .text pseudo-op must be used
configure:2676: checking for assembler global-symbol directive

The thing is I can't execute the /static/i686-pc-linux-gnu/bin/as eventhough the ownership has already been set to 0:0 as instructed.

Can the knowledgable please assist.

Thank you! :)

citro 07-08-2003 02:01 PM

Well, as I can see it here, your problem ist not the ownership of that file, your problem is that the file doesn't exist (at least not in the directory /static/i686-pc-linux-gnu/bin/ )

Try this:
check /static/bin and /bin and /usr/bin if as is in there and then link it to /static/i686...
for example, if you found it in /usr/bin (where I think it should be):

ln -s /usr/bin/as /static/-i686-pc-linux-gnu/bin/as

and then try configuring glibc again.

CU citro

Azmeen 07-08-2003 08:09 PM

Quote:

Originally posted by citro
Well, as I can see it here, your problem ist not the ownership of that file, your problem is that the file doesn't exist (at least not in the directory /static/i686-pc-linux-gnu/bin/ )

Try this:
check /static/bin and /bin and /usr/bin if as is in there and then link it to /static/i686...
for example, if you found it in /usr/bin (where I think it should be):

ln -s /usr/bin/as /static/-i686-pc-linux-gnu/bin/as

and then try configuring glibc again.

CU citro

Hi citro,

Thanks for responding... Actually that's the problem. The files are there! And the permissions are correct and executable flag is set for the files there.

Another funny thing is that I can execute the files as "real root" but not the "pseudo root" in the LFS system!

I'll try the linking when I get back home... I'm currently at work now.

Again, thanks for the feedback. Much appreciated :)
If i do a ./as

citro 07-09-2003 06:11 AM

Azmeen:
you opened another thread with problems compiling the 'binutils' package, right?
guess what, the 'as' program is part of the 'binutils' package...so try to install your binutils correctly and then try compiling glibc again.
CU citro

Azmeen 07-09-2003 11:48 AM

I've restarted from scratch again... hopefully this time it'll work out. Wish me luck!


All times are GMT -5. The time now is 11:19 PM.