LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 12-20-2010, 08:47 AM   #1
prakashsince92
Member
 
Registered: Jan 2010
Distribution: Ubuntu 10.10 Maverick
Posts: 37

Rep: Reputation: 0
Unhappy Problem after booting the LFS 6.7 system


Hi,

I have completed the LFS-build and booted into the new system,
But i get this serious of messages which is recurring again and again

Code:
[71. 2744257] PPS event at 429474556
[72. some number] PPS event at somenumber
     "             "
  
     "             "
This goes on and on.
If i keep pressing the Enter(return) key I can see the login prompt , and even after entering into the bash shell..these messages continue. Everytime the Serial no at the left most end increases and the number at the right most end increases.

Plese help me solve this issue:
Thanks for any valuable comments

Last edited by prakashsince92; 12-20-2010 at 08:48 AM.
 
Old 12-20-2010, 10:26 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi,

The following will probably suppress the errors being shown in your terminal, which makes working on your new lfs system a bit easier.

Open the following file (as root): /etc/rc.d/init.d/sysklogd

Change this line:
loadproc klogd
To:
loadproc klogd -c 3

Restart sysklod (as root): /etc/rc.d/init.d/sysklogd restart

It depends a bit on the severity of the error, but the -c 3 flag tells klogd to only send errors and more severe to the terminal. I suspect PPS event at to be a warning or less severe.

After that you do need to have a look at the PPS event messages that keeps showing up (I never seen these before). A message shouldn't keep reappearing that often. Have a look at the output of the dmesg | more command and also the logs in /var/log.

Without any information its kinda hard to point you in a specific direction, but I'm assuming you have PPS enabled in you kernel config. If you don't need it, disable it.

Hope this helps.

Last edited by druuna; 12-20-2010 at 10:28 AM.
 
1 members found this post helpful.
Old 12-20-2010, 12:15 PM   #3
prakashsince92
Member
 
Registered: Jan 2010
Distribution: Ubuntu 10.10 Maverick
Posts: 37

Original Poster
Rep: Reputation: 0
Smile

Hi druuna,
Quote:
Open the following file (as root): /etc/rc.d/init.d/sysklogd
Change this line:
loadproc klogd
To:
loadproc klogd -c 3
Restart sysklod (as root): /etc/rc.d/init.d/sysklogd restart
After editing as above from the chrooted environment ,i rebooted to the lfs and the PPA messages have now vanished. WOW.. Thanks a lot !!

But there is a certain lag between the pace at which i type the keys and the pace at which it appears in the shell.

Quote:
Without any information its kinda hard to point you in a specific direction, but I'm assuming you have PPS enabled in you kernel config. If you don't need it, disable it.

Please tell me how to disable them !

And why do such messages appear in the shell?

Thanks you very much druuna.
 
Old 12-20-2010, 12:50 PM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Quote:
Originally Posted by prakashsince92 View Post
After editing as above from the chrooted environment ,i rebooted to the lfs and the PPA messages have now vanished. WOW.. Thanks a lot !!

But there is a certain lag between the pace at which i type the keys and the pace at which it appears in the shell.
Your lfs system is still generating a lot of PPS event at ... messages, the creation and logging of these message are causing the lag in response.

Quote:
Please tell me how to disable them !
Like I said in my previous relpy: I'm assuming it is a kernel setting. With that in mind:
You need to change the kernel settings and re-compile the kernel (As you did here: 8.3. Linux-2.6.35.4).

When you are in the kernel configuration menu select the Device Drivers section, look for a PPS entry and make sure none of the entries are checked (be it * or M). Exit, save changes and continue with the make and following steps.

Quote:
And why do such messages appear in the shell?
klogd sends these messages to the shell/terminal. Without the -c NUMBER option it sends more then you want (my opinion). Adding the -c 3 limits what is send to the terminal. 3 sets the log level to Error (or higher; also 2, 1 and 0).
BTW: There are 8 log levels:
0 system is unusable
1 action must be taken immediately
2 critical conditions
3 error conditions
4 warning conditions
5 normal but significant condition
6 informational
7 debug-level messages

Hope this helps.
 
1 members found this post helpful.
Old 12-20-2010, 01:10 PM   #5
prakashsince92
Member
 
Registered: Jan 2010
Distribution: Ubuntu 10.10 Maverick
Posts: 37

Original Poster
Rep: Reputation: 0
Hi,

Quote:
Like I said in my previous relpy: I'm assuming it is a kernel setting. With that in mind:
You need to change the kernel settings and re-compile the kernel (As you did here: 8.3. Linux-2.6.35.4).
But I already have my kernel installed right.So, is there a way to uninstall it OR is it enough if I compile the kernel once again.
 
Old 12-20-2010, 01:25 PM   #6
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi,

The kernel you previously compiled and some other files (System.map and .config) are placed in: /boot/.
When you set up grub you told grub where to look for the kernel (something like this: linux /boot/vmlinux-2.6.35.4-lfs-6.7 root=/dev/sda2 ro).

The easiest way is to replace the current kernel (all 3: vmlinux-2.6.35.4-lfs-6.7, System.map and config) with new ones.

I would first make a backup of the 3 files in /boot, then recompile the kernel and replace them with the newly compiled/created files. On the next boot the new kernel will be used. If the system doesn't boot you can always edit/retry using the chrooted environment.

Hope this helps.
 
1 members found this post helpful.
Old 12-20-2010, 01:37 PM   #7
prakashsince92
Member
 
Registered: Jan 2010
Distribution: Ubuntu 10.10 Maverick
Posts: 37

Original Poster
Rep: Reputation: 0
Hi,


So, now i should backup the three files in /boot and enter the chrooted environment and compile the kernel again.Am I in the right direction?


Quote:
When you are in the kernel configuration menu select the Device Drivers section, look for a PPS entry and make sure none of the entries are checked (be it * or M). Exit, save changes and continue with the make and following steps.
Please tell me how to look for a PPS entry and what is "(be it * or M)".
 
Old 12-20-2010, 01:51 PM   #8
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi,
Quote:
Originally Posted by prakashsince92 View Post
So, now i should backup the three files in /boot and enter the chrooted environment and compile the kernel again.
Correct.

Quote:
Please tell me how to look for a PPS entry
I already did (post #4). Maybe this does a better job

- After this step: make LANG=<host_LANG_value> LC_ALL= menuconfig you get a menu,
- Look for and enter the Device Drivers section,
- Look for and enter PPS section,
- If there is a * or M before the first entry (there could be more, but it could also be just one entry), it tells you this device is activated. Deactivate it (press space-bar until * and M are gone),

Quote:
and what is "(be it * or M)".
The * tells you that the option is part of the kernel (compiled in), the M tells you that this options is compiled as a module.

Hope this helps.
 
1 members found this post helpful.
Old 12-22-2010, 01:47 AM   #9
prakashsince92
Member
 
Registered: Jan 2010
Distribution: Ubuntu 10.10 Maverick
Posts: 37

Original Poster
Rep: Reputation: 0
Smile

Hi druuna,

Re-compiling the kernel did the task.My LFS system is up and running with out any lag now

Thanks a lot,

One more question:

The terminal looks like this

Code:
-bash-4.1#
how do I change it to

Code:
root@something#
Thanks for any comments
 
Old 12-22-2010, 02:19 AM   #10
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi,
Quote:
Originally Posted by prakashsince92 View Post
Re-compiling the kernel did the task.My LFS system is up and running with out any lag now
Thanks a lot,
Congrats!! And : You're welcome

Quote:
One more question: The terminal looks like this

Code:
-bash-4.1#
how do I change it to

Code:
root@something#
After finishing LFS you have a very basic Linux system. You still need to do some stuff to make it more usable/workable. Most of that is done in BLFS.

Have a look at the BLFS - After LFS Configuration Issues, especially this chapter: The Bash Shell Startup Files.

That chapter will take care of your question (and a lot more....).

Hope this helps.
 
Old 12-22-2010, 02:35 AM   #11
prakashsince92
Member
 
Registered: Jan 2010
Distribution: Ubuntu 10.10 Maverick
Posts: 37

Original Poster
Rep: Reputation: 0
All right.

Thank you for your help throughout my LFS journey

Looking forward to BLFS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] problems booting lfs system frieza Linux From Scratch 4 09-07-2010 11:53 PM
problem in booting lfs even for the very first time sureka Linux From Scratch 3 05-21-2008 01:42 PM
Problem In Booting Lfs neshuagarwal1909 Linux From Scratch 1 05-11-2008 08:11 AM
LFS Booting problem jgmyshko Linux - Laptop and Netbook 1 09-02-2006 07:07 PM
Problem on booting LFS LiveCD satimis Linux From Scratch 4 10-29-2005 08:42 AM


All times are GMT -5. The time now is 02:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration