Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.


  Search this Thread
Old 01-08-2008, 03:56 AM   #1
LQ Newbie
Registered: Jan 2008
Distribution: Slackware 14.2
Posts: 13

Rep: Reputation: 0
No rule to make bootstrap error - LFS LiveCD


I am facing a problem when I issue 'make bootstrap' command

Host system : LFS LiveCD x86-6.3-r2160
Book: Linux from Scratch 6.3
Chapter 5.4 GCC-4.1.2 Pass 1

Hard disk partitioned as follows
/dev/hda1 - 20GB Fat32 partition FreeDOS
/dev/hda2 - 19GB Ext3 partition Linux
/dev/hda3 - 1GB swap partition

First step goes fine without errors
CC="gcc -B/usr/bin/" ../gcc-4.1.2/configure --prefix=/tools \
--with-local-prefix=/tools --disable-nls --enable-shared \

Next step I issue the command 'make bootstrap'

...some messages scroll past then at the ending I get

Bootstrapping compiler
make[1]:Entering directory '/mnt/lfs/gcc-build/gcc-4.1.2/gcc'
make[1]:***No rule to make target 'bootstrap'. Stop
make[1]:Leaving directory '/mnt/lfs/gcc-build/gcc-4.1.2/gcc'
make: ***[bootstrap] Error2

Can someone please explain what is causing the problem ?

Binutils-2.17 Pass 1 went well without errors.

I am new to Linux but have installed and used Fedora and
CentOS in the past.

Also how do I capture the scrolling output during compilation
to a file ?

Old 01-08-2008, 11:06 PM   #2
Registered: May 2006
Location: UK
Distribution: Debian
Posts: 448

Rep: Reputation: 37
The directories are wrong and the resulting permission issues may be causing your problem. Remove any gcc directories and start 5.4 again.

Extract gcc-4.1.2.tar.bz2 INSIDE the sources directory. You should now have the directory /mnt/lfs/sources/gcc-4.1.2

The book expects you to run "mkdir -v ../gcc-build" from inside /mnt/lfs/sources/gcc-4.1.2. So now you should now have the directory /mnt/lfs/sources/gcc-build. cd to that directory and try the configure/make commands again. You can check the current directory at any time by using "pwd".
Old 01-09-2008, 12:59 AM   #3
LQ Newbie
Registered: Jan 2008
Distribution: Slackware 14.2
Posts: 13

Original Poster
Rep: Reputation: 0
You are correct, Daws. I re-read the instructions and then realized my error. After I made the correction the build went ok. I'm too used to Windoze point&click I suppose.
Old 02-20-2008, 09:01 PM   #4
Registered: Aug 2006
Location: Shen Zhen
Distribution: Ubuntu 10.04
Posts: 198

Rep: Reputation: 33
I encounter the same problem when compile GCC, and later fix it by using "lfs" account. I think LFS documents should better add a note there in order to make reader more clearly.
Old 02-21-2008, 10:48 AM   #5
LQ Newbie
Registered: Jan 2007
Posts: 16

Rep: Reputation: 0
Does that mean that it's going to come back to bite me in the bum that I just ran it as make, with no bootstrap argument?

Once I compiled gcc without bootstrap everything seemed to proceed ok.
Old 03-24-2008, 01:14 AM   #6
Registered: Nov 2007
Location: Seattle, WA
Distribution: LFS
Posts: 36

Rep: Reputation: 16
Same prob

I had the same problem, thanks for your help DAWS! -DN
Old 08-06-2008, 10:27 AM   #7
LQ Newbie
Registered: Jul 2008
Posts: 1

Rep: Reputation: 0
thanks DAWS

same problem, thanks for your help DAWS!
Old 09-18-2008, 08:51 PM   #8
Registered: Apr 2007
Location: BKK, Thailand
Distribution: Gentoo 10.1
Posts: 112
Blog Entries: 2

Rep: Reputation: 15
Originally Posted by PhillipHuang View Post
I encounter the same problem when compile GCC, and later fix it by using "lfs" account. I think LFS documents should better add a note there in order to make reader more clearly.
Agreed... That page screw-up my head for a couple of month, till see this topic
Old 02-08-2012, 02:31 PM   #9
LQ Newbie
Registered: Feb 2012
Posts: 2

Rep: Reputation: Disabled
Uhh, well heck.

I'm having the same problem with gcc erroring out while trying to make bootstrap. I did avoid the two pitfalls mentioned. I was logged in as lfs, and untared gcc-4.1.2.tar.bz2 inside the $LFS/sources directory before making a the new $LFS/sources/gcc-build directory then issuing the commands from within gcc-build. I have tried several times, including scrapping and starting over. I also tried just issuing the "make" command, but no luck there either. I'm not sure how to post the output of the commands, but here is briefly that last lines I could see:

In file included from /usr/include/features.h:346,
from /usr/include/stdio.h:28,
from ../../gcc-4.1.2/gcc/tsystem.h:90,
from ../../gcc-4.1.2/gcc/crtstuff.c:68:
/usr/include/gnu/stubs.h:7:27: error: gnu/stubs-32.h: No such file or directory
make[4]: *** [32/crtbegin.o] Error 1
make[4]: Leaving directory '/mnt/lfs/sources/gcc-build/gcc'
make[3]: *** [extra32] Error 2
make[3]: Leaving directory '/mnt/lfs/sources/gcc-build/gcc'
make[2]: *** [stmp-multilib] Error 2
make[2]: Leaving directory '/mnt/lfs/sources/gcc-build/gcc'
make[1]: *** [stage1_build] Error 2
make[1]: Leaving directory '/mnt/lfs/sources/gcc-build/gcc'
make: *** [bootstrap] Error 2

I know version 7.0 is out, but its not supported by the liveCD, and I mainly want to use this build as a training platform to learn more about how linux works. Any help would be great, thanks so much!
Old 02-08-2012, 03:15 PM   #10
Senior Member
Registered: Jan 2011
Distribution: /LFS/Centos6.3/Debian
Posts: 2,191
Blog Entries: 1

Rep: Reputation: 327Reputation: 327Reputation: 327Reputation: 327

What files do you have in /usr/include/gnu.

You can build LFS 7 using the cd just get the packages listed in the book use the cd as host
Old 02-09-2012, 03:04 AM   #11
LQ Veteran
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389
Hi scoobysmith44,

Looking at this error:
/usr/include/gnu/stubs.h:7:27: error: gnu/stubs-32.h: No such file or directory
You seem to be missing the glibc development package (32 bits!!) on your host.

Hope this helps.

BTW: You posted in an old thread that isn't really related to your problem and it deals with an old LFS version compared to yours. Please post a new thread next time you encounter a problem.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
automake error: no rule to make target all jwstric2 Programming 2 10-18-2011 02:48 PM
lopster v1.2.2 make error: No rule to make target `m4/glibc21.m4' Kropotkin Fedora 0 10-31-2004 11:19 AM
Error: *** No rule to make target 'all'. Stop aa2bi Linux - Newbie 6 06-08-2004 12:55 PM
GCC first build for LFS, bootstrap error Blibblob Linux From Scratch 8 01-07-2004 05:50 PM
EGCS 1.1.2 make bootstrap error natto34 Linux - Software 2 06-26-2003 06:04 AM

All times are GMT -5. The time now is 01:09 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration