LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   nasty little error with glbc :( (http://www.linuxquestions.org/questions/linux-from-scratch-13/nasty-little-error-with-glbc-802696/)

March_26 04-18-2010 10:52 AM

nasty little error with glbc :(
 
I am using version 6.6 of LFS, and am on chapter 5.7 where i have to compile glbc.
the problem comes after i enter the command to prepare glbc for compliation. I get this!

Code:

checking whether __attribute__((visibility())) is supported... no
configure: error: compiler support for visibility attribute is required

i checked the host requirements and found nothing unusual... everything seems, at least to a noob, to be fine.

how can I fix this?

crts 04-18-2010 11:56 AM

Quote:

Originally Posted by March_26 (Post 3939432)
I am using version 6.6 of LFS, and am on chapter 5.7 where i have to compile glbc.
the problem comes after i enter the command to prepare glbc for compliation. I get this!

Code:

checking whether __attribute__((visibility())) is supported... no
configure: error: compiler support for visibility attribute is required

i checked the host requirements and found nothing unusual... everything seems, at least to a noob, to be fine.

how can I fix this?

Hi,

what host system are you using? Please post the commands that you executed before the error occurred. We also need a little more of the output.
As for the requirements, make sure that every program is installed with it's recommended minimal version, e.g. by executing
Code:

gcc --version
bash --version
...

Do this for all programs listed in the host system requirements section.

March_26 04-19-2010 07:19 PM

Hey CRTS, thanks for the reply.
i expected it to take much longer :D

I'm using Ubuntu 9.10 as host, for lack of any specific suggestions from anyone making an LFS.
this is my first lfs, if it isn't apparent enough already :)

before I got the error i executed these commands:
Code:

case `uname -m` in
  i?86) echo "CFLAGS += -march=i486 -mtune=native" > configparms ;;
esac

^^ this one was ok
Code:

../glibc-2.11.1/configure --prefix=/tools \
    --host=$LFS_TGT --build=$(../glibc-2.11.1/scripts/config.guess) \
    --disable-profile --enable-add-ons \
    --enable-kernel=2.6.18 --with-headers=/tools/include \
    libc_cv_forced_unwind=yes libc_cv_c_cleanup=yes

^^ this is the code that gave me the error
and the output was (not the whole thing)
Code:

checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking for i686-lfs-linux-gnu-ranlib... no
checking for ranlib... ranlib
configure: WARNING: using cross tools not prefixed with host triplet
checking whether as is GNU as... yes
checking whether ld is GNU ld... yes
checking for as... as
checking version of as... 2.20, ok
checking for ld... ld
checking version of ld... 2.20, ok
checking for pwd... /bin/pwd
checking for i686-lfs-linux-gnu-gcc... (cached) i686-lfs-linux-gnu-gcc
checking version of i686-lfs-linux-gnu-gcc... 4.4.3, ok
checking for gnumake... no
checking for gmake... no
checking for make... make
checking version of make... 3.81, ok
checking for gnumsgfmt... no
checking for gmsgfmt... no
checking for msgfmt... no
checking for makeinfo... no
checking for sed... sed
checking version of sed... 4.2.1, ok
checking for autoconf... no
configure: WARNING:
*** These auxiliary programs are missing or incompatible versions: msgfmt makeinfo autoconf
*** some features will be disabled.
*** Check the INSTALL file for required versions.
checking whether ranlib is necessary... no
checking LD_LIBRARY_PATH variable... ok
checking whether GCC supports -static-libgcc... -static-libgcc
checking for bash... /bin/bash
checking for gawk... gawk
checking for perl... /usr/bin/perl
checking for install-info... /usr/bin/install-info
checking for bison... no
checking for signed size_t type... no
checking for libc-friendly stddef.h... yes
checking whether we need to use -P to assemble .S files... no
checking whether .text pseudo-op must be used... yes
checking for assembler global-symbol directive... .globl
checking for .set assembler directive... no
checking for assembler .type directive prefix... @
checking for assembler gnu_unique_object symbol type... yes
checking for .symver assembler directive... yes
checking for ld --version-script... no
*** WARNING: You should not compile GNU libc without versioning. Not using
*** versioning will introduce incompatibilities so that old binaries
*** will not run anymore.
*** For versioning you need recent binutils (binutils-2.8.1.0.23 or newer).
checking for .previous assembler directive... yes
checking for .protected and .hidden assembler directive... yes
checking whether __attribute__((visibility())) is supported... no
configure: error: compiler support for visibility attribute is required

so yeah... im gonna go back and do what you said about the prereqs though, and see what's up.
thanks

EDIT: checked all the host requirements, all good
PLEASE HELP!

March_26 04-28-2010 04:44 PM

Haven't gotten help.
I really wanna fix this before i quit and move to archlinux or something.
any other details necessary?

druuna 04-29-2010 01:43 AM

Hi,

Quote:

EDIT: checked all the host requirements, all good
PLEASE HELP!
What did you do to meet these requirements?? Out of the box Ubuntu isn't suitable as host for LFS.

My advise: Use the LFS liveCD instead.

Hope this helps.

titinail 05-17-2010 05:00 PM

I think in chapter 5 when binutils-pass1 and gcc-pass1 is compiled there is a misconfiguration with the ld.

You could try to force gcc to prefer the linker from the host in /usr/bin.

Try this in pass 1 of binutils
Code:

CC="gcc -B/usr/bin/" ../binutils-2.20.1/configure \
--target=$LFS_TGT --prefix=/tools \
--disable-nls --disable-werror

make

make install

and this in pass 1 of gcc
Code:

CC="gcc -B/usr/bin/" ../gcc-4.5.0/configure \
--target=$LFS_TGT --prefix=/tools \
--disable-nls --disable-shared --disable-multilib \
--disable-decimal-float --disable-threads \
--disable-libmudflap --disable-libssp \
--disable-libgomp --enable-languages=c

make bootstrap

make install



All times are GMT -5. The time now is 04:24 PM.